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Introduction 

IRIS (Image Retention and Information System) is an image retrieval system that provides a 
complete photographic record of all transactions and surveillance activity. The IRIS system is 
composed of two primary components: 

IRIS DVS Server (hardware at remote location) 

IRIS DVS Software (software at remote location) 

The IRIS DVS Server (DVS Server) is the primary component of the IRIS system. As a digital 
video server, the DVS Server records all transaction and surveillance information at the 
remote location. Image information, along with supporting data files, may be saved at the 
remote site for later retrieval. In addition to capturing image information, the DVS Server 
monitors the current health and status of the associated cameras and video equipment. 

The IRIS system also includes a software application that works with the DVS Software to 
retrieve images stored on the DVS Server and enables the user to retrieve an image from 
any camera, at any time, from the remote environment.  This software application is referred 
to as: 

IRIS Inquiry (viewing and retrieval software) 

The IRIS system also includes several support components: 

Service (Status) Manager - Monitors the status of multiple remote DVS Server sites. 

Access Manager (DNS) – Used to manage user IDs and passwords on a system-
wide basis as well as the authorized user lists for both DVS and RNS server sites. 



IRIS  STATUS MANAGER 

001.09  7 IRIS  Control  Sui te  

To provide a secure system, the IRIS system supports the following levels of user access.  

 At the basic USER access level, the system allows only image search and 
retrieval.  

 At the SYSOP access level, IRIS Inquiry allows the user to perform all of the 
basic USER access functions.  The SYSOP level is also used for the IRIS 
Access Manager to maintain access and configuration rights to the Remote 
Name Server (RNS), IRIS Status to monitor the operational status of the 
system. 

 At the FACTORY access level the user is allowed to search and retrieve 
images as well as generate status and activity logs, set remote location date 
and time, and perform additional remote setup and maintenance functions.  
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IRIS Service (Status) Manager 
IRIS Service (Status) Manager is a support component, providing status monitoring on a 
group or system-wide level. This feature provides an easy method of automatically monitoring 
the complete operational status of a large number of remote IRIS systems from a single 
location and displaying the current system-wide status. This application automates the 
system-checking function by contacting each remote system and retrieving system health 
indicators. This application allows the SYSOP to perform the following functions: 

 Maintain IRIS DVS Server sites. 

 Group Sites for Monitoring 

 Set Preferences for Status Display 

 Configure Status Update Modes 

 Globally Update Time and Date for all Remote Sites 

 Send Data to Individual or All Remote Sites 

 Modify, Print, and/or Save Status Information 

 Export Status Information for use in Commercial Database Software such as 
Excel and Access 
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Logon to IRIS Status 
In order to access the IRIS Status application, an 
authorized user must click the Status icon that 
appears on the desktop to start the program. This 
application provides access to the remote IRIS 
system, using the SYSOP access level. When this 
application attaches to a remote IRIS site, the remote 
site will authenticate the remote user for valid access. 
Therefore, it is necessary that the support programs 
use a valid User ID and Password that is permitted in 
all remote sites.  

The Remote System Access dialog box is used to 
enter User ID and Password to enable the SYSOP 
user to access data from the remote site.  

1. Click the IRIS Status icon from the desktop.  

2. Select Config > Access from the main menu. 

3. Enter the User ID and Password (to be used for all sites) and click OK.  The remote site 
will use the Authorized User List to authenticate the user for valid access.   

Typical Setup Procedure for IRIS Status 
Although there are numerous functions and capabilities for the IRIS Status application, the 
basic procedural workflow to monitor and view the operational status for a group of remote 
IRIS systems is as follows:   

1. Select Config > Group and select the default group “Demo”.  Refer to page 15 – 19 
regarding site and group maintenance. 

2. Select Config > Sites and add DVS location to the monitored list.  Refer to page 19 
regarding adding sites to each group. 

All Passwords are 
case sensitive. 
Example 
“Password” is NOT 
the same as 
“PASSWORD”. 

The User ID and 
Password MUST 
BE SET prior to 
using the IRIS 
Status application 
to enable the 
application to 
successfully 
retrieve data from 
the remote sites. 
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3. Select Config > Access and enter a User ID and Password.  When this application 
attaches to a remote IRIS site, the remote site will authenticate the remote user for valid 
access. Therefore, it is necessary that this program use a valid User ID and Password 
that is permitted in all remote sites.  The suggested User ID is “SYSOP”. Refer to page 9 
for instructions regarding remote site access. 

4. Select Preferences > Show Normal and Show Error to allow the system to show all 
sites.  Refer to page 20 regarding preferences. 

5. Select Function > Get Status from Remotes to view the status from the selected DVS 
Group.  There are numerous options under the Function menu item.  Refer to pages 21 - 
32 regarding these options.   

  

User Interface 

The IRIS Status application has been designed with a familiar and user-friendly work 
environment. The user may easily enter and access data using familiar data controls such as 
text boxes, drop-down selection boxes, radio buttons, selection lists, and check boxes.   

Application Window 

The status table, system prompts, and all dialog boxes will be displayed within the application 
window.   
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Title Bar 

While connected, the name of the site group will appear in the title bar of the main IRIS 
Status window.  

 

Column Headings 

Horizontal Menu Bar 

Application Window 

Title Bar 

Status Bar 

The column width of each 
column  may be resized  by 
clicking the column divider to 
display the directional arrow, 
and then dragging the column 
boundary left or right.   
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Horizontal Menu Bar 

The IRIS Status main menu items are included on a horizontal menu bar that appears across 
the top of the application window. 

MENU ITEM DESCRIPTION OF FUNCTIONS 

CONFIG Access - Displays the Logon dialog box and allows the user to enter their 

user name and Password and access IRIS Status. 

Sites – Used to add, edit or delete remote sites in the selected Group. 

Group – Selects the active group. This allows the user to group remote sites 

by region, state, organization, or other parameter. 

PREFERENCES Sort – Allows the user to specify the sort order by none, ascending or 

descending and select a specific column from the status output to sort on. 

Show Normal Sites  - If enabled, displays all sites within the current group 

that do not have errors. 

Show Error Sites – If enabled, displays all sites within the current group that 

have errors. 

To Display all sites, enable both options. 

Delete Old Status – Determines what to do with old status when a new status 

request from a site fails. If enabled, and a status request from a site fails, the 
program will delete the old status and replace it with the failure modes “Site 
Not Responding”. If enabled, and a status request from a site fails, the 
program will continue to display the last status information received from the 
site. It is the responsibility of the operator to note that the date and time stamp 
on the site status is old. 
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MENU ITEM DESCRIPTION OF FUNCTIONS 

FUNCTION  Get Status from Remotes – Provides an On Demand status update from the 

remote locations. Allows the user to select a single location or all locations for this 
process.     

Get Detail Status Report – Displays a detailed status report from the remote 

locations.  Allows the user to select a single location or all locations for this 
process. 

Set Remote Time and Date Information – Updates the system date and time 

information for the remote locations.   

Send Remote Files – Sends a file to an individual location or all locations at 

once.   

Restore Deleted Status – When clicked, restores the last displayed status for 

sites that are currently not responding. This option is normally used only if 
“Delete Old Status” in the preferences section is enabled. 

Set Periodic Updates - Configures update frequency for the status display.   

Export File – Opens a standard Windows file box and allows the user to locate 
and select the file to be exported. Export Format options allow the user to filter 

the file and include/exclude status columns and set the delimiter to be used.  

Export Format – Allows the user to select fields of the status report to be 

exported to a remote location.  Provides the capability to specify a comma, tab, or 
semi-colon delimiter. 

Print - Opens a default text editor (generally Notepad) and allows the user to 

modify the status information.   The file may be saved or printed using the default 
editor Save and Print options.  Print Format options are also available to filter the 

status report.   

Print Format  - Allows the user to select fields of the status report to be printed.   

Exit – Closes IRIS Status 
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Column Headings 

When the IRIS Status program is active, the current site status is displayed in the application 
window.  The system will display the following information for all sites: 

Status ICON Icon to quickly show site status 

Site Name Name of remote site 

Update Time Date and Time of last update of status from remote site 

System Status Detailed description of errors reported or system health. 

System Time Date and Time from remote site at time of last update. 

S/W Version Remote operating software version 

S/N  Unit serial number at remote site 

Resize Column Width 

The column width may be adjusted by clicking the right 
boundary of the column to display the directional arrow.  
Once the directional arrow is displayed, the user may 
drag the column boundary to the left or right. 

Status Bar 
A brief description of each function will be displayed in the status bar as the cursor is placed 
over the menu and sub-menu items. 
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Maintain Remote Sites 
IRIS Status maintains a database of all remote sites monitored by the system. This database 
is organized into site groupings to allow the system administrator to organize the sites into 
logical groups. These groupings may be based on function, geographical location, or any 
other criterion specified by the system administrator. This database contains information on 
how to connect to all of the remote sites contained in that site-group. 

To monitor a remote site, the site must be contained in the current site list displayed in the 
application window. Once a site is listed, all future status update functions will include the site 
and allow the user to display the current status of the site. Using the Configuration menu 
item, the user may add, edit or delete sites.    

 

Add Remote Site 

1. Select Config > Sites from the main menu to open the Remote Connection dialog box.   

2. Enter the Location Name in the text field for Remote Location.  This name will be the 
name of the site that will be displayed on all reports. 

3. Select the type of connection. Options are LAN and Modem.  

4. Enter an IP Address and/or phone number, depending on the connection type.   

Updates changes made to 
existing location parameters.   

Cancels changes 
and closes the 
Remote Connection 
dialog box.  

Deletes the current 
location.   

Saves a new location. 
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5. Click the NEW button to save the information. 

6. Repeat steps 2. through 5. for all locations to be added. 

7. Once all locations are added, click the CANCEL button to exit the screen and return to the 
main menu. 

Edit Remote Site  

1. Select Config > Sites from the main menu. 

2. Select the location to be modified from the list of remote locations. 

3. Make the required changes to the type of connection, IP Address or Phone Number. (The 
name of the site cannot be changed. Refer to the note displayed below.) 

4. Click the UPDATE button to save the information. 

5. Click the CANCEL button to exit the screen and return to the main menu. 

 

 

 

Delete Remote Site  

1. Select Config > Sites from the main menu. 

2. Select the location to be modified from the list of remote locations. 

3. Verify that the highlighted location is the location to delete. 

4. Click the DELETE button to delete this site. 

5. Click the CANCEL button to exit the screen and return to the main menu. 

The site 
information can 
contain a IP 
Address and 
Phone Number 
for the site but 
only the LAN 
connection type 
will be used for 
status updates. 

 

To modify the name of a site, follow the above directions except click NEW 

rather than UPDATE.  Then reopen the dialog box and delete the old site as 
shown below.   

Once a site has 
been deleted it 
cannot be 
recovered. To 
restore a deleted 
site to the 
monitored list, the 
site information 
will have to be 
added to the site 
list as a new site. 
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Group Remote Sites 
Monitored sites may be organized into groups containing one or more sites. This grouping 
allows remote sites to be organized by region, state, or organization.  Much like an Address 
Book, the Site Group lists the names and connection details for all sites contained within the 
group and are, therefore, monitored as a group.  

 All site names within the various groups must be unique.  

 Sites may appear in multiple groups by assigning the same site name to each 
group.  

 The application window will show the status for all sites listed as part of the 
group. 

The name (and path) of the currently selected group is displayed in the Title Bar of the main 
IRIS Status application window. On startup, the default group, DEFAULT.IGP, will be 
selected.  

 All functions are performed on the currently selected group. 

 IRIS Status must always have a valid group selected.  

 The user may select an existing group or add a new group.    

Create IRIS Group 

1. Select Config > Group from the main menu. 

2. When the IRIS Group dialog box is displayed, enter the name of the new group in the text 
field.  
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3. Click the OPEN button to create the new group entry.  A 
prompt will be displayed confirming the new group.  
Click YES to create the new group, or NO to close the 
dialog box.  The group will be saved with an .IGP 
extension.   

4. Since this is a new group, it is empty.  Sites must be 
added to the group before it will be available for 
selection.   

5. Immediately click Config > Sites to add sites to this group.  A No Records Found prompt 
will be displayed.  Click OK and the Remote Connections dialog box will be displayed. 
(Refer to Add Sites to a Group for additional instruction). 
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A D D  S I T E S  T O  I R I S  G R O U P  

1. Select Config > Sites from the main menu to display the Remote Connections dialog 
box. 

2. Enter the location name in the text field for Remote Location.  This name will be the name 
of the site that will be displayed on all status reports.  

3. Select the type of connection. (Options are LAN or Modem). Enter an IP Address or 
Phone Number depending on whether a LAN or Modem connection was selected, 
respectively. 

4. Click the NEW button to save the information. 

5. Repeat steps 2. through 4. for all locations to be added. 

6. Click the CANCEL button to exit the screen and return to the main menu. 

Select IRIS Group 

1. Select Config > Group from the main menu. 

2. An IRIS Group dialog box will be displayed similar to the Windows File dialog box. Select 
(or path to and select) the name of the group and click the OPEN button.  

The dialog box will close and the selected group will be displayed in the application window 
showing the last reported status for that group of sites. This group will now be used for all 
future status updates and functions.  

Delete IRIS Group 

To delete obsolete groups that are not required, use the Windows Explorer.  Path to the 
location, select the group to be deleted, and click File > Delete or use the delete button from 
the Windows menu bar   

The site 
information can 
contain a LAN 
and Phone 
Number for the 
site but only the 
type of 
connection 
selected will be 
used for status 
updates. 
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Set Status Preferences 
IRIS Status allows the user the ability to display the current status information using several 
filters and sort options. The Preference menu allows the user to determine what sites will be 
displayed. The user may toggle the Show Normal Sites and Show Error Sites to display: All 
Sites, only Sites with no Errors, or only Sites with errors.  By selecting the Sort option, the 
user may choose one of three sort orders: None, Ascending, or Descending. 

Display Preferences 

Select Preferences from the main menu and enable the display options as required.  When 
enabled, a check mark will be displayed next to the option (refer to the Menu Items display 
presented on page 9 for an example). 

 To view all sites, enable the Show Normal Sites and Show Error Sites by 
clicking the option.   

 To view only sites with errors, enable Show Error Sites. 

 To view only sites without errors, enable Show Normal Sites. 

The window will be refreshed and the table will display the sites in accordance with the 
selected display options.    

Sort Order Preferences 

1. Select Preferences > Sort from the main menu.   

2. Select one of the sort options: None, Ascending, or Descending. 

3. Left-click the column to sort on from the main window.   

4. The window will be refreshed and the table will be resorted and displayed in accordance 
with the selected sort options.     

To add or remove a 
check mark,  click 
the box once to 
toggle the selection.   
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Configure Status Update Modes 
IRIS Status is designed to provide continuous status information for the IRIS system.  As 
such, it may be configured to run in one of three status update modes:  

Periodic Update 

On Demand Update 

Scheduled Update (uses separate schedule program) 

Each of these update modes may be used to capture and display the current status for any or 
all IRIS systems. When the IRIS Status application is active, it connects with each monitored 
IRIS system and requests a status check. The IRIS system will then return the current health 
status indicators.  

Using one of the update modes, the remote IRIS system returns configuration and status 
information that provides the IRIS Status application with information on the current status, 
software revision, and current configuration. This information is used to build a local 
database of system health. 

Using this local database, IRIS Status may be used to display the last reported status from 
any monitored remote site. Status information may be further analyzed and organized to 
display all sites, all healthy sites, all sites with problems, or all sites with specific problems. In 
addition, IRIS Status provides the user with the ability to focus in on a particular site and 
acquire current data for only that site to resolve issues that may exist at one site only. For 
issues that may exist on a system-wide basis (date, time or upgrade remote operational 
software) IRIS Status provides the ability to update the complete system with a single 
selection. 

As each site is 
updated the current 
status of the Status 
Update function is 
shown in the status 
display box. 
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Periodic Update Mode 

In the Periodic Update mode, the IRIS Status application is left active, but idle on a dedicated 
PC. The IRIS Status window is still available but may be minimized. Periodically, the IRIS 
Status application will wake up and poll each remote IRIS DVS Server to gather the current 
remote system health, after which, the IRIS Status application returns to the idle state. The 
frequency of the updates is determined by the configuration settings in the Schedule Updates 
dialog box. At any time, the user may open the IRIS Status application window and display 
the current status of the remote sites. 

S E T  P E R I O D I C  U P D A T E  F R E Q U E N C Y  
1. Select Function > Set Periodic Update from the main menu. 

2. Check the Enable Periodic Updates checkbox to enable this function.  

3. Enter the time between updates in hours in the box provided.  

4. Click OK to save the new data entered.  The CANCEL button may be used to close the 
dialog box without changing the values. 
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On Demand Update Mode 

Any time while the IRIS Status application is active, the user may request an immediate 
update from one or all monitored sites. When this option is selected, IRIS Status will begin to 
poll the selected remote site(s) and update the local health database. Once all sites have 
been contacted, the software will refresh the status window with the updated information. 

R E Q U E S T  S T A T U S  U P D A T E  F O R  A L L  S I T E S  

1. Select Function > Get Status from Remotes from the main menu to display the Select 
Remote Location dialog box. 

2. Click the All Locations check box.   

3. Click DONE to initiate the status request.   As each site is polled, the current status of the 
status update function is displayed in the status display box.    

When all sites have been polled IRIS Status application will update the application window 
with the current status for all sites. 

 

To get the status for 
an individual site, 
select the site from 
the list.  

  

 

 

To get the status for 
all sites, click the All 
Locations box.   
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R E Q U E S T  S T A T U S  U P D A T E  F O R  S I N G L E  S I T E  

1. Select Function > Get Status from Remotes from the main menu to display the Select 
Remote Location dialog box. 

2. Select the location to request status from by clicking the location name. 

3. Click DONE to initiate the status request.   As the site is polled, the current status of the 
status update function is displayed in the status display box. 

When the site has been polled IRIS Status application will update the application window with 
the current status. 

Scheduled Update Mode 

In the Scheduled Update mode, a separate schedule program (not part of the IRIS software) 
periodically runs the IRIS Status application. When the IRIS Status application starts, it 
immediately polls each of the monitored remote sites and builds a local database of the 
remote sites health indicators. Once all remote sites have been polled, IRIS Status 
terminates. The period of the update is determined by the settings of the schedule program. 
Normally, the schedule program is a standard component of the Windows® operating 
program; however, third-party scheduling programs may be used.  When using the 
Scheduled Update option, IRIS Status should be called with the “/UPDATE” parameter.  

Example “IRISSTATUS.EXE /UPDATE” 

 

 

 

Refer to the instructions for the specific Scheduler Program for detailed 
information.   
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Send Remote Time Info 
The IRIS Status program allows the user to update the system time at the remote sites. The 
date and time can be set for one or all sites that are contained in the monitored site list. 

1. Select Function > Send Remote Time Info from the main menu to display the Select 
Remote Location dialog box.   

 

2. Select the location to request status from by clicking the location name.  To modify all 
locations at the same time, click the All Locations box in the lower left-hand corner.  Click 
DONE to open the Get Remote Site Time dialog box.  . 

 If a single site is selected, the system will access the remote IRIS site and 
retrieve the current time and display.  

 If All Locations is selected, the system will display the current date and time as 
provided by the computer that is running the IRIS Status application. 

3. Enter the correct time and/or date and click UPDATE.  The CANCEL button may be used to 
abort the update function.    
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The system will send the date and time to the selected remote IRIS DVS Server site(s) and 
verify that the time was changed. Once the function is complete the dialog box will 
automatically close and return to the main application window. 

Send Remote File 
The IRIS Status application provides the flexibility to send a file to an individual or all remote 
sites contained in the monitored site list.  This function is normally used to update program 
files or perform other maintenance at the remote sites.   

1. Select Function > Send Remote File from the main menu to display the Select Remote 
Location dialog box (as displayed on the previous page).     

2. Select the location to receive the file by clicking the location name.  To modify all 
locations at the same time, click the All Locations box in the lower left-hand corner.   Click 
DONE. 
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3. The application will open a standard 
Windows File dialog box. Select the file to 
be sent and click OPEN. A Remote 
Filename dialog box will be displayed. 

4. Enter a save as file name to be used for 
the transferred file at the remote site.  
Include the complete path information with 
the filename (C:\directory\subdirectory\subdirectory\testfile.dat).  The current name may 
be used by clicking the Use Same Name at Destination at Source check box.   

5. Click OK to send the file. The CANCEL button may be used to cancel the remote transfer.  

As the file is transferred to each site, the current status of the file transfer is shown in the 
status bar. When the transfer is complete, the system will automatically return to the main 
application window and display the last status information of all of the selected sites 

 

The unwarranted or incorrect transfer of files could cause the remote system to 
become unstable and result in the loss of images files and operation.   
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Delete Old Status 
When IRIS Status queries a remote site, the new status replaces the 
old status and the status window is updated.     

 If the Delete Old Status option is enabled, and no new 
status is available, the site will be marked in error and 
indicated as Site Not Responding in the status window.  

 If the Delete Old Status option is not enabled, and no new status is available, 
the site will display the last status received but the date and time of the status 
will not change; however, the site will be marked in error and indicated as Site 
Not Responding in the status window.  

Click Preferences > Delete Old Status to enable this option.  When enabled, a check mark 
will be displayed.  To disable, click again. 

Restore Deleted Status Information 
At times it may be necessary to view the last retrieved status information from the site.  To 
restore deleted status information, select Function > Restore Old Status from the main 
menu.  IRIS Status will recover the last status update for each site with a Site Not 
Responding status, and display the results in the application window.    

This function has 
no effect on sites 
that are responding 
to status request. 
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Print Status Information 
IRIS Status provides an easy method of printing the current status information as shown on 
the status window using a default text editor.  The spacing of the individual selected columns 
will be the same as is shown on the status window.  Once Function > Print is selected from 
the main menu, a text report file is generated and opened in a default text editor (normally 
Notepad) allowing the user to review the report and make changes, as necessary, before 
printing.  

 

Notepad opens and saves text in ASCII (text-only) format only.  

To enable the user to view all columns of the status report, it may be necessary to modify the font 
size by selecting Edit > Set Font.   

To get additional help modifying text in Notepad, click the Help menu item from the main menu. 
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Print Format 

Printed status reports may be formatted to include or exclude specific fields in the status 
report. To select the status items to be included or excluded on the report, select Function > 
Print Format, and click the appropriate checkbox(s) to select or deselect the items.  

 

Edit Status Information 

1. Size the status information columns on the display window to show the desired 
information. 

2. Select Function > Print from the main menu. The default text editor will open, displaying 
the generated status report. The report will be formatted based on settings in the Print 
Format option. 

3. Edit the report text, as required.  The report may be saved for later retrieval and/or 
printed using the editor Save and Print commands. 
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Save Status Information 

1. To save the report, select File > Save As from the editor main menu.   

2. When the Save As dialog box is displayed, path to the folder to contain the saved report 
using the Save In drop-down field. 

3. Enter a name for the report in the File Name text field, and click SAVE.  The report will be 
saved as a text file with a .txt extension.   

Print Status Information 

1. Size the status information columns on the display window to show the desired 
information. 

2. Select Function > Print from the main menu. The default text editor will open, displaying 
the generated status report. The report will be formatted based on settings in the Print 
Format option. 

3. Edit the report output, as required.  The report may be saved for later retrieval and/or 
printed using the editor Save and Print commands. 

4. Select File > Print from the main menu of the text editor and the file will immediately be 
sent to the printer. 
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Export Status Information 
IRIS Status provides an easy method of exporting the current status as shown on the status 
window. This information may be exported to an Excel, Access or other commercially 
available relational database. The Export Format option may be used to selectively include 
or exclude fields of the status window, select the field delimiter, and format the titles.  

1. Select Function > Export from the main menu to display the Windows File dialog box.   

2. Use this dialog box to identify the destination filename. The user may select an existing 
file as the destination file by selecting the path and then selecting the file name to be 
exported, or enter a new file name.  

3. Once the file name is entered, the system will export the file to that filename. This export 
file can then be imported to a third-party database program.   

Export Format 

Exported files may be formatted to include or exclude specific fields in the status report and 
to define the delimiter to be used.  

1. To select the status items to be included or excluded on the report, select Function > 
Export Format, and click the appropriate checkbox(s) to select or deselect the items.  

2. To select the delimiter to be used, click the appropriate selection.  Only one selection is 
allowed. 

3. Click OK and the formatting options will be saved and used each time an export file is 
created.   

 

Prior to creating the export file, the user may define the items to be included in the export file 
and define the delimiter format for the file to be used by clicking Function > Export Format 
from the main menu.   
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. . 

Close IRIS Status 
If IRIS Status is configured to use periodic updates, the application should not be closed. The 
window should only be minimized and the application left in an idle mode so that sites may be 
polled based on the specified update schedule. 

Select Function > Exit from the main menu to terminate the program.  The  in the upper 
right hand corner may also be used to close the application.   
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IRIS Access Manager    
IRIS Access Manager is a support component that provides the SYSOP with 
the ability to setup and maintain Remote Name Servers (RNS). Unlike IRIS 
Inquiry where the SYSOP manages User IDs and Passwords on a site-by-site 
basis, the IRIS Access Manager allows the SYSOP to manage User IDs and 
Passwords on a system-wide basis as well as the Authorized User Lists for 
both DVS and RNS Server sites.   

The RNS Server may be located on a PC inside a facility, on a separate server 
on the network, or on a dedicated dial-up PC unit. Generally, the RNS Server is 
positioned near the DVS Server.   An IRIS system may include one or more 
RNS Servers.   

When using IRIS Inquiry to attach to a remote IRIS DVS Server, the remote 
user typically displays the available DVS server locations using their local 
Address Book.  As an option, the user may access the RNS Server and receive 
a temporary, one-time use, Address Book that may contain a more current 
listing of available DVS Servers. This RNS Address Book may be used to 
directly access the remote DVS location. An optionally configured feature 
enables this temporary Address Book to be downloaded and replace the local 
Address Book of the user, automating the access update function.  

Typical Access Manager Setup Procedure 
Although there are numerous functions and capabilities for the IRIS Access 
Manager, the basic procedural workflow to setup and maintain an RNS Server 
and send and retrieve the updated information to and from the DVS and RNS 
servers, is as follows:   

1. Select RNS Server > Select RNS Group and select the default group 
“Demo”.  Refer to pages 47 - 48 for information regarding RNS Groups. 
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2. Select RNS Server > Address of RNS to set the address of the RNS to 
the appropriate TCP/IP address/phone number. Refer to page 49 regarding 
setting the address of the RNS. 

3. Select RNS Server > Get Auth User List to upload the current Authorized 
User list from the selected RNS.  The Remote Access dialog box will be 
displayed prompting for a SYSOP User ID and Password.  Refer to page 
61 regarding uploading the Authorized User List from the RNS to the 
Access Manager application. 

4. Select RNS Server > Get User Connect Files to retrieve old file 
information (optional).   The user has the option to start with an existing list 
and add or modify users or to enter all users manually.  The Remote 
Access dialog box will be displayed prompting for a SYSOP User ID and 
Password.  Refer to page 59 regarding retrieving the user connection files 
(Address Book) from the RNS to the Access Manager application. 

5. Select Users > Valid User IDs to add all users. Refer to page 50 regarding 
adding users.  These User IDs are used to update the Authorized User 
Lists at the RNS. 

6. Select Users > Video Service Access to configure the DVS Server access 
for all users.  Refer to page 52 regarding assigning DVS Server access to 
each User ID. This becomes the temporary Address Book available to each 
user accessing the RNS. 

7. Select User > Rebuild User Information to build the user information.  
Refer to page 55 regarding rebuilding the user information. 

8. Select RNS Server > Update Auth User List and select Merge to update 
the Authorized List with all new users.  Refer to page 62 regarding updating 
the Authorized User List records in the Access Manager.  The user has the 
option to Merge or Replace records.   

9. Select RNS Server > Send Authorized User List to download this 
updated list of users to the RNS. The Remote Access dialog box will be 
displayed prompting for a SYSOP User ID and Password.  Refer to page 
63 regarding downloading the updated Authorized User List to the RNS. 
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10. Select RNS Server > Send User Connect Files to update the Address 
Book entries for each user at the RNS.  The Remote Access dialog box will 
be displayed prompting for a SYSOP User ID and Password.  Refer to 
page 59 regarding downloading the User Connection Files to the RNS. 

Menu Tasks 
Once the initial setup is configured, the SYSOP may connect to the appropriate 
servers (RNS or DVS) and download or upload Authorized User Lists and 
Connection Files (Address Books). The SYSOP then uses the Access Manager 
application to perform the maintenance and update functions. The following 
table presents the various tasks and menu item access during both the initial 
setup and operations phases of this application.  
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Access Control Use SYSOP User ID to access remote server 
sites. 

Create/Select RNS Server Group(s)  RNS Server > Select RNS Group 

Set RNS Address RNS Server > Address of RNS 

Add User IDs to RNS Server Group  Users > Valid User IDs or  

RNS Server > Get Auth List from RNS Server 

Specify DVS Servers Available to RNS Video Servers > Locations Supported by RNS 

Assign DVS Server Access to each User 
ID  

Users > Video Service Access 

Enable User to Download Temporary 
Address Book 

Users > Video Service Access 

Rebuild User Information Users > Rebuild User Information 

 

Select/Add/Delete RNS Server Groups RNS Server > Select RNS Group 

Set RNS Address RNS Server > Address of RNS 

Add/Update/Delete User IDs Users > Valid User IDs or  

RNS Server > Get Auth List from RNS Server 

Add/Update/Delete DVS Servers Available 
to RNS 

Video Servers > Locations Supported by RNS 

Assign DVS Server Access for each User 
ID and Enable User to Save Temporary 
Address Book 

Users > Video Service Access 

Rebuild User Information Users > Rebuild User Information 

Update DVS Authorized User List to DVS 
Server 

Video Servers > Update Auth User List at Video 
Server 

Upload/Download RNS Connection Files to 
RNS Server 

RNS Server > Get User Connection Files from 
RNS Server 

RNS Server > Send User Connection Files to 
RNS Server 

Upload/Display/Update/Download RNS 
Authorized User Lists to RNS Server 

RNS Server > Get Auth User List from RNS 
Server 

RNS Server > Display Current RNS Auth List 

RNS Server > Update RNS Auth User List 

RNS Server > Send Auth User List to RNS 
Server 

I N I T I A L  

S E T U P  

F U N C T I O N S  

M A I N T E N A N C E

F U N C T I O N S  
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User Interface 
The IRIS Access Manager application has been designed with a familiar and 
user-friendly work environment. The user may easily enter and access data 
using familiar data controls such as text boxes, drop-down selection boxes, 
radio buttons, selection lists, and check boxes.   

Application Window 

All dialog boxes and prompts will be displayed within the application window.   

 
 

Horizontal Menu Bar 

Application Window 

Title Bar 

Status Bar 
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Title Bar 

While connected, the name of the RNS group will appear in the title bar of the 
main IRIS Access Manager application window.  

Horizontal Menu Bar 

The IRIS Access Manager main menu items are included on a horizontal menu 
bar that appears across the top of the application window. 

MENU ITEM DESCRIPTION OF FUNCTIONS 

USERS Valid User IDs – Used to add, edit or delete users to the 
RNS Server Groups.  This list of Valid User IDs may be 
used to maintain the Authorized User Lists for the RNS and 
DVS Servers. The User ID together with the assigned DVS 
Servers define the User Connection Files which are used as 
the temporary Address Book for each user when they 
connect to the RNS.   

Video Server Access – Used to assign DVS Server access 
to each User ID and to enable a user to save the temporary 
Address Book from the RNS Server as their local Address 
Book allowing direct access to all locations contained in the 
new Address Book. The assigned DVS Server access 
together with the User ID define the User Connection Files 
which are used as the temporary Address Book for each 
user when they connect to the RNS.   

Rebuild User Information – When any of the connection 
information has been changed, this menu item is used to 
update the User Connection Files (which are used as the 
Address Book) for all User IDs in the RNS Server Group. 

Exit – Closes the Access Manager application 
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MENU ITEM DESCRIPTION OF FUNCTIONS 

VIDEO SERVER Update Authorized Users at Video Servers – Used to 
update the Authorized User List for DVS Server locations. 
User has option of updating a single DVS Server or multiple 
DVS Server sites concurrently. 

Locations Supported by RNS – Used to add, edit or delete 
DVS Server locations available to the RNS Server Group.  
These entries are displayed when the SYSOP assigns 
Video Server Access to each User ID by selecting Users > 
Video Server Access from the main menu. 

RNS SERVER Get User Connect Files from RNS Server – Uploads the 
connection files from the RNS Server to the Access 
Manager application.  This option may be used when 
configuring the RNS Server Group for the first time to upload 
the existing User IDs and DVS Server access records from 
the existing RNS Server rather than create new entries.  
Once uploaded, these entries may be modified using the 
Valid User IDs or Video Server Access menu items 
available from the Users main menu item.     

Send User Connect Files to RNS Server – Downloads the 
updated connection files (Address Book) to the RNS Server.   

Get Authorized User List from RNS Server - Uploads the 
current Authorized User List from the RNS Server to the 
Access Manager application.   

Display Current RNS Authorization List – Displays the 
uploaded Authorized User List for review only.    This list 
may not be updated from this location.   

Update RNS Authorization List – Enables the SYSOP to 
update the list using the Valid User IDs that have been 
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MENU ITEM DESCRIPTION OF FUNCTIONS 

entered for the RNS Server Group.  The SYSOP has the 
option to merge the two lists or replace the list with the Valid 
User IDs list.   

Send Authorized User List to RNS Server – Downloads 
the updated Authorized User List to the RNS Server. 

Select RNS Group – This menu item is used to select the 
RNS Server Group or to create a new group.   

Address of RNS – This menu item is used to enter 
connection type and the IP Address or Phone Number of the 
RNS Server. This address will be used by the IRIS Inquiry 
users for Indirect DVS Server access when connection to 
the RNS Server and using the temporary Address Book to 
connect to assigned locations.     

Status Bar 

A brief description of each function will be displayed in the status bar as the 
cursor is placed over the menu and sub-menu items.  Additionally, the transfer 
status will also be displayed in the status bar during any download or upload 
process.   
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Access Levels 
There are two access levels used throughout the IRIS System to control and 
validate access to the various DVS and RNS Server locations and respective 
Address Books.   

User IDs and Passwords  

User IDs and Passwords are assigned to each user authorized to connect to a 
DVS or RNS Server site. The IRIS system provides the capability to maintain 
these User IDs and Passwords site-by-site or system-wide basis.   

IRIS Inquiry allows a SYSOP user to add User IDs and Passwords on a site-
by-site basis (using the Config menu item) for users authorized to access the 
attached DVS Server site.  All users added by the SYSOP will be included in 
the Authorized User List for that site.     

IRIS Access Manager enables the SYSOP to build groups of Valid User IDs, 
assign DVS locations to each ID, and download this information to the various 
DVS Server sites and update the Authorized User List on a system-wide basis. 
Additionally, the Access Manager may be used to configure RNS Server 
access that allows users to access a temporary Address Book and connect to 
locations that may not be included in their local Address Book.  In this instance, 
the user must be included in the Authorized User List for the RNS Server 

Authorized User Lists 

Authorized User Lists are maintained and downloaded to each DVS and RNS 
Server by a SYSOP using the IRIS Access Manager application. This list 
contains the User IDs and Passwords for all users that have been assigned 
access to the respective Server.  As the user attempts to connect, the Remote 
System Access dialog box will be displayed prompting for a User ID and 
Password.  The system will compare the User ID and Password to the 
Authorized User List for validation.  
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For a direct DVS Server access, the User ID and Password must be included in 
the Authorized User List for that server. 

For indirect DVS Server access where the user will connect to a RNS Server 
and use a temporary Address Book to access the DVS Server, the User ID and 
Password must be included in the Authorized User List for the RNS Server.   
Users may then access any DVS Server location included in the temporary 
Address Book without further verification.   

Operational Modes 
IRIS RNS Manager supports many modes of operation for the security 
requirements of each IRIS system. The selection of an operational mode 
depends on organizational operating procedures and the degree of restriction 
required for access to the DVS and RNS Servers.  

Open System Access 

For minimum security, the Open System allows for Direct (using local Address 
Book) and Indirect (using temporary RNS Address Book) to all DVS Servers 
with no restrictions for normal user access. All users would use a common User 
ID and Password.  

 

  

 

It is suggested to assign the User ID as Guest and the Password as 
Password.  
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Direct DVS Server Access 

In the Direct DVS Server Access mode of operation, the remote user is 
assigned a unique User ID and Password, and connects to available IRIS DVS 
Servers using their local Address Book. When the user attempts to connect, the 
User ID and Password are compared with the Authorized User List at the 
remote location to verify that the user is authorized to access the site.    

 
Figure 1 – Direct DVS Server Access 

Indirect DVS Server Access 

The IRIS system may be configured in the Indirect DVS Server Access mode 
where each user is assigned a unique User ID and Password.  The user will 
connect to a DVS Server by first connecting to the RNS.  As the user attempts 
to connect to the RNS, the Remote System Access dialog box will be displayed 
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prompting for a User ID and Password.  The system will compare the User ID 
and Password to the Authorized User List of the RNS for validation.  

Once connected to the RNS Server, the users a temporary Address Book will 
be displayed. The user is then allowed to access any DVS Server contained in 
the temporary Address Book without further verification. Additionally, if 
configured by the Access Manager SYSOP, the temporary Address Book may 
be downloaded to replace the local Address Book of the user, automating the 
access update function, and providing direct access to the DVS Server 
locations contained in the list. However, when connecting directly to a DVS 
Server, the user must be included in the DVS Server Authorized User List. 

 
Figure 2  - Indirect DVS Server Access 
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Address Book Update 
The Access Manager may be used to update local Address Books at each of 
the DVS Server sites.  This provides an easy method of updating the Address 
Books as new DVS Servers come on-line or are moved.  When a user connects 
to the RNS Server (Indirect DVS Server Access), a temporary Address Book is 
made available to the user. The User ID and Password must be included in the 
Authorized User List for the RNS Server.   Users may then access any DVS 
Server location included in the temporary Address Book without further 
verification.   

If the Access Manager SYSOP enables the user to save the Address Book, the 
user will be given the opportunity to save the temporary Address Book to be 
used as the local Address Book, allowing the user to connect to the DVS 
Servers directly. However, when connecting directly to a DVS Server, the user 
must be included in the DVS Server Authorized User List. 

 
Figure 3 – Address Book Update 
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RNS Server Groups  
The RNS Access Manager software can support multiple RNS Servers.  Each 
RNS Group defines a RNS Server location comprised of a list of Valid User IDs 
and associated DVS Servers that have been assigned access to the respective 
RNS. The Access Manager must always have a valid group selected; therefore, 
on initial access, the Default group will be selected.  The user may select an 
existing group or add a new group.  All functions are performed on the currently 
selected RNS Server Group.  

Select RNS Server Group 

1. Select RNS Server > Select RNS 
Group from the main menu to display 
the Select RNS Server Group dialog 
box.  All available groups will be 
displayed in the list. 

2. Select a group from the list, and click 

OK to return to the main menu.   The 
selected group will be displayed in the 
Title Bar.   

Add RNS Server Group 

1. Select RNS Server > Select RNS Group from the main menu to display 
the Select RNS Server Group dialog box.  All available groups will be 
displayed in the list. 

2. Enter a name for the new group and click 

ADD.  A prompt will be displayed to use the 
group now.   

3. Click YES to close the dialog box and return 
to the main menu. The new group will be 
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selected as the current group and displayed in the Title Bar. Click NO to add 
another group name or select a group from the list.  

4. When all groups have been added, the user may use the last group added 
as the current group by clicking YES to the prompt, or click NO, select a 
group to be used as the current group, and click OK to return to the main 
menu. 

Delete RNS Server Group 

1. Select RNS Server > Select RNS Group from the main menu to display 
the Select RNS Server Group dialog box.  All available groups will be 
displayed in the list. 

2. Select a group from the list to be deleted, and click DELETE.  A confirmation 
prompt will be displayed.  Click YES to delete the group, or CANCEL to abort 
the deletion process. 
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Set Address of RNS 
Each RNS Server Group must be assigned an address.  Only one RNS Server 
may be assigned to a Server Group.   

1. Select RNS Server > Address of RNS to display the location dialog box.   

2. Select the connection type (options are LAN or Modem).  Only one 
selection is allowed. 

3. Enter the Phone Number or IP Address depending on the connection type 
selected, and click OK to return to the main menu.    

 

The site information may 
contain an IP Address 
and a Phone Number; 
however, only the 
selected connection type   
will be used for status 
updates. 
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Valid User IDs 
Once an RNS Server Group has been defined, a group of users must be 
associated with the RNS.  Each user is assigned a unique User ID, Password, 
and software S/N that will provide access to the RNS and associated DVS 
Servers.  Once the User ID has been entered, it may not be changed; however, 
each user may change their Password from IRIS Inquiry by selecting Config > 
Change Password.  

Each User ID will be assigned access to specific DVS Servers. Together, these 
items create the User Connection Files that are downloaded to the RNS Server 
and become the temporary Address Book for each user. 

Add User IDs 

1. Select Users > Valid User IDs from the main menu to display the Add or 
Delete Users dialog box.  

 

 

On initial setup, 
the SYSOP may 
retrieve existing 
User Connection 
Files from the 
RNS rather than 
create all new 
records.  Once 
retrieved, these 
files may be 
modified as 
required.   
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2. Enter a unique User ID (maximum 10 characters), Software Serial Number, 
and initial Password (maximum 10 characters) and click ADD to save the 
information.  The user will be included in the list. 

3. Once all users have been added, click DONE to return to the main menu. 

Update User IDs 

1. Select Users > Valid User IDs from the main menu to display the Add or 
Delete Users dialog box.  

2. Select a User ID by highlighting the entry or entering the User ID in the text 
box.  Make the necessary changes to the Password and/or software S/N 
and click UPDATE to save the information.   

3. Click DONE to return to the main menu.   

Delete User IDs 

1. Select Users > Valid User IDs from the main menu to display the Add or 
Delete Users dialog box.  

2. Select a User ID to delete by highlighting the entry or entering the User ID 
in the text box and click DELETE to delete the user from the RNS group. 

3. Click DONE to return to the main menu. 

 

Changes to the User ID are not allowed.  To change the User ID for a user, the 
SYSOP must first delete the user record and re-enter the user record with a 
new User ID.   
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DVS Server Locations Supported by RNS 
Once the RNS Server Group has been defined, a group of DVS Servers must 
be associated with the RNS.  Each associated DVS Video Server is listed by 
the name and includes the contact information including the connection type 
(LAN or Modem), and an IP Address and/or Phone Number. Each User ID 
associated with the RNS may be given selective access to any number of the 
associated DVS Servers. This information is used to construct the temporary 
Address Book that will be available for each of the Valid User IDs 

 

Add DVS Server Location 

1. Select Video Servers > Locations Supported by RNS from the main 
menu to display the Digital Video Server dialog box. 

2. Enter a name in the remote server name text box.  This name will be 
displayed on all reports and Address Books. 

3. Select the type of connection (LAN or Modem) 

4. Enter an IP Address or Phone Number depending on whether the 
connection type was LAN or Modem, respectively, and click the ADD button 
to save the information. 
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5. When all DVS Servers have been added, click DONE.  The Rebuild User 
Information prompt will be displayed. 

Update DVS Server Location 

1. Select Video Servers > Locations Supported by RNS from the main 
menu to display the Digital Video Server dialog box.  

2. Select a User ID by highlighting the entry or entering the User ID in the text 
box.  Make the necessary changes to the Password and/or software S/N 
and click UPDATE to save the information.   

3. Click DONE.  The Rebuild User Information prompt will be displayed. 

 

Delete DVS Server Location 

1. Select Video Servers > Locations Supported by RNS from the main 
menu to display the Digital Video Server dialog box 

2. Select a User ID to delete by highlighting the entry or entering the User ID 
in the text box and click DELETE to delete the user from the RNS group. 

3. Click DONE.  The Rebuild User Information prompt will be displayed.  Refer 
to page 55 for additional information.   

 

Changes to the Remote Server Name are not allowed.  To change the name of 
the remote server, the SYSOP must first delete the record and re-enter the 
server as a new location.   
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Assign DVS Server Access  
Access to individual DVS Servers is managed by the SYSOP for each User ID.  
The available DVS Servers assigned to each User ID is unique and can contain 
any number of available servers.     

1. Select Users > Video Service Access from the main menu to display the 
Video Server Access dialog box.   

2. Using the drop-down selection box, select the User ID. 

3. All available DVS Servers will be listed in the Available Video Servers list.  
All DVS Servers that have enabled for the user will be displayed in the 
Assigned Video Servers list.   

 To assign all sites, click the  button. 

 To select a specific site, click the  button. 

 To remove all assigned sites click the  button. 

 To remove a selected site, click the  button. 
 

 

All available DVS 
Servers as defined 
using the Video 
Servers > 
Locations 
Supported by RNS 
will be listed in the 
Available Video 
Servers box.   
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Enable User to Save Temporary Address Book 

4. Click the check box, Allow user to save server configuration, to enable the 
user to save the temporary Address Book from the RNS Server 

5. When all assignments are complete for the selected user, click UPDATE to 
select another user or click OK to close the dialog box and return to the 
main menu. 

Rebuild User Information 
When connection information for the associated DVS Servers has changed, it is 
necessary to rebuild the user information files since these files are the Address 
Book entries that contain the DVS Server connection information.  The Rebuild 
User Information prompt is displayed after 
changes have been made to any DVS 
Server location supported by the RNS 
using the Video Servers > Locations 
Supported by RNS main menu item. 
When the prompt is displayed, click YES to 
rebuild or NO to return to the main menu. 

 

The DVS Servers assigned to each User ID are stored as User Connection 
Files and will become the temporary Address Book displayed when the user 
connects to the RNS Server. 
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Access Control 
In order to access a remote (DVS Server or RNS Server) site, the Remote 
System Access dialog box will be displayed, prompting for a User ID and 
Password.  When the User ID and Password have been entered, the system 
will then compare the User ID and Password to the Authorized User List for the 
site to validate access.  

 

 

 

 

 

 

 

 

 

 

 

 

Since all Access Manager functions that require attaching to remote sites 
(downloading and uploading information) require a SYSOP user level, it is 
recommended that the SYSOP User ID be used for all functions.  
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Update DVS Authorized User List 
Each DVS Server has an Authorized User List that is used to validate access to 
the Server. This list contains the User IDs and Passwords for all users that 
have been assigned access to the respective server. As the user attempts to 
connect, the Remote System Access dialog box will be displayed prompting for 
a User ID and Password. The system will compare the User ID and Password 
to the Authorized User List for validation.  

For Direct DVS Server Access, the User ID and Password must be included in 
the Authorized User List for that server.  

For Indirect DVS Server Access, the user will connect to a RNS Server and 
use a temporary Address Book to access the DVS Server. The User ID, 
Password and software S/N must be included in the Authorized User List for 
the RNS Server. The RNS will then provide a temporary User ID and Password 
allowing users to access any DVS Server location included in the temporary 
Address Book without further verification.  This allows users to connect to a 
DVS Server whether or not they are included on the Authorized User List for 
that server.   

1. Select Video Servers > Update Auth Users at Video Server from the 
main menu.  
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 To update all DVS Server sites displayed in the list, check the 
Update All Sites box.   

 To update a specific site, highlight the site. 

 To merge user records, select the Merge update mode. When 
the merge option is selected, the Access Manager will use the 
existing Authorized User List at the destination DVS site and only 
change user records where the User ID matches a User ID 
contained in the RNS Group. All other User ID’s will not be 
modified or deleted. This feature is useful when the intent is to 
revise the list by adding new or modifying existing User ID’s. 

 To replace user records, select the Replace update mode.  
When the replace option is selected, the Access Manager will 
delete all existing User IDs on the Authorized User List at the 
destination DVS site and add only the User ID’s contained in the 
RNS group. This feature is useful when the intent is to delete 
obsolete User ID’s and replace the existing list with an entirely 
new list. 

2. When all options have been selected, click OK.  The Remote System 
Access dialog box will be displayed prompting for a User ID and Password. 

3. The SYSOP must enter their User ID and Password and click OK to begin 
downloading the new User ID information.  The transfer status will be 
displayed in the status bar.  
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User Connection Files 
Each RNS Server contains a list of User Connection Files that define the 
allowed DVS Servers that each user is allowed to access. These are created 
when the SYSOP enters the Valid User IDs and assigns each ID DVS Server 
access.  This User Connection File becomes the temporary Address Book that 
is available to the user when they connect to the RNS.   

Upload User Connection Files from RNS 

1. Select RNS Server > Get User Connection Files from the main menu and 
the Remote System Access dialog box will be displayed prompting for a 
User ID and Password.    

2. The SYSOP must enter their User ID and Password.  Refer to page 56 for 
more information regarding access control.   

The transfer status will be displayed on the status bar. Once all data is 
retrieved, a completion status will be displayed.  At this point, the SYSOP may 
use the Valid User IDs (refer to page 50) and Video Server Access (refer to 
page 54) options to update the user connection information    

Download User Connection Files to RNS 

1. Select RNS Server > Send User Connection Files from the main menu 
and the Remote System Access dialog box will be displayed prompting for 
a User ID and Password.   

2. The SYSOP must enter their User ID and Password and click OK to begin 
the transfer.    

When setting up the 
RNS Server Group for 
the first time, the SYSOP 
has the option to retrieve 
the existing list of User 
Connection Files rather 
than create all new files. 



 IRIS CONTROL SUITE  

 

IRIS  Control  Sui te  60 001.09 

The transfer status will be displayed on the status bar. Once all data is 
downloaded to the RNS, a completion status will be displayed.  At this point, 
the SYSOP should verify that each user has access to the RNS using the Get 
Auth List from RNS Server, Display Current RNS Auth List.  If changes are 
required, the SYSOP must use the Update RNS Auth User List.  Once all 
users have been verified and updated (as required), the SYSOP must send the 
Authorized User List to the RNS using the Send Auth User List to RNS.  All of 
these functions are discussed in the following section.   
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RNS Authorized User Lists  
Each RNS Server has an Authorized User List that is used to validate access to 
the Server. This list contains the User IDs and Passwords for all users that 
have been assigned access to the respective RNS Server.  

As the user attempts to connect, the Remote System Access dialog box will be 
displayed prompting for a User ID and Password. The system will compare the 
User ID and Password to the Authorized User List for validation.  The RNS will 
then provide a temporary User ID and Password allowing users to access any 
DVS Server location included in the temporary Address Book without further 
verification.  This allows users to connect to a DVS Server whether or not they 
are included on the Authorized User List for that server.   

The Access Manager application provides numerous options for processing the 
RNS Authorized User List which may involve retrieving the list from the RNS, 
displaying the list for verifying users, updating the list, as required, and 
downloading the list back to the RNS.    

Receive Existing RNS Authorized User List 

1. Select RNS Server > Get Auth User List from RNS Server from the main 
menu and the Remote System Access dialog box will be displayed 
prompting for a User ID and Password.   

2. The SYSOP must enter their User ID and Password.  Refer to page 56 for 
additional information regarding access control. 

The transfer status will be displayed on the status bar. Once all data is 
received, a completion status will be displayed and the SYSOP can review the 
list using the Display Current RNS Auth List option.   
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Display RNS Authorized User List 

1. Once the Authorized User List has been uploaded from the RNS Server, 
the SYSOP may select RNS Server > Display Current RNS Auth User 
List from the main menu.  All users from the Authorized User List will be 
displayed.   

2. Verify that all User IDs exist for the selected RNS Server Group. If 
discrepancies are found, the list cannot be updated from this screen.  

 To add or edit the User ID entries, select Users > Valid User IDs. 

 Once all changes have been made, select RNS Server > Update 
RNS Auth User List to update the list.   

 Once updated, the list may be redisplayed (using the procedures 
described above) or downloaded to the RNS Server by selecting 
RNS Server > Send Auth User List to RNS Server.   

Update RNS Authorized User List 

1. Select RNS Servers > Update RNS Auth Users List from the main menu.  
Two update options are available in a sub-menu selection: Merge and 
Replace.   

 To merge user records, select the Merge update mode. When 
the merge option is selected, the Access Manager will use the 
existing Authorized User List at the destination RNS site and only 
change user records where the User ID matches a User ID 
contained in the RNS Group. All other User IDs will not be 
modified or deleted. This feature is useful when the intent is to 
revise the list by adding new or modifying existing User IDs. 

 To replace user records, select the Replace update mode.  
When the replace option is selected, the Access Manager will 
delete all existing User IDs on the Authorized User List at the 
destination RNS site and add only the User IDs contained in the 
RNS group. This feature is useful when the intent is to delete 
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obsolete User ID’s and replace the existing list with an entirely 
new list. 

2. When the records have been updated, the SYSOP may use the Send Auth 
User List to RNS Server option to update the Authorized User List at the 
RNS location.   

Download RNS Authorized User List 

1. Select RNS Server > Send Auth User List to RNS Server from the main 
menu and the Remote System Access dialog box will be displayed 
prompting for a User ID and Password.   

2. The SYSOP must enter their User ID and Password.  Refer to page 56 
regarding access control. 

The transfer status will be displayed on the status bar. Once all data is 
downloaded to the RNS, a completion status will be displayed.    

Close IRIS Access Manager 
Select Users  > Exit from the main menu to terminate the program.  The  in 
the upper right hand corner may also be used to close the application.  
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Technical Support  
IRIS provides a technical support line regarding the installation, operation, and use of all 
hardware and application modules. Users may reach a technical support representative 
using any of the following methods.   

Telephone 

Use these numbers to reach the IRIS Customer Service Department and speak to a 
technical support representative during normal office hours: 

Monday – Friday 8:30 am to 5:00 pm CST 

Phone: 214.349.0480   

Fax: 214.349.9429 

After-hours the number below may be used to request assistance. Using a touch-tone 
telephone, enter the full phone number, including area code, and a support 
representative will return your call as soon as possible: 

After-Hours Number: 888.451.4646 

Calls to the regular support number after-hours will be forwarded to a voicemail system. 
Leave a message with the full phone number, including area code. The voicemail 
system will then contact the technical support representative that a request for support 
message is in the system. 

Email 

To send questions using email, and to receive a detailed answer from the technical 
support department by return email, use the following address: 

support@secur i t ytexas.com 

To contact the sales department use the following address: 

sa les@secur i ty texas.com 
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Internet 

To access the IRIS Digital Video Systems website for more information on the company, 
products, and updates, use the following URL: 

  www.DigitalVideocc.tv 

Software and/or Firmware Updates 

IRIS maintains its most current versions of software on its website.  At the home screen, 
select IRIS DIGITAL VIDEO SYSTEMS, and then SUPPORT.  Among the options under 
SUPPORT will be password-controlled SOFTWARE DOWNLOADS.   

If you have not been given the password, check with your local IRIS technical resource, 
or contact IRIS Customer Service Department. 

You then have a choice of software, firmware, or instruction downloads. Be sure to 
select the appropriate category for the product you are working on. 

Manuals 
Each FX-Series system will have a copy of the necessary Manuals in digital format on it.  
Current versions and/or updates are also available on the IRIS website.   
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