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Introduction 
The IRIS FX-Series of digital video recorders is the latest version of IRIS’ popular 
TotalVision TouchScreen wall-mount and DVS servers.  While the TotalVisionTS is 

wall-mount only, the DVS-FX may be configured in the field as either a desktop or rack-
mount unit. 

These two systems are available in 16 and 32 video channel versions to meet most any 
site specific needs. 

Both are based on the Windows
®
 XP Embedded Operating System (standard) and use 

either a network card for a LAN connection, or (optional) modem for phone line 
connections.  

The TotalVision-FX TouchScreen has a build-in high resolution LCD display covered 

with a thin, transparent overlay that converts physical touch pressure into keyboard or 
mouse input signals.  Use of an external keyboard and mouse is optional. 

FX-Series options:   

 16 channel external Video Expansion Multiplexer (VEM), expanding 
either IRIS FX-Series system to 32 channels and 8 data inputs total. 

 Wall-mounted, desktop / rack-mount systems using a full version of 
the Windows

®
  XP Operating System. 

 Raid Array (Redundant Array of Independent Disks).   

 Uninterruptable Power Supply (UPS). 

 External 19” LCD Display.                                       

 

 

Earlier products based on the Windows NT platform are no longer supported by IRIS Digital Video Systems. 
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The Scope of this Manual 

 

The purpose and scope of this Manual is to outline the steps necessary to install and 
configure the IRIS FX-Series TotalVisionTS or DVS units.  

To effectively perform this installation, the IRIS system installer is required to be skilled 
in basic electronics, and have a working knowledge of personal computer systems and 
the Microsoft Windows

®
 operating systems. Additionally, the installer must be familiar 

with field installation of closed circuit television equipment.   

The installer should also be familiar with the Visio software package, or similar, with 
sufficient expertise to generate a Site Map which will allow a remote viewer to pull up a 
map of a location and locate all of the cameras in their field of view. 

  

 

Throughout this Manual the IRIS system may be referred to DVS, DVS 
Server, FX-Series System, IRIS System, or TotalVisionTS.  Unless indicated 
otherwise, functions and/or descriptions will apply to any type of FX-Series 
System. 

 

 

 

For user convenience, Start-up and IRIS-DVS programming instructions 
have been included in the Quick Reference section on page 132. 

 

 

 

Many of the screen samples throughout this Manual were captured on a 
TotalVisionTS; therefore, they will display the TouchScreen KB button in the 
lower-right corner.  On the DVS-FX display, no KB button will be displayed. 
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 System Specifications 

 Sixteen (16) cameras and four (4) data inputs standard configuration. Each camera 
may be separately programmed as a transaction camera, surveillance camera, or 
both.  Optional expansion to thirty-two (32) cameras. 

 Color or black and white camera compatibility. 

 Network interface card. Connects directly to location router, switch, or hub. 

 Surveillance and transaction image access at each site location or remotely.  
Multiple simultaneously users can gain access via LAN/WAN. 

 Managing of image settings and user settings centrally or locally. 

 Customized access for each individual user to fit areas of responsibility. 

 IRIS Inquiry software “Hot-Keys” to enable single-touch copy of surveillance images 
for evidentiary purposes. 

 Standard DVD-RW drive and front panel-mounted USB port. 

 Minimum 750 GB (gigabyte) hard-drive storage of images.   

 Minimum of six (6) months surveillance and one-year transaction image storage. 

 Automatic system health maintenance checking (i.e., ATM lighting compliance). 

 Managing of enterprise-wide video security functions. 

 The dynamic IRIS Inquiry software. 

 Standard Service Manager software allows monitoring of all IRIS systems. 

 Phone line access with the optional modem.  

 System’s capability to log onto itself while running to look at both real-time and 
stored images (IRIS Inquiry software must be resident on the system). 

 Optional ATM data interface unit is available to capture transaction images from 
ATMs not on a LAN. This interface is not necessary with single-point installation or if 
the ATM is on the network (TCP/IP).   

 Operating temperature range: +23° to +104° F,  -5° to +40° C 
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The IRIS factory strongly recommends that the FX-Series digital video recorders be 
installed with an UPS with at least 15 minutes (average) battery back-up for continued 
system operation if there is a main power failure.   

A “smart” UPS will have a controlled shut down of PC when battery voltage reaches 
minimum safe level. Such supplies connect to the DVR via USB cable. 

 

 

Sample “Smart” UPS 
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Installation 
 

Sample Installation Diagrams 

The following displays a typical IRIS FX-Series TotalVisionTS unit.  

 

16 Camera Inputs (Standard)

 Internal Network 

Connection

ATM

Up to 4 RS-232 Data Inputs

(8 Data Inputs with Expansion Module)

ATM Data Inserter

DVD-RW

Single Connection for Transaction 

Data

and 

Communications

Dial-In Communications

Optional Printer

Optional Modem

LCD TouchScreen

Front Panel USB 

Port

16 Additional Camera Inputs for a total of 32

Optional External 

16-channel Video 

Expansion 

Module

UPS

IRIS recommends that the system be 

protected by an uninterruptable 

power supply (UPS).

VIDEO EXPANSION 

MODULE

Optional Spot 

Monitor

Optional Spot 

Monitor

 * Note: The VEM receives its 

power via the USB cable. 

USB*

 

Figure 1 - Sample FX-Series TotalVisionTS Installation 
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The following displays a typical IRIS FX-Series DVS unit.  

 

16 Camera Inputs 

(per Video Expansion Module)

 Internal Network 

Connection

ATMATM Data 

Inserter 

(optional)

Single Connection for 

TCP/IP Transaction Data

and Communications

Optional Printer

VIDEO EXPANSION 

MODULE

Optional Video Expansion Module for a 

total of 32 camera inputs

IRIS DVS-FX

Optional LCD Monitor

VIDEO EXPANSION 

MODULE

M1

M2

M1

M2

USB*

USB*

If the DVS-FX is installed as a tower system, 

remove rack-mount flanges, and install four (4) 

rubber feet (included) to bottom of chassis.

Optional Spot 

Monitor

(1 per VEM)

UPS

IRIS recommends that the system 

be protected by an uninterruptable 

power supply (UPS).

 * Note: The VEM receives its 

power via the USB cable. 

Observe cable numbering 

during installation (M1 and M2).

Note: The chassis keys are 

secured behind the left door.  

Be sure to provide to your 

customer during turnover.

 

Figure 2 - Sample FX-Series DVS Installation 
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Site Installation Requirements 

TotalVisionTS-FX 

The FX-Series TotalVisionTS is a comprehensive digital video recording system that 

includes everything needed for both recording and reviewing images in a simple, easy to 
install, wall-mounted unit.  The unit includes a 12.1” LCD screen with a TouchScreen 
virtual keyboard overlay.  This eliminates the need for an external keyboard and mouse.  
The keyboard can be minimized when not needed with a simple “tap” on the screen. 

 

Figure 3 - FX-Series TotalVisionTS System  

The unit is normally installed in the network equipment room and as close to the 
transaction window(s) as possible to keep cable lengths to a minimum. However, each 
site will be different, and the final selection must take into account all installation factors 
that are involved.  

Sufficient wall space should be acquired to accommodate the unit, with easy access to 
the right side of the unit for access to the DVD-RW drive.  The UPS should be located 
close enough to the unit to allow all necessary cables to reach without strain. A proper 
system installation requires the following: 

  Dedicated 110 VAC 15 Amp circuit 

  Clean and temperature controlled environment, adequate lighting 
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Using the template drawing included with the unit, measure and mark the location for the 
FX-Series TotalVisionTS mounting holes. 

Drill and install the appropriate mounting hardware for the surface mounted on. 

The base of mounting screw head should be 1/16” to 1/8” above the wall surface. 

Place the FX-Series TotalVisionTS cabinet on the mounting hardware.  Secure the 
bottom of the cabinet through the two (2) remaining exposed mounting holes. 

 

DVS-FX 

 

 

Figure 4 - FX-Series DVS System 

The FX-Series DVS system may be configured either as a desktop, or rack-mount with the 
included flanges.  Electrical requirements and environmental considerations are the same as 
with the TotalVisionTS-FX systems.  (Rack-mount slides are local purchase item.)    

Major operational switches as well as access to the USB port and DVD-RW drive are behind 
key-locked panels. 
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Cabling and Connections 
Prior to pulling cable, the installer should determine the best and shortest route between 
the transaction window, ATM, surveillance cameras, and the FX-Series DVR unit. It is 
important that the shortest possible cable-runs are planned. Keep in mind that the older 
the location, the more abandoned cables that will be encountered under the transaction 
windows, so try not to get entangled in the used and unused cables.    

 

It is very important that cables for existing equipment not be disconnected 
during the IRIS cable installation. Take all precautions not to disconnect 
any existing live cabling from the equipment currently in use. 

 

Bundling Cables 

 All IRIS system cables should be bundled together with cable ties every 2-4 feet 
where they run parallel. Do not bundle IRIS cables together with other vendor 
cabling or power lines.   

 Above drop ceilings, all cables should be tied-up to the building structure or hangers 
so that they do not rest on the drop ceiling.   

 During the pulling process, be sure to make the cables long enough to facilitate tie-
up requirements. 

  Around Fluorescent Lighting 

 Keep all cables at least 12 inches from fluorescent light fixtures.   

Through Walls 

 Do not stress cables against the structure and building equipment when going 

around corners or down through walls. Do not bundle cables together when they run 
down through walls.    

 Try to bring cables through walls below countertops or inside cabinets.  
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UPS Installation  

1. Connect the power cord of the FX-Series System to the regulated and battery  

back-up output of the UPS.   If used, connect the USB cable between the UPS and 
FX-Series system. 

2. Connect the power cord of the UPS to the dedicated 110VAC duplex provided by 
the site electrician.   

3. Do not connect teller line or surveillance cameras to the same UPS supply as the  
FX-Series System is.  Use a separate UPS for any cameras. 

 

 

 

Figure 5 - Sample of Typical UPS 

 

Use a separate UPS for Transaction and/or Surveillance Cameras. 
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FX-Series Computer Connections 
 

              

Figure 6 – Computer Connections 
TotalVision-FX (left) and DVS-FX (right) 

 

1. The FX-Series TotalVisionTS unit contains a built-in LCD with virtual keyboard 
TouchScreen overlay.  For ease of installation, an external monitor and keyboard 
may be connected.  The FX-Series DVS uses external input/output devices.  
Connect the keyboard, mouse, and LCD display to the DVS-FX using the 
appropriate connectors. 

2. Obtain or assemble a CAT5 cable of sufficient length to reach the site Network 
Router, connect the output of the FX-Series Ethernet card to the site router.  

3. If the site is connected using phone lines, locate the RJ11 for the dedicated landline 
and connect an appropriate cable between the RJ11 and the modem on the  
FX-Series unit. 

4. Plug the unit into a UPS back-up supply.  Do not use this UPS as a source of power 
for the teller line or surveillance cameras.  Install a separate unit with the 
appropriate back-up rating for the installed cameras. 
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Video Expansion Multiplexer (VEM) 
Cameras are connected to the FX-Series units through one or two Video Expansion 

Multiplexer(s). Each VEM receives images from up to sixteen (16) cameras. The video 
output of the cameras is connected via coax to the VEM using BNC connectors located 
on the bottom of the TotalVisionTS unit, or on the front of the VEM.  The VEM will emit 
an intermittent tone on loss of communications.  
 

The base 16 video channel TotalVisionTS will consist of one internal VEM.  This unit 
may be expanded to 32 video channels by adding one external VEM and connected via 
supplied data cable.    The DVS consists of only external VEM’s; one for 16 channels, 
two for 32 video channels.  External VEM’s may be mounted using the four case tabs 
and appropriate hardware for the surface the unit is being mounted to.  Be sure to neatly 
route all cables.  Power is supplied via the included USB cable. 
 

In addition to the video connections, the multiplexer contains four (4) data circuits. These 
data circuits are connected to the VEM through CAT5 cable using the RJ45 connectors.  
Each VEM also contains a BNC output connector for a spot monitor, and alarm 
input/output connections.   

                    

Figure 7 – Video and Data Connections 
TotalVisionFX (left) and VEM (right) 

 

The silk-screening on the VEM allows for easy identifying of each video channel connector on either 
VEM#1 or VEM#2.  Channels 1-16 are printed 1-16.  Channels 17-32 are printed with each number within 
a box as shown above (right) 
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Transaction Cameras 
Transaction cameras should be installed to the left or right of each transaction window 
and approximately 28”-30" from the normal customer position as they are standing in 
front of the window during transactions.   

 Make sure that cameras do not interfere with other equipment.   

 After all cameras are connected and tested, align them using a string and fasten 
them to the countertop. They should be positioned to get as close to a "full face" 
view of the customer making the transaction as possible.   

 IRIS Tower Cameras and Sign Cameras are supplied with a fixed focal length lens. 
No field adjustment is required.  For brightly lit lobbies IRIS offers its Total Light 
Control (TLC) Cameras with wide dynamic range circuitry. 

 

The cameras are usually numbered from left to right as viewed from the perspective of a 
customer standing in line at the transaction window.  

                                                                        

Figure 8 – IRIS Transaction Cameras 
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Surveillance Cameras 
Surveillance cameras are mounted to walls and ceilings to monitor the platform, 
transaction window, vault door, exits, drive-up facilities, night depository, and other 
sensitive security areas. Surveillance cameras are programmed to take pictures at timed 
intervals. The images are saved based on a comparison between the current and prior 
image for changes that exceed the set threshold.  
 

Some surveillance cameras can be powered by a separate 24VAC power supply. To 
prevent video synching problems during camera switching, ensure that the AC phasing 
is the same on all cameras. After terminating the coaxial and power cables to the 
camera, work the excess service loop back into the wall or ceiling, and cover the 
exposed cables with an appropriate length of plastic cable sheathing. 
 
When installing surveillance cameras outside, in ATMs, or indoors where large 
uncovered windows are present, be sure to consider all light conditions throughout the 
day. The use of wide dynamic range or IRIS TLC cameras may be required.   

 Do not point cameras directly at high-level light sources (i.e., the sun or flood lights), 
and exterior lighting that could flood the camera after dark.   

 If necessary, use auto-iris lens on cameras that are located in areas where there 
will be wide variations in light levels through the course of the day.   

 Do not point the camera in the direction of a high traffic area, i.e. “main highway.” 
This may cause excessive storing of images for with no practical purpose. 

 If a camera is to be mounted outside, it is necessary to enclose it in an appropriate 
housing that will provide security for the camera and cabling.  

 Consider the weather when choosing the camera housing. If high humidity levels 
are present during certain portions of the year, it may be necessary to install a 
heater module in the camera enclosure to prevent lens fogging during cool or wet 
seasons. 

 Interior and exterior cameras can accept different focal length lenses. The lens 
should be chosen so that the head height of an adult person standing at the teller 
window, ATM, or center of the scene is displayed as one-inch high on a 9” video 
monitor. 

 Focus the camera at the center of the displayed scene or location of the person 
involved in the transaction. 
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How to Use the TouchScreen 
The FX-Series TotalVisionTS 12.1” LCD display includes a TouchScreen overlay 
enabling the user to input commands via a virtual keyboard. 
 

To activate the TouchScreen keyboard press 
the KB button in the lower right corner of the 
screen. 

To minimize the keyboard press the Min 
button above and to the right of the cursor 
pad. 

                                                                                                                                                                                                  
 

 
 
 

To use a “right mouse button” function (i.e., print a viewed image) press the Ctrl / Min 

keys, and then tap the screen.  The right mouse button function list will now appear.  
Note:  The “right mouse button” function is limited on an XP Embedded OS system. 

 
Use caution to prevent damage to the TouchScreen surface.  Do not use any sharp 
objects on the screen surface.  Keys are easily activated by a light, consistent touch. 
The use of a stylus or similar device is recommended. 
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When the IRIS System is operational, this is the standard display screen. 

 
Note: Sample is of TotalVisionTS screen, with its KB button in the lower-right corner. 

To access the IRIS second or third level system functions, first click on the Maintenance 
button. Then insert one of two (2) passwords. 

 

Call IRIS Customer Service Department at 888.451.4646 for the passwords, if needed. 
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Displayed is the IRIS Control Pannel Screen. 

 

By entering the other password you will be taken to the IRIS desktop.  
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You may also access the IRIS Application from this screen by clicking-on the 
IRIS DVS icon. 

Select: File, then enter the Password.  Call IRIS Customer Service Department for any 
needed assistance. 

From this screen, the proper method to shut down the system is to click the 
Shut Down icon . 

Never turn off the switch on the power supply or unplug the AC cord to shut down the 
system.  You may also use the Unit Shut Down option from the Control Panel screen. 
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To configure the IRIS Applicaton, select: Config then, Configuration. This will take you to 
the third level installation functions screen. 



 IRIS FX-SERIES DVS SERVER  

 

IRIS FX-Series DVR’s 32 001.09  

 

You are now in the Configuration program. From here, you are able to enter the number 
of available cameas, name the cameras, change the frame rate if necessary of each 
camera independently of the others, setup transaction protocalls, program video alarm 
masking, scheduld camera operation times and so on. 
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System Configuration 
 

System configuration of the IRIS FX-Series Server involves the process of setting-up 
system specific functions and programming. 

The IRIS FX-Series Server configuration is done using the Main Menu and various drop-
down menu selections from the IRIS Configurator application, and a portion of the 
Windows set-up application. The system is shipped with all necessary CDs containing 
drivers, programs and updates. Store these CDs near the system for emergency access. 
These CDs may be required to make changes or reload information should the system 
settings become corrupt during configuration.  

Configuration options will vary based on selecting the Advanced option from the 
Configuration screen.  The chart on the next page lists the additional functions when 
Advanced is checked. 
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IRIS Configuration Menu Options 

Standard  Advanced 

Video 

Cameras 

  Port Configuration 

Video Parameters 

Captions 

Video Output 

Schedule 

Video 

Cameras 

  System Configuration     

  Port Configuration 

  Name Assignment 

Image Selection 

Video Parameters 

Captions 

Video Output 

Schedule 

Events 

  Transactions 

  ATM Transactions 

  TCP/IP Monitoring 

  TCP/IP ATM Configuration 

  Alarm Configuration 

Events 

  Transactions 

  ATM Transactions 

  TCP/IP Monitoring 

  TCP/IP ATM Configuration 

  TCP/IP Capture 

  Alarm Configuration 

Site Data 

  Site Map 

  Remote Monitoring 

  Site Identification 

  Version Info 

  Modem 

Site Data 

  Site Map 

  Remote Monitoring 

  Site Identification 

  Version Info 

  Modem 

  Com Ports 

    Primary 

    Slave 

  System Health 

Files 

  Disk Usage 

Files 

  Disk Usage 

  Activity Log 

  Status Log 

Help 

  Help Topics 

  About 

Help 

  Help Topics 

  About 
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Set-up Network Addressing and Protocol 

The first step in customizing the IRIS DVS Server to the site is to install the appropriate 
network addressing and protocol.  

There are two ways to configure the network address:  

1.    From the Main screen, press the Maintenance function and enter the correct 
password. You will be able to directly access the TCP/IP functions by pressing the 
LAN Settings button. 

2.    Normal LAN configuration is accessed by selecting the Control Panel and double-
clicking the Network icon. Then double-click on Local Area Connection and choose 
Properties.  

On the General tab, only the IP Address information will be modified.  

1. Scroll down to Internet Protocol (TCP/IP) click on it, then click on Properties. 

2. Click in the “Use the following IP address box. 

3. Enter the following information for the site: 

IP Address - Check with the network administrator to determine the IP address 

assigned to the DVS server. Each device on the network will have a unique address. 
Normally the first three (3) fields will be the same as the rest of the site and the fourth 
(4

th
) field will be used to identify a specific device at that site.  

Subnet Mask - In most cases, this value will be 255.255.255.0. Check with the 

facility network support group for verification. The network administrator may assign 
a different subnet mask number.  

Default Gateway - The first three (3) fields will be the same as the IP address 

described above. The fourth (4
th

) will be the one set-up by network support group. 

4. Once the information is entered, click the APPLY button, then click OK twice.  

5. Exit the Control Panel.  

6. Restart the FX-Series unit to apply the new parameters.  
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Connect to a Network Time Server  
For networks that have a Time Server, the installer must sync the digital video server to 
the network. The name of the Time Server must be obtained from the network 
administrator and the following command must be entered at a DOS window or the Start 
> Run command line: 

 

 NET TIME \\SERVER_NAME /SET /Y where SERVER_NAME is the name of the Time 

Server. 

 

 

 

Not all networks have a Time Server; therefore, this setting is optional. 
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IRIS Configurator 
IRIS Configurator is a support component that allows the SYSOP user to perform 
various system set-up and maintenance configurations for the DVS Server. The 
application provides a convenient method of changing and setting system parameters 
and is designed for either local access (through Bank IRIS application) or remote access 
(through IRIS Inquiry). The operation of the program is exactly the same at either 
location only the method of starting the program is different. 

 

 

For user convenience, Quick Start-up and IRIS-DVS Programming 
instructions have been included in the Quick Reference section on 
page 132. 

 

Local Access 
Local access of IRIS Configurator allows a user direct access to the settings and system 
parameters. Generally, the Start Menu will contain a shortcut to the IRIS DVS 
application. When the application is selected, the program will be executed, the default 
menu of the IRIS DVS system will be displayed, and the application will be running 
either in minimized or normal mode.   

1. To access the IRIS XP Application, select File > Password. A Password dialog box 

will be displayed. Call The Security Center for the password. Enter the password 
and click OK.   

2. To start the IRIS Configurator program, select Config > Configuration.  
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Typical Set-up Procedure for IRIS Configurator 
The basic procedural workflow to configure the DVS Server is: 

1. Specify the Last Logical Camera that may be directly viewed by a remote user by 
selecting Video > Cameras > System Configuration   Refer to page 45. 

2. Assign a Port to each logical camera number by selecting Video > Cameras > Port 
Configuration. Refer to page 45. 

3. Assign Descriptive Camera Names to each logical camera number by selecting 
Video > Cameras > Name Assignment. The descriptive camera name may also 

be assigned from the Camera Properties dialog box during Port Configuration. 
Refer to page 50. 

4. Configure the Image Selection by defining the Compression Factor (default:  5.0), 
setting the Pixel Delta (default: 5.0) and Pixel Change Percentage (default: 5.0), 
and enabling Lumen Compensation by selecting Video > Image Selection. Refer 

to page 54. 

5. Set the amount of time that the IRIS system will wait for the frame capture board to 
capture an image after the VEM has changed channels by defining a video sync 
time and recovery time (does not apply to the FX-Series systems.) Options are also 
available to show and set video resolution. Refer to the Video Timing section 
presented on page 55.    

6. Use the IRIS Scheduler to set ON and OFF periods to indicate when the 
surveillance cameras are active using the IRIS Scheduler. These periods may be 
specified in one (1) hour segments and can be different for each day of the week. 
Refer to page 60. (Leave as default.) 

7. Select the Transaction Protocol, define the number of images per transaction, and 
enable the system to capture transaction images whether or not they match the 
selected Transaction Protocol, by selecting Events > Transactions. Refer to page 

64. 

8. Define the ATM Receipt Information with respect to the image display and receipt 
display by selecting Events > ATM Transactions. The typical lines for an ATM 

receipt to display system-defined data will be lines 2, 5, and 10. Refer to page 67. 
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9. Set the TCP/IP ATM Configuration by defining the method for decoding the receipt 
data from an ATM to extract the transaction number by selecting Events > TCP/IP 
ATM Configuration. Refer to page 70. 

10. Set-up Network Monitoring by configuring a network device for Transaction 
Monitoring by selecting Events > TCP/IP Monitoring. Refer to page 75. 

11. Enable an Alarm and set specific configuration options by selecting Events > Alarm 
Configuration. From this menu, the user may also configure the Alarm Inputs for 

two alarms. Refer to page 76. 

12. Configure the Site Map to enable a remote viewer to view a Site Map and locate all 
cameras by selecting Site Data > Site Map. The Site Map must have been 

generated prior to configuration. Refer to pages 95 and 141. 

13. Specify the number of video and data ports to report status info during Remote 
Monitoring by selecting Site Data > Remote Monitoring. Refer to page 83. 

14. Enter site name by selecting Site Data > Site Identification. Refer to page 84. 

15. Verify the version information by selecting Site Data > Version Information. Refer 

to page 85. 

16. If a modem is installed Enable Modem Operation, select Site Data > Modem. Refer 

to page 86. 

17. To set the Disk Allocation parameters, select Files > Disk Usage.  Refer to page 

90.  Specify the number of days the surveillance images are to be saved (default: 
90), define the amount of reserved disk space (default: 8000), define the Number of 
Transaction event images (default: 7), and specify the minimum age of transaction 
images (default: 365). 

18. Configure the number of days to save Activity Log data (default: 90) select Files > 
Activity Log.  Refer to page 93. 

19. To set the maximum size for the Status Log, select Files > Status Log.  Default: 

500.  Refer to page 94. 

Do not change the settings in items #17, #18, or #19 unless directed by the 
IRIS Customer Service Department. 
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IRIS Configurator via Remote Access 
Remote access of the IRIS Configurator is limited to users that have the SYSOP access 
level. This application is mainly designed for service and maintenance, and as such 
should not be used for normal operation.  

1. Log-on to the network and double-click the IRIS Inquiry icon on the desktop, or from 
Start menu. 

2. Select the CONNECT TO A REMOTE SITE button (or go File > Connect > Remote 
Site…) 

3. Choose the Remote Location name, highlight it and click CONNECT.  

4. If the location is not in there, type the new name in “Remote Location” window, 
enter the phone number or IP address, select ”LAN” or “Modem” in the connection 
area, and “Server” (for IRIS v10.00 and later). Click “New” to create entry. You will 
be asked if you want to connect, click “Yes.” 

5. Enter the User ID and Password, and click OK. Call The Security Center for the 

access user name and password. On successful log-on, the “Connection Status” 
confirmation window will be displayed with a message of what location it is 
connected to. 

6. Click OK, and then select Config > Get Rmt Configuration to open the IRIS 

Configurator application.   
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User Interface 
The IRIS Configurator application has been designed with a familiar and user-friendly 
work environment. The user may easily enter and access data using familiar data 
controls such as text boxes, drop-down menus, radio buttons, selection lists, and check 
boxes.   

Application Window 

The system prompts, and all dialog boxes will be displayed within the application window 
using drop-down menus and selection boxes.   

 

Horizontal 
 Menu Bar 

Application 

 Window 

Title Bar 
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The IRIS Configurator Main Menu items are included on a horizontal menu bar that 
appears across the top of the application window. 

 

MENU ITEM DESCRIPTION OF FUNCTIONS 

OPERATION Exits the IRIS Configurator application 

VIDEO Cameras - Allows the user to configure the system cameras by assigning 
a number, name, and identifying the location. This menu item also allows 
the SYSOP to define the port assignment and enter the Last View value.   

Image – The image selection is used to set-up the compression factor 
and Lumen compensation.   

Video Timing – This option is used to set-up the amount of time the 
system will wait for the frame capture board to capture an image after the 
VEM has changed channels by defining the Video Sync Time and Video 
Recovery Time. The option also allows the user to enable the Video 
Resolution.  

Captions - Enables the user to add captions to the printed image. 

Video Output – Allows the user to select specific cameras to be sent to 
an external monitor. The user can also specify the sequence time. 

Schedule – Allows the user to select motion detection to save images 
during off periods. 

 

EVENTS 

Transactions – This option allows the user to set-up the operation of the 
transaction cameras by selecting the protocol, defining the number of 
images per transaction. The user may also enable the Print All 
Transaction Events option and enter a customer field size.   

ATM Transactions – Configures the set-up for the transaction receipt 
information and how it will be saved with the image, enables the user to 
specify color and background color parameters and set-up how the ATM 
receipt data will be displayed.  

TCP/IP Monitoring – Used to specify the TCP/IP network address to be 
monitored.   

TCP/IP ATM Configuration – Used to set-up how the receipt data from 
the ATM will be decoded to extract the transaction number.  
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MENU ITEM DESCRIPTION OF FUNCTIONS 

EVENTS 

(CONTINUED) 
Alarm Config – Allows the user to set specific reporting parameters 

for sending an alarm and to enable up to two alarms.  

SITE DATA Site Maps – Once a site map has been generated, this menu item 

allows the SYSOP to set-up the information for the site map that will 
be displayed to the user.   

Remote Monitoring - This dialog box is used to identify which ports 

should be monitored to prevent unused video and data ports from 
being reported as bad or showing no activity. 

Site Identification – This configuration dialog box is used to set the 

site name and read the software S/N (registration information).   

Version Info – Display the current version number of the IRIS 

Inquiry software.  

Modem – Used to enable modem access, debug messages, and 

timeout period.   

Com Ports – Used to set-up communication interface for each VEM 

unit. 

System Health – This option is used to monitor the VEM activity. 

FILES Disk Usage – Sets up how the IRIS Inquiry system will be used and 

determine the parameters for the memory management algorithm.   

Activity Logs – Defines the number of days to save activity that will 

be displayed on the Activity Log. 

Status Logs – Allows the user to set the maximum file size to be 

logged. 
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Camera Configuration 

The System Configuration menu item is used to specify the last logical camera that 

may be directly viewed by a remote user and to select the camera type.   
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Last View 

Last View specifies the last logical camera that may be directly viewed by a remote user. 
When a remote user attaches to an IRIS system, one option is the capture and 
immediate retrieval of an image from a surveillance camera. This immediate display is 
referred to as a Live View.   

This Live View may be requested from a list of cameras supplied to the user using the 
camera name or location. The Last View value limits the number of cameras available to 
the remote user. Any surveillance camera with logical camera numbers exceeding the 
Last View value will not be displayed; however, these cameras will continue to capture 
and save surveillance images. The remote user may view these images using the 
surveillance image retrieval option from IRIS Inquiry.   

Surveillance Camera System Parameters 

1. Select Video > Cameras > System Configuration from the Main Menu to display 

the Surveillance Camera System Parameters dialog box. 

2. Enter a numeric Last View value between 1 and 16, or 1 and 32, to be used as the 
last logical camera that may be directly viewed by a remote user. 

3. Select the camera type. If one or more of the cameras are color, the color option 
must be checked. 

4. Click OK to return to the Main Menu. 

Port Assignment 

The Port Configuration menu item is used to assign a port to each camera, enable 
Motion Detect, and set percent change values. The Port Assignment identifies which 
surveillance cameras are connected to the IRIS System. Surveillance cameras may be 
lobby cameras and/or transaction cameras. Cameras are installed in sequential order 
starting with logical camera number one (1). To enable surveillance cameras, the user 
will select the appropriate camera number, enter the port number that is used for this 
camera, check the Enabled box, and enter a camera name in the text fields. All cameras 
that are enabled will be monitored on system start-up. 
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Monitor Illumination 

Each system has the ability to automatically perform ATM light monitoring and generate 
an alarm if the light level falls below minimum recommended levels. When the Monitor 
Illumination function is enabled, the system will monitor the camera and generate an 
alarm if the level falls below a set value.   

Calibrate Illumination 

To determine the alarm set value, enable Calibrate Illumination which causes the system 
to monitor the camera video for the next twenty-four (24) hours and automatically select 
the optimum low-light level alarm set value. Once the system is calibrated, the Calibrate 
Illumination will automatically be turned-off by the system and the alarm value (ranging 
from 1-255) will be displayed in the Alarm Level field. Although the user may override 
this number by manually entering a value, it is not recommended.   

Motion Detect 

Motion Detect is used to reduce the number of surveillance images saved. By comparing 
the previous image with the current image, the system determines if there has been 
sufficient change in the picture content to indicate that movement has occurred. In the 
detection process, each pixel in an image is compared with the previous image to 
determine if the pixel content has changed (pixel delta). The total number of pixels that 
have changes in the image is then compared with the pixel change value to determine if 
sufficient motion has occurred. Pixel change and pixel delta values are set from the 
Image Selection menu.    

Percentage Change 

The Percentage Change value is highly dependent on the type of image and the field of 
view.  

 For close-up (head and shoulder) images a typical percentage change value 
would be 5-10%. 

 For a wide angle view image, a typical percentage change value would be  
2-5%. 

 Default setting is 5%. 
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Camera Properties 

1. Select Video > Cameras > Port Configuration from the Main Menu to display the 
Camera Properties dialog box. Each logical camera number (1-16, or 1-32) will be 

displayed in a tabbed format.  The user will click the appropriate camera number to 
display the port configuration fields. 

 

 



 IRIS FX-SERIES DVS SERVER  

IRIS FX-Series DVR’s 48 001.09  

 

2. To enable the port for the selected camera, click the Enabled check box.  

 

 

If the camera name was entered during Camera Name Assignment, it will be displayed in 
the Camera Name text field. If a name is not entered, enter the name in this field.      

3. For cameras that monitor outdoor terminals such as an external ATM or any camera 
that must maintain a set level of illumination, enable the Monitor Illumination and 
Calibrate Illumination. The system will set the Alarm Level value automatically. 
(Refer to Set Camera for Illumination Monitoring.) 

4. If a different frame rate is desired, uncheck Motion Detect. You are now able to 

change to a different capture rate for that specific camera (32 channel system 
shown below.)    The Capture Rate will calculate automatically based on the number 
of enabled video ports.  This rate may be unique for each of the 16 video channels 
by VEM (i.e., VEM#1 may be 7.5, while VEM#2 is 15.) 

 

Specify the port 
number for the 
camera. Each port 
number is assigned 
to a logical camera 
number. The port 
numbers are 
assigned as ports 1-
16 or 1-32 to match 
the BNC video ports 
on the TotalVision-
FX or DVS-FX. 
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5. Percentage Change. Enter the minimum amount of change necessary to result in a 
saved image in this Field.  Recommended value is 5% (default). 

6. For cameras that monitor outdoor terminals such as an external ATM or any camera 
that must maintain a set level of illumination, enable the Monitor Illumination and 
Calibrate Illumination. The system will set the Alarm Level value automatically. 
(Refer to Set Camera for Illumination Monitoring.) 

7. Repeat steps 1-7 as described above for each camera.  

8. Click the APPLY button to save the changes and configure another camera, or click 
OK to save the changes and return to the Main Menu.   
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Set Camera for Illumination Monitoring 

1. Check the Monitor Illumination box to enable the function. 

2. To calibrate the system, check the Calibrate Illumination checkbox.  

3. Click the APPLY button to save the changes and configure another camera, or click 
OK to save the changes and return to the Main Menu.   

 

 

By verifying that the area 
the camera is monitoring 
has been properly 
illuminated during the 
previous 24 hour period, 
the alarm level will be 
correctly set to ensure 
that if the illumination 
level falls below that 
setting, an illumination 
alarm will be sent. Do 
not modify the number 
contained in the Alarm 

Level field. 
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Camera Name Assignment 

Lobby cameras are used for surveillance images. When configuring the IRIS system, the 
installer must specify a port camera number and a logical camera number (range from 1-
32) to identify each specific camera on the system. Each camera may also be assigned 
a descriptive name. This descriptive name is then displayed to a remote user to enable 
the user to select the correct camera. If a camera name is not assigned, the system will 
use the logical camera number as the name, by default.   

This dialog box is used to assign a name to each of the surveillance cameras. The 
camera name may also be entered during Port Configuration from the Camera 
Properties dialog box. The text version of the camera name allows the user to readily 
identify the camera. Prior to name assignment: 

 Verify that the surveillance camera is enabled and a valid camera port has been 
assigned during Port Configuration by reviewing the Camera Properties dialog box.   

 Ensure the Last View number has been set since the name assignment will only 
display the camera names up to the Last View camera specified during System 
Configuration using the Surveillance Camera System Parameters dialog box.  

  

 

 

1. Select Video > Cameras > Name Assignment from the Main Menu to display the 

Camera Name Assignment dialog box. 

Camera Number: 
Logical Number 
from 1-32 that 
identifies a unique 
camera.  
 

Camera numbers 
are assigned in 
order and no 
camera numbers 
are skipped. 
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2. Increment the camera number using the  and  buttons and enter a numeric 
value for the logical camera number (range is 1-32).   

3. Enter a camera name in the text field.  The following are typical camera names: 

Transaction Window # (From left to right from the perspective 
of the customer.) 

Queue Line 

Vault Door 

Safe 

Back Room 

Drive In ATM # 

Drive In Transaction Window # 

Inside ATM # 

Exterior ATM # 

Exit - North, South, East, or West 

Night Drop 

Parking Lot - North, South, East, or West 

 

4. Click UPDATE after change of each camera name to save the changes. 

5. Click OK to return to the Main Menu. 
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Image Configuration 

The image selection configuration screen is used to define the compression factor, 
lumen compensation, and pixel values used when motion detect is enabled. 

Compression Factor 

The Compression Factor determines the amount of compression that should be used for 
each image. A larger number will result in a small image file resulting in great storage 
space, but poor quality image. A lower number will result in a large image file size and a 
higher quality image. This value ranges from 1-9 with the normal setting at 5. 

Pixel Change 

Pixel Change values are used by the motion detect algorithm to determine if movement 
has occurred. This value represents the number of pixels that must have changed in a 
series of images to indicate movement has occurred. Pixel changes are expressed in 
percent and range from 1-100%. A typical setting is between 3% and 8%. This pixel 
change value is used as the default setting when a number is not specified in the 
Camera Properties dialog box.   

Pixel Delta 

The Pixel Delta value is used to determine the amount of change to mark the pixel as 
changed from one image to a second image. Pixel delta values are also expressed in 
percent and range from 1-100%. Default is 5.10%.  The lower the percentage, the less 
motion it takes to trigger a recording. 

Lumen Compensation 

Lumen Compensation is an automatic feature that compensates for the gradual lighting 
change that occurs with the time of day. If the Lumen Compensation does not occur, the 
changing contrast could be detected as movement by the motion detect algorithm.   
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Image Selection 

1. Select Video > Image Selection from the Main Menu to display the Image 

Selection dialog box.  

2. Enter a numeric value for the Compression Factor, using a range of 1-9. 
Recommended compression value is 5.   

3. Enter the Pixel Change (typical settings range between 3% and 8%). 

4. Enter the Pixel Delta values in percent.  

5. Enter the number of surveillance images taken when motion is detected. The 
number of images saved is based on detected motion between two consecutive 
images. 

6. To enable Lumen Compensation, which applies automatic adjustments for gradual 
light level changes, click the check box.   

7. Click OK to return to the Main Menu.   
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Video Timing 
Video Timing is used to set the amount of time that the IRIS system will wait for the 
frame capture board to capture an image after the VEM has changed video channels. 

Video Sync Time 

Video Sync Time is the amount of time (in milliseconds) the system must wait for the 
video capture card(s) to re-sync to the new video source and capture a new image.  
When a VEM channel changes, its video capture card must re-sync to the new camera 
horizontal and vertical sync before an image can be captured.  Note: this does not apply 
to the FX-Series systems. 

Video Recovery Time 

Video Recovery Time occurs when a VEM selects a video channel that has no video 
signal.  The video capture card may have trouble establishing sync on the next good 
video channel.  This problem is due to requiring the restoration of the DC balance.  To 
compensate for this problem the Video Recovery Time is used as the delay amount 
instead of the Video Sync Time on the next video channel after a bad video source has 
been detected. 

Show Video Resolution 

This option is primarily a diagnostic feature. When enabled, the system will log the 
selected video resolution to the error file. 

Set Video Resolution 

The X and Y represent the number of pixels to be recorded in each image. The options 
are standard and full-size which indicate to the system to select predefined images sizes 
of 320 x 243 (Default) or 640 x 480, respectively. These images may be manually 
overridden; however, sizes greater than full-size will not be accepted. The higher 
resolution (full size) image requires approximately four times the hard drive storage 
requirements.  

Contact the IRIS 
Customer Service 
Department for the 
correct values for 
these two settings.  
These settings 
should not be 
changed unless 
directed to do so. 
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Do not check the Show Video Resolution in normal operation. 

1. Select the desired image size. 

2. Click “OK” to save changes. 

 

Since resolution affects image file size, it is highly recommended the standard size 
should be used as the default selection to provide the best tradeoff between storage 
capacity and image quality. 
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Video Parameters 

To set “On Screen Captions” 
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To set “Video Output” 

 
 

You may select whatever camera(s) desired for spot monitoring by Video Expansion 
Multiplexer – Cameras 1-16 on VEM#1, Cameras 17-32 on VEM#2. 

 

The example above shows Cameras 1-4 on VEM #1 assigned to spot monitor #1.   
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The example below shows Cameras 1-14 of VEM #2 assigned to spot monitor #2 – 
these are actually Cameras 13-29 on a 32 video channel FX-Series system. 

 

 

 

The Scan Time is the dwell setting, expressed in 100mS increments, and can be unique 
to each spot monitor.  1000ms = 1 second.  The spot monitor output is a BNC 
connector.   (Default = 10.) 
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Video Surveillance Schedule 
Access to the Surveillance Schedule dialog box is accomplished using Video > 
Schedule.   

The IRIS system supports 
scheduling of ON and OFF periods 
using the IRIS Scheduler. The user 
may program when the 
surveillance cameras are active 
using these ON and OFF periods 
which may be specified in one (1) 
hour segments and can be 
different for each day of the week. 
Once set, the schedule applies to 
all surveillance cameras.  

During an ON period the system 

will always be enabled to save a 
surveillance image. If a camera has Motion Detect enabled then only images that show 
motion during the ON period will be saved. If a camera has Motion Detect disabled then 
the system will save all images from that camera during the specified ON period. 

During OFF periods the IRIS system will ONLY record surveillance images if the “Save 
motion detection images during OFF periods” option on the Surveillance Schedule 
dialog screen is checked and the system detects that there has been motion between 
individual frames for any of the surveillance cameras. It is not necessary that the Motion 
Detect option on the individual surveillance cameras be selected for this feature to be 
functional.  

The Video Surveillance Schedule feature only affects surveillance images. Transaction 
and alarm images will be saved as defined elsewhere in this Manual. 
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To enable the schedule feature select the “Enable schedule for all surveillance cameras” 
check box on the dialog box. 

 

To enable the 
schedule feature 
for all surveillance 
cameras check 
this box.  
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S C H E D U L E  B Y  D A Y  A N D  H O U R  

Using the tabs on the Surveillance Schedule dialog box, the user may select the 
individual days of the week. Once a day of the week is selected the ON and OFF 
periods may be set on an hour-by-hour basis for that particular day. 

 

To specify an ON period, select the check box to the left of the time period. There is no 

limitation to the number of time periods selected. If a time period is not selected then the 
system will be in the OFF state during that time range. 

This example shows 
the system set to be 
in an ON state from 
8:00AM to 8:59:59AM 
each Monday. A 
different schedule 
can be set for each 
day of the week. 

x 
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S C H E D U L E R  C O N F I G U R A T I O N  G U I D E  

Mode of Operation 

Enable 
Motion 

Detect for 
Camera 

Surveillance 
Schedule  
Enabled 

Save Motion 
During off 
Periods 

Day and Hour 
Selected 

Record all images all times NO NO N/A N/A 

Record only Images with 
motion at all times 

YES NO N/A N/A 

Save all images during a 
specified day and time. No 
pictures saved at other 
times 

NO YES NO 

Set desired day 
and time when all 
images should be 
saved. 

Save only images with 
motion during specified 
time. No pictures saved at 
other times. 

YES YES NO 

Set desired day 
and time when 
system should 
save images with 
motion. 

Save all images during 
specified day and time. At 
other times only save 
pictures with motion. 

NO YES YES 

Set desired day 
and time when all 
images should be 
saved. 

 

The Enable Motion Detect for Camera function is enabled on an individual camera 
basis from the IRIS Configurator Main Menu by selecting Video > Cameras > Port 
Configuration.  This feature allows selected cameras on a system to be operating in a 

different mode from other cameras on the same system. 
 

The Surveillance Schedule Enabled, Save Motion During Off Periods, and Day and 
Hour Selected functions apply to all enabled cameras and are enabled at the system 
level from the IRIS Configurator Main Menu by selecting Video > Schedule. 
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Transaction Protocol  
As transactions are detected, the IRIS system captures an image and saves it for later 
retrieval using a transaction camera. Transaction information is captured using network 
monitoring. As the information is received, the trigger sequence is determined using the 
Transaction Protocol settings.   

To support a wide variety of teller printer interfaces the IRIS software now includes 
optional teller configuration files. These files can be used to define the nature of the data 
as captured on a TCP/IP network and how to decode a transaction. The teller 
configuration files are similar to the information specified in the generic TCP/IP 
transaction monitoring but the teller configuration files allow a wider range of options 
than available on the generic transaction interface. Refer to the Teller Configuration 
Files documentation presented in the Quick Reference section, on page 153 which 
describes each field in the configuration file.  

Network Monitoring 

The IRIS system monitors traffic on an attached network using a Net Monitor to detect 
transaction information. 

Trigger Sequence 

Trigger sequence is a series of alphanumeric characters sent to a transaction location 
that identifies a transaction has occurred. This sequence generally includes various 
information specific to the transaction, such as location ID, employee ID, and transaction 
number.  

Print All Transaction Events 

This option enables transaction events that do not match the selected Transaction 
Protocol to still result in a transaction image. Any activity on the monitored transaction 
channel will result in a transaction image being captured. If the activity meets the 
requirements of the Transaction Protocol, then the transaction images saved will have 
the captured sequence number and other related image information. If the activity does 
not meet the transaction protocol then the transaction images will be given a sequential 
transaction number.  

The Transaction 
Protocol is set by 
location and built 
into the system.   
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Images Per Transaction 

When a transaction is detected, the IRIS system will capture an image. The Images per 
Transaction determines the number of images captured for each transaction.    

Customer Field Size 

The Customer Field Size is used to modify the operation of the Transaction Protocol. 
This field is set by the system to 0 or 3 depending on the Transaction Protocol used. 
Customer Field size is used in the further refinement of specific customer applications 
and may not be necessary for all customers. Contact the IRIS Customer Service 
Department for specific information on the required setting for this parameter. 

 

Transaction Set-up 

1. Select Events > Transactions from the Main Menu to display the Transaction 
Set-up dialog box.  

2. Using the drop-down selection list, select one of the defined Transaction Protocol 
entries. If the specific location is not listed, use the default.   
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3. Enter a numeric value to define the number of images to be captured with each 

transaction. The  and  buttons may be used to increase or decrease the 
number. 

4. To enable the system to Print All Transaction Events including transaction events 
that do not match the selected Transaction Protocol, check the box.  

5. The Customer Field Size is a value set by the system, depending on the selected 
Transaction Protocol (normally set 0 or 3). 

6. Click OK to return to the Main Menu. 
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ATM Receipt Information 
As ATM transactions are detected, the IRIS system captures an image for the 
transaction and includes transaction receipt information with the image. The saved data 
is three selected lines out of the 12 lines of customer receipt data.  

Image Display 

The ATM Transaction Data dialog box is used to define how the transaction receipt 
information will be saved with the image. The saved Transaction receipt information may 
be displayed using two methods: 

 Overwriting the text of the receipt on the image.  

 Enlarging the image area and showing the receipt information in the 
enlarged portion.  

To help highlight the receipt information, the color for the text and the color of the 
background for the text may also be changed. 

Receipt Display 

The section displayed at the bottom of the dialog box is used to define the line 
placement for each of the three system-defined display lines for the ATM Receipt. To 
reduce the amount of data captured with each transaction, the IRIS system has selected 
three lines from the receipt and captures this data with the transaction image. The three 
lines selected are as follows:   

Display Line 1  - Date/Time/Company Location (usually Line 2 of the ATM receipt.) 

Display Line 2 - Type of Transaction & Employee ID # (usually Line 5 of the ATM receipt.) 

Display Line 3  - Customer Account # and Sequence # (usually Line 10 of the ATM receipt.) 

This set-up information may be different for each ATM or ATM network. If the site 
requirements are different from the above list, determine the site requirements with the 
aid of an ATM receipt. Looking at the receipt count the lines shown and select the 
appropriate line numbers for the requested information. 

If you have any difficulty 
setting up the ATM 
transaction information, 
contact the IRIS Customer 
Service Department for 
specifics on setting this 
parameter for the ATM 
network. 
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1. The  and  buttons are used to scroll through the line numbers (1-12). 

2. To enable the selected line number, click the Display Line check box. 

3. To assign one of the system-defined display lines to the selected line number, 
click the Line 1, Line 2, or Line 3 selection button. 

4. To save the display properties, click the UPDATE button.   

To remove the display properties from a line, select the line number, uncheck the 
Display Line box, and click UPDATE to save the setting. 
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ATM Transaction Data 

1. Select Events > ATM Transactions from the Main Menu to display the ATM 
Transaction Data dialog box.   

2. Select one of the display methods by clicking the box and entering a check for the 
selected method.    

3. Using the drop-down selection list, select the text color. Options are black, white, 
red, green, or blue. Black is normal. 

4. Using the drop-down selection list, select the background color. Options are black, 
white, red, green, or blue. White is normal. 

5. To set-up the lines for an ATM Receipt where the system defined data will be 
displayed on lines 2, 5, and 10, use the following instructions: 

Using the  button, scroll to line 2. Check the Display Line box and select Line 1. 
Click Update. 

Using the  button, scroll to line 5. Check the Display Line box and select Line 2. 
Click Update. 

Using the  button, scroll to line 10. Check the Display Line box and select  
Line 3. Click Update. 

Click OK to save the settings and return to the Main Menu. 
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TCP/IP ATM Configuration 
The dialog box TCP/IP ATM Setup is used to set-up the method for decoding the receipt 

data from an ATM to extract the transaction number using IP address. This extracted 
number is separate from the information contained in the Display Lines for the Image 
Display and Receipt Display.  

Transaction Number Source 

There are two (2) options for determining the Transaction Number Source: Camera 
Field, or Print Field. These fields determine where the system will recover the 
transaction number information. 

 When Camera Field is selected, the user may only specify the Employee Number 

assigned to this ATM device and the Location Number. Both fields are associated, 
along with the Transaction Number, with the image.   

 When Print Field is selected, the user must specify the line number and character 

position where the transaction number appears on the ATM printed receipt.   

ATM Configuration Style 

In the TCP/IP Monitoring dialog box, the user specifies the type of device that is used to 
determine how to retrieve data from the LAN. Once the ATM data is retrieved, the 
TCP/IP ATM Configuration dialog box determines how to decode the ATM receipt data 
to extract the transaction information used to associate the image to a transaction. The 
ATM Configuration Style is used to link the TCP/IP configuration to a specific TCP/IP 
monitored device.  

The style number is a value selected from the TCP/IP ATM Setup dialog box when 

defining the ATM Configuration Style. When the TCP/IP Transaction Monitoring is 
enabled from the TCP/IP Transaction Monitoring dialog box, and an ATM device is 
selected, the Configuration Style field will activate and the user must enter the ATM 
Configuration Style number in the field to provide the link. 
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TCP/IP ATM Set-up 

1. Select Events > TCP/IP ATM Config from the Main Menu to display the TCP/IP 
ATM Setup dialog box. 

 

2. Select the Transaction Number Source. Options are Camera Field and Print Field. If 
Print Field is selected, the Line Number and Character Position fields will be 
activated.  

3. Enter the Teller Number. Normally this number is 99, the second 98, etc. If more 
than one ATM exists at a location, the ATM numbers are numbered from 99-90. 

4. Enter the Branch Number for this location. 

5. If Print Field was selected as the Transaction Source, enter the line number. This 
line number does not have to be one of the displayed lines as specified in the ATM 
Transaction Data dialog box, but is normally included for reference as the last 
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displayed line. The placement of this information is ATM network dependent and is 
best determined by viewing an ATM receipt. Looking at the receipt, count the lines 
and select the line number containing the transaction number. 

6. If Print Field was selected as the Transaction Source, enter the Character Position. 
Count the number of character positions from the left side of the ATM receipt 
(including spaces) to the first position of the transaction number.  

7. Click UPDATE to save this information and leave the dialog box open and click Next 
to move to the next ATM, or click OK to save the information and return to the Main 

Menu.  

Typical Settings for NCR-Style TCP/IP ATM 

1. Select Events > TCP/IP ATM Configuration from the Main Menu to display the 
TCP/IP ATM Setup dialog box.   

2. Using the NEXT and PREVIOUS buttons, scroll to select one of the previously defined 

ATM Configuration Styles (1-4). This value will be entered in the TCP/IP 
Transaction Monitoring dialog box as the Configuration Style number.   

3. Select Camera Field as the Transaction Number Source. 

4. Enter the Teller Number. Normally this number is 99. If more than one ATM exists 
at a location, the ATM teller numbers are numbered from 99-90. 

5. Enter the Branch Number for this location. 

6. Click UPDATE to save this information and leave the dialog box open or click OK to 

save the information and return to the Main Menu.   

Typical Settings for Interbold-Style TCP/IP ATM  

1. Select Events > TCP/IP ATM Configuration from the Main Menu to display the 

TCP/IP ATM Setup dialog box.   

2. Using the Next and Previous buttons, scroll to select one of the previously defined 
ATM Configuration Styles. This value will be entered in the TCP/IP Transaction 
Monitoring dialog box as the Configuration Map number.  

A maximum of 4 
ATMs may be set-up 
per VEM. Up to 16 
ATMs may be 
monitored via 
TCP/IP. 



IRIS  CONFIGURATOR 

001.09 73 IRIS FX-Series DVR’s  

3. Select Camera Field as the Transaction Number Source. 

4. Enter the Teller Number. Normally this number is 99. If more than one ATM exists 
at a location, the ATM teller numbers are numbered from 99-90. 

5. Enter the Branch Number for this location. 

6. Click Update to save this information and leave the dialog box open or click OK to 

save the information and return to the Main Menu.   

TCP/IP Network Monitoring 
This dialog box is used to set-up Network Monitoring by configuring a specific network 
device for transaction monitoring. Since the IRIS system can monitor network traffic to 
determine when a transaction has occurred, this dialog box is used to specify the 
TCP/IP network address that should be monitored. When TCP/IP Transaction 
Monitoring is enabled, the IRIS system uses the data from this dialog box to determine 
how the data should be handled.   

To support a wide variety of teller printer interfaces the IRIS software includes optional 
teller configuration files. These files can be used to define the nature of the data as 
captured on a TCP/IP network and how to decode a transaction. The teller configuration 
files are similar to the information specified in the generic TCP/IP transaction monitoring 
but the teller configuration files allow a wider range of options than available on the 
generic transaction interface. Refer to Teller Configuration Files documentation 
presented in the Quick Reference section on page 153 describes each field in the 
configuration file. 

Configuration Map 

Additionally, when an ATM device is selected, the Configuration Map field will activate. 
The user must enter the numeric value selected as the ATM Configuration Style in the 
TCP/IP ATM Setup dialog box. The Configuration Map is used to link the TCP/IP 
configuration to a specific TCP/IP monitored device.   

This is a global 
enable for all 
TCP/IP monitor 
activity and has no 
effect on remote 
users connecting to 
the network.    



 IRIS FX-SERIES DVS SERVER  

IRIS FX-Series DVR’s 74 001.09  

 



IRIS  CONFIGURATOR 

001.09 75 IRIS FX-Series DVR’s  

TCP/IP Transaction Monitoring 

1. Select Events > TCP/IP Monitoring from the Main Menu to display the TCP/IP 
Transaction Monitoring dialog box.   

2. To enable TCP/IP Transaction Monitoring, click the check box.  

3. Using the Next and Previous buttons, scroll to select one of the system-defined 
Monitor Channel values. This value represents the data channel number assigned 
to the current address. 

4. Enter the appropriate address. The MAC Address and TCP/IP Address are used to 
identify a specific device on the network. If the monitored device uses a static IP 
address then it is only necessary to enter the TCP/IP address in this section. If the 
monitor device uses a dynamic IP address then it is necessary to enter the MAC 
address for the device. In no case is it necessary to enter both the MAC and TCP/IP 
address to determine the MAC address, refer to the Quick Reference section, page 
158.  

5. Enter the Camera Port Number, which specifies the port that will be used to take a 
picture when the specified LAN address has a transaction.   

6. Using the drop-down selection list, select the device type.   

7. If an ATM device is selected, the Configuration Map field will activate. The user 
must enter the numeric value selected as the ATM Configuration Style in the 
TCP/IP ATM Setup dialog box. 

8. Click Update to save this information and leave the dialog box open and click “Next” 
to repeat a set-up of additional ports associated with transactions or click OK to save 

the information and return to the Main Menu.   
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Alarm Configuration 
To enable an alarm input, select Events > Alarm Configuration from the  

Main Menu.  

 

Note:  Alarms #1 and #2 are located on VEM #1.  Alarms #3 and #4 are located on VEM #2. 
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Enable Watchdog 
When this option is enabled, the watchdog will monitor the system to verify proper 
operation. If the system fails to operate correctly because of either a hardware or 
software failure, the watchdog circuit will reboot the DVS in an attempt to maintain the 
system. In normal operation this feature should be enabled and should only be disabled 
for testing and diagnostic operations. 

Exclusive Camera Record on Alarm Inputs 
When enabled, this option selects how the DVS will record images when an alarm 
occurs. The system may record images depending on how the alarm is configured.  

 If this option is enabled, the system will capture the number of images set in 
the “Number of samples for each alarm camera view”. Recommended value 
is 1 to 15. All images are saved. 

 If this option is not enabled, the alarm images will be included with the normal 
sequence of images scheduled by the surveillance and transaction 
specifications. 

System Alarms 
The following table defines the alarm conditions monitored by the system. If this option is 
checked, when an alarm condition is detected, it is recorded in the IRISERR.TXT log. 
This error log may be retrieved by the SYSOP using the IRIS Inquiry or IRIS Status 
Manager application.  

In addition to recording the alarm messages in the error log file, the program can 
generate a message to inform a remote device that the alarm has just occurred. If 
enabled, each of the following alarm types may be configured to send a message to a 
remote device. 
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Table 1 - Alarm Types 

ALARM TYPE DESCRIPTION 

REPORT POWER-UP A power-up sequence indicates a normal start-up sequence, and 
generally indicates the system was started normally. 

REPORT REBOOT A reboot sequence indicates the previous shutdown sequence was not 
completed normally. On start-up, the system determines if the last shut 
down was successful, if not, the reboot error is reported. Generally a 
reboot error would indicate one of the following: loss of power, watchdog 
reboot, or manual reboot. 

REPORT VIDEO 

FAILURES 

 

All video cameras are monitored for the image quality. If a camera fails to 
return a good image, the video failure is logged for that camera when the 
image is requested. Video qualities measured include: loss of signal, 
poor signal quality, and inadequate signal level. 

REPORT VEM FAILURE The IRIS VEM is responsible for switching the video signals from 
individual cameras and monitoring transaction data in direct-connect 
installations. Periodically, the DVS sends commands to the IRIS VEM. If 
the VEM fails to respond or reports an internal failure, the VEM failure is 
recorded. 

REPORT DISK FAILURE As images are saved to the hard disk, the success or failure of the save 
action is recorded. If the DVS cannot save an image due to lack of disk 
space or a failure of the hard drive, the disk failure will be recorded. 

REPORT ILLUMINATION 

ALARMS 

 

The IRIS DVS system has the capability to monitor illumination on any of 
the surveillance cameras. (See Camera Properties dialog box). If any of 
these cameras detect the light level has fallen below a set threshold, an 
illumination alarm is generated. 
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The following paragraphs describe how and when the reports will be sent: 

Enable Phone Report 
If enabled, all selected alarm conditions will be sent to the phone number provided. The 
Report Phone Number represents the number of the remote device that will receive the 
alarm messages. These alarm messages will include the following information: 

 Location reporting the alarm. 

 Date and time of the alarm. 

 Type of alarm condition recorded. 

Alarm Inputs/Outputs 
In addition to the System Alarms, the Configurator allows the user to configure two alarm 
inputs. These are the two (2) inputs that are on the Video Expansion Multiplexer (both 
internal and external units). Both alarms offer the same options for configuration. 

         

For Alarm Properties settings, VEM #1 is considered Primary, and VEM #2 is considered Slave. 

This information is sent 
in ASCII format so the 
alarm report may be 
logged using a modem 
and software at the 
receiving computer.    
 
Alarm conditions may be 
queried using the IRIS 
Service Manager 
software included with 
the system. 
 
Alarms are also 
indicated when 
connecting to a site 
using IRIS Inquiry. 
 
Refer to the Manuals for 
Service Manager and 
Inquiry for additional 

information. 
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Alarm Enabled 

If checked, the system will enable the selected alarm. 

Active State for Input 

The user may specify the desired alarm condition to trigger an alarm.  

 If the circuit is normally open, the alarm will be activated on closure, 
therefore select “Closed”.  

 If the circuit is normally closed, the alarm will be activated on opening, 
therefore select “Open”. 

Record Time in Seconds 

When an alarm is detected, the system will record video images for a predetermined 
number of seconds. Use this text field to enter the number of seconds that should be 
recorded by the system. 

Record Surveillance Cameras 

When an alarm is detected, the system will record video images from a predefined 
number of surveillance cameras. Use this text field to enter the camera number(s) for 
the surveillance camera(s) that should be recorded for the duration of the alarm. Multiple 
camera numbers may be entered. If multiple cameras are entered each camera number 
must be separated using a comma. For example: Enter “3, 4, 5, 10” to record video 
images from surveillance cameras 3, 4, 5, and 10.  

Report Alarm 

Each alarm event may be reported to the log file or a remote device. Select the 
destination of an alarm event (if any). If the Phone destination is selected, they will be 
reported to the same addresses specified in the System Alarm Properties.  

Alarm conditions may be queried using the IRIS Service Manager software included with 
the system.  Alarms are also indicated when connecting to a site using IRIS Inquiry.   
Refer to the Manuals for Service Manager and Inquiry for additional information. 
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Alarm Input/Output Wiring  

On the bottom of the FX-Series TotalVisionTS unit there are two alarm inputs. Similar 
inputs are also on each Video Expansion Multiplexer.  These alarm inputs are designed 
to connect to a dry contact relay. Using the Alarm Properties dialog box the alarms can 
be configured to generate an alarm when the relay contacts are open or closed.  

                                                                                      

 TotalVision-TS  VEM 

TotalVision-TS alarm inputs are on the right side of the wire connector under the “IN” 
label. The input channels are labeled “Ch1” and “Ch2”. Connect the alarm wires to the 
“+” and “-“ terminals. Normally if you are using a relay contact to connect to the  
FX-Series system, it is not important to observe the polarity marks. For applications that 
use an alarm system with a polarity sensitive output, you must observe the polarity 
markings. Connect the “+” terminal to the positive terminal of the alarm system and the 
“-“ terminal to the minus terminal of the alarm system.  

The same connections will be found on the VEM, although oriented differently. 
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Alarm Input Specification 

 Maximum voltage between  +  and  –  terminals: 5 VDC 

 Current required to indicate contact closed: 12mA 

Alarm Outputs 

The FX-Series units include two or four Alarm Outputs. These alarm outputs are used 

for custom applications and are not available for general usage.  Contact the IRIS 
Customer Service Department for additional information. 

Alarm Output Specification 

The Alarm Output is a SPDT reed relay with the following contact ratings: 

 Power Switching: 5W Max 

 Voltage Switching: 48VDC (32VAC) 

 Current Switching: 125mA (0.125 A) 

 Current Carrying: 125mA (0.125 A) 

 Contact Resistance: 0.200 ohms 
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Remote Monitoring 

While the IRIS system is running, it is constantly monitoring the status of each of the 
video ports and data ports. This information is then available to remote users so that the 
health of the IRIS system can be checked.  

Since all locations are not configured the same, some locations will use more or less of 
the video and data ports than other locations. To prevent unused video and data ports 
as being reported as bad or showing no activity, the Remote Monitoring dialog box is 
used to identify which ports should be monitored.  

Number of Video Ports Monitored 

All video channels are assigned a unique camera number. This logical camera number 
is assigned in a sequential manner. The Number of Video Ports Monitored should be set 
to the last logical camera number.   

Number of Data Ports Monitored 

Each data port is also monitored for activity. If a data port does not indicate activity for a 
substantial period of time that might indicate a problem with the port since no 
transactions are being recorded from the site. Data ports are also assigned sequentially 
so the Number of Data Ports Monitored should be set to the total number of ports 
connected. 
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1. Select Site Data > Remote Monitoring from the Main Menu to display the Remote 
Monitoring dialog box.  

2. Select the number of Video Ports monitored using the  and  buttons to 
select the number that matches the last logical camera number.   

3. Select the number of Data Ports monitored using the  and  buttons to select 
the number that matches the number of data ports connected.   

4. Click OK to save the settings and close the dialog box.    

Site Identification 
The dialog box is used to enter the site name and display the software registration 
information. The site name entered in this box will be displayed when an IRIS Inquiry 
user connects to the site.   

1. Select Site Data > Site Identification from the Main Menu to display the Site 
Identification dialog box. 

2. Enter the branch name in the text box.   

3. Click OK to save the information and return to the Main Menu. 

 

In most cases, the 
location, company, and 
S/N (serial number) are 
entered during the 
install process and 
displayed here for 

reference.   
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Software Version Information 
When a remote user attaches to an IRIS system, the IRIS DVS sends configuration 
information to the IRIS Inquiry application of the remote user, including the version 
number of the software.  If the system detects the software has not been updated to the 
most current version, the remote user will be given the opportunity to upload the updated 
version of IRIS Inquiry directly from the IRIS DVS site. 

The versions of software installed can be verified through the Configuration menu, too. 

1. Select Site Data > Version Information from the Main Menu to display the Inquiry 
Software Version Control dialog box.  

2. The latest version of the Inquiry and Bank IRIS (Application) software will be 
displayed at the bottom of the dialog box.  If not displayed, enter the current IRIS 
Inquiry version number in the text field.  If this information is unknown, contact IRIS 
Customer Service Department support for assistance. 

3. Click OK to update the software or click CANCEL to abort the update process and 

return to the Main Menu. 

 

  

To disable this update 
function, enter “none” 
in the text field.   
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Modem Set-up (Optional) 
This menu item is used to enable modem operation, enable debug message to help 
identify connection problems, and to enter a no answer time-out value. Additionally, the 
FX-Series system will answer incoming calls based on the ring number specified in item 
5 below.  

1. Select Site Data > Modem from the Main Menu to display the Modem Setup dialog 

box.  

2. Check the Enable Modem Operation box to enable modem operations. To disable 
modem operation, uncheck the box.   

3. Only check the Enable TAPI Debug Messages box if directed by IRIS technical 

department. 

4. Enter a time, in seconds, for a no answer time-out.   

5. Enter a numeric value in the Answer on Ring text box to specify the number of rings 

before the IRIS system will answer an incoming call. 

6. Click OK to save the modem configuration.   
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USB Video Expansion Multiplexer Configuration 

1. Find the usb_mux desktop icon and double click.   

 

2. To assign the external Video Expansion Multiplexer, first highlight the mux ID, then 
assign it by selecting USB 1 for the first 16 channels (1-16), or USB2 for the second 
16 channels (17-32). 

3.   After assignment has been made, click the Test button. If communication is 
established, the lights on the Video Expansion Multiplexer will flash. 
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Com Port Configuration 
The Com Port configuration screen can be used to set-up the communications interface 
for the internal FX-Series Video Expansion Multiplexer.  

The VEM is an electronic device used to connect multiple inputs to another electronic 
device in a logical order. In the IRIS system, the VEM connects the video signals of all 
the cameras to the video capture card in the FX-Series unit. 

1. Select Site Data > COM Ports > Primary MUX from the Main Menu to display the 

respective configuration dialog box.  

 

 

 

  

This information will be 
used to communicate to 
the internal FX-Series 
VEM the next time the 
IRIS DVS program is 
initiated. Com 1 is for the 
TotalVision-FX internal 
Video Expansion 
Multiplexer only. Select 
MUX 2 to communicate 
to the 2nd Expansion 
Multiplexer for channels 
17 thru 32.  
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2. Using the drop-down selection box, select the following:  

Com Port (Com Ports1 will be automatically set for TotalVisionTS) 

FX-Series DVS (USB 1 and USB 2) 

Baud Rate (normally 9600)  

Bits Per Byte (normally 8) 

Stop Bits (normally 1) 

Parity (normally none) 

 

3. When all settings have been selected, click OK to save the configuration.  

To discard the changes click CANCEL and close the dialog box.  
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System Health 
This menu item is used to enable an automatic reboot if the DVS system senses a loss 
of video signal input. 

To access this screen, select Site Data > System Health from the IRIS Configurator 

Main Menu to display the following dialog box: 

Select the Reboot on VEM Timeout box and the Maximum number of timeouts field will 

become editable. 

Enter a numeric value for the maximum number of timeouts and click OK.   

Files 

Disk Usage 
Disk space allocated to image storage is reserved for Transaction Images and 
Surveillance Images. Each of these image types has slightly different storage 
requirements. 

Reserved Disk Space 

Transaction images are saved for as long as possible. These images will be deleted 
automatically as disk space is needed. At the beginning of the day, the system will 
determine the amount of free disk space that is available. If the amount of free disk 
space is less than the Reserved Disk Space, the system will delete transaction images 
until this value is equal to or exceeds the requirement.  

Maximum Number of Days 

Surveillance images are saved for a specified number of days. At the beginning of a new 
day, all surveillance images older than the maximum number of days will be deleted 
regardless of the amount of disk space. 
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Minimum Transaction Age 

As transaction images are deleted, the system verifies the date of the image and will not 
delete any images less than the Minimum Transaction Age.   
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Disk Allocation 

Select Files > Disk Usage from the Main Menu to display the Disk Allocation dialog box.   

Disk Space to Reserve: The amount of memory that is set aside each day for storage 

of images. This reserved disk space should be at least as big as the maximum number 
of Mbytes required for storage on any day. Recommended amount is 8000 (amount in 
MB). 

Number of Days to Save Surveillance Images. The value entered is the maximum 

number of days that the system will save surveillance images. Images older than this will 
automatically be deleted from the disk. Typical value is 90. 

Minimum Number of Transaction Images: Minimum transaction age is the minimum 

number of days that transactions images will be save. Images newer than this will not be 
deleted to meet reserved disk space requirements. Typical value is 120. 

All other parameters on this screen should not be changed. These are factory set 

options and are not designed for user modification. 
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Activity Log Set-up 
This dialog box is used to configure the number of days to save Activity Log data. This 
value is used from IRIS Inquiry when the SYSOP runs the Activity Log.   

 

1. Select Files > Activity Log from the Main Menu to display the Activity Log Setup 

dialog box.  

2. Enter a numeric value representing the number of days to save Activity Log data. 
Default is 100. 

3. Click OK to save this value.   
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Status Log Set-up 
This dialog box is used to set the maximum file size of the status log.   

 

1. Select Files > Status Log from the Main Menu to display the Status Log Setup 

dialog box.  

2. Enter a numeric value representing maximum file size in Kbytes. 

3. Click OK to save this value.  Close IRIS Configurator 

 

Select Operations > Exit from the Main Menu to terminate the 
program. The  in the upper right hand corner may also be used to close the 

application.   

 

For the changes to take effect, close the IRIS server application 
[Operation > Exit]. 
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Site Map Configuration 
One of the features of the IRIS DVS Server is the ability of a remote viewer to pull up a 
Site Map of a location and locate all of the cameras in their field of view. To facilitate this 
feature, the installer must have made a Site Map prior to configuring the system (refer to 
page 141). Site Map Configuration allows the user to identify each camera, shown on 
the Site Map, by dragging and dropping the camera number. This will enable a remote 
viewer to see the location of each camera and its field of view.   

Once the Site Map has been generated by the installer, it will be saved in the IRIS-DVS 
directory as a *.jpg file.   
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Position Cameras 

1. Select Site Data > Site Map from the Main Menu to display the Site Map dialog 

box.   

2. To enable the user to view the Site Map, click the box. This is recommended. 

3. Enter the name of the Site Map (saved as a .jpg), using the full path to the location. 
The default site map file is named SiteMap.jpg. 

4. Select the SHOW MAP button to display the Site Map.  

5. Select the logical camera number using the  and  buttons. As the camera 
number is selected, the current camera name will be displayed by the system.   

6. Once the camera number is selected, click PLACE and position the cursor over the 

map. 

7. Select the location on the map for the camera. As the cursor enters the Map Image 
it will change to a set of cross hairs.  

8. Click the left mouse button to drop the camera icon on the selected location. 

 To reposition the camera location after it has been placed, click the 
PLACE button again. 

 To save the camera location, click UPDATE button once the camera has 

been selected. 

 To delete a camera from the location, click DELETE once the camera has 

been selected. 

9. Repeat steps 1-8 for all cameras to be placed.  When all cameras have been 
entered, click OK to save the changes and close the dialog box. 
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IRIS DVS Service vs. Application  
IRIS DVS uses the Windows XP Operating System as the core operating system. In 
Windows XP, a process that automatically starts as the system boots, and then remains 
running as a background process, is referred to as a Service. An Application program 

is a process that is started once a user is logged-on and selects a program to run. 
Generally an Application will have a user window to display messages to the user while 
an XP Service will not have a user window. 

In normal operation, the IRIS DVS operates as an XP Service. This allows IRIS DVS to 
start-up and become active without user interaction. Once the IRIS DVS Service is 
active, local and remote users may connect to the Service using any of the IRIS 
software applications. 

As an aid in troubleshooting and testing configuration or hardware problems, IRIS DVS 
can be run as an application, thereby providing additional feedback to on-site 
maintenance personnel using the IRIS DVS application user window. 

Understanding IRIS DVS Service 
Windows XP Services are controlled using the Services icon from the Control Panel. 
When viewed on an IRIS DVS PC (select Start > Control Panel > Services), a number 

of standard services will be displayed, including the IRIS Digital Video Server. For each 
service listed there is a Status and Startup entry.  

 For the IRIS Digital Video Server, the Start-up should indicate Automatic, which 
enables the IRIS DVS to start automatically. DO NOT change the Startup method. 

Doing so may prevent the IRIS DVS process from starting automatically the next 
time the unit is restarted.  

 The Status heading indicates if the IRIS DVS Service is stopped. 

Starting and Stopping the IRIS DVS Service 

1. Select Start > Control Panel > Services. 

2. Scan down the list of installed services and select the IRIS Digital Video Server. 

DO NOT ATTEMPT TO 

RUN BOTH THE IRIS 

DVS SERVICE AND THE 

IRIS DVS APPLICATION 

SIMULTANEOUSLY. 
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3. Click the START or STOP button to start or stop the IRIS DVS. 

4. When the function is complete, click CLOSE, and exit the Control Panel. 

Using the IRIS DVS Application 
As an aid in troubleshooting, the IRIS DVS may be operated as a Windows application. 
When the IRIS DVS is operated as a Windows application the local user is provided with 
a local application window that can be used to display debug and set-up information. 
Generally this information is only available locally and cannot be seen by a remote user. 

 

IRIS DVS is not intended to be operated in the Windows Application mode as a normal 
condition. While in the Windows Application mode, all IRIS DVS functions operate normally 
except that the unit cannot be reset remotely.  

If a reset occurs while in the Windows Application mode, the IRIS DVS program will be 
terminated and will require a user to log-on and restart the IRIS DVS program.   

Normal operation is to run the IRIS DVS as an XP Service. 
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Accessing the IRIS DVS Application 

The IRIS DVS application allows users direct control of the IRIS DVS process. The Start 
Menu will contain a shortcut to the IRIS DVS application. When the application is 
selected, it will be running in minimized mode and the program will be executed and 
display the default menu of the IRIS DVS system.    

To access the DVS application, select File > Password. A Password dialog box will be 

displayed. Call IRIS Digital Video Systems for the access user name and password. 
Enter the user name and password and click OK. At this point the IRIS DVS application is 

open and may be configured using the IRIS Configurator (refer to page 37), or the IRIS 
DVS application may be started. 

Starting the IRIS DVS Application 

Once the IRIS DVS application is open, select Operation > Run to start the local IRIS 

DVS application. 

  Show Mux Data – Displays VEM data in a debug window. 

 Show Net Data – Displays decoded network traffic in debug window. 

 Capture to Log – Selects the option to capture IRIS application data to log. 

 Capture Net Traffic – Creates file NETCAP.TXT for engineering use. 

 Comm Diagnostics – Tests modem. 

 Exit – Closes the IRIS DVS Application. 

NOTE: PCs with the 
full version of 
Microsoft XP go to 
the Services Icon and 
stop the IRIS Video 
Server before starting 
IRIS the Application. 

 

 

When exiting the IRIS DVS Application be sure to restart the IRIS DVS Server 
Process (refer to page 97) or reboot the system to ensure that the IRIS DVS 
Service process is restarted. 
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System Status 
The IRIS DVS Application Menu includes a number of system status screens that can be 
used to determine the current system status of various components. 

Monitor TCP/IP Port   

If configured to monitor TCP/IP traffic, the IRIS DVS reviews all data sent to a specific 
TCP/IP address. This data is decoded and analyzed by the IRIS DVS to determine if a 
transaction has occurred. The TCP/IP Port Status is used to show specific data about 
the monitored TCP/IP address and will indicate the monitored MAC address on the 
network. Another method that may be used to determine the MAC address is presented 
in the Quick Reference section, beginning on page 158.  

Attached Users  

While the IRIS DVS application is running, remote users can be attached and access the 
supported functions of the IRIS DVS. This status screen is used to indicate the number 
of remote users that are currently connected to the IRIS DVS. If the IRIS DVS 
application is closed while one or more remote users are connected, the remote user(s) 
will be disconnected when the IRIS DVS application is terminated. 

TCP/IP Adapter 

Displays TCP/IP adapter name and description. 

Show Change in Image 

For manufacturing use only. 
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XP Embedded System 
The XP Embedded FX-Series system is basically a limited-function Windows XP system 
that has been modified for the IRIS application. The following image screen shows the 
initial application page with two options: IRIS Inquiry and Maintenance.  

 

 

 

Any IRIS system the uses the Control Panel screen must never use a log-
on user account or no images will be captured until the user starts the 
DVS Application. 
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Maintenance 

The Maintenance Menu will be available to authorized personnel only and is password 
protected.   

1. To access the Maintenance module, click the Maintenance button from the main 
page. 

2. Enter a password and click OK and the Maintenance Menu buttons will be 

displayed.   
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The following menu buttons will be available from the Maintenance module. A screen 
sample is presented on the following pages for each function. 

 Inquiry IRIS – opens the IRIS Inquiry application.  

 IRIS Application – opens the IRIS DVS application. If the application is currently 

running the application window is made visible. 

 Upgrade Software – prompts user to insert the upgrade disk. 

 Exit Maintenance – closes the Maintenance page and returns the user to the home 

page showing the IRIS Inquiry and Maintenance buttons. 

 LAN Settings - presents a dialog box allowing the user to specify the LAN 

configuration. 

 Unit Shut Down – prompts the user to reboot the IRIS system. 
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Inquiry IRIS 

Selecting the Inquiry IRIS button from the Maintenance Menu will open the IRIS Inquiry 
application.  

IRIS Application 

Selecting the IRIS Application button opens the IRIS DVS Application. This application is 
normally running in the background at all times and is responsible for the image capture 
function. Using this screen, the user can set-up the IRIS FX-Series DVS operation as 
outlined in this Manual.  

 

 

The embedded Application is the engine IRIS uses to make the system 
perform.  Therefore, the embedded system must never be exited or no 
images will be recorded. 
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Upgrade Software 

After selecting the Upgrade Software button, the user will be prompted to insert the 
upgrade disk and click OK to initialize the installation.   
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Exit Maintenance 

Selecting the Exit Maintenance button will return the user to the home page displaying 
the Inquiry IRIS and Maintenance buttons.  
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LAN Settings 

The LAN Settings button is used to set the various addresses and enable the DHCP.  
DHCP must not be checked if using the IP Address option. 
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Unit Shut down 

The Unit Shut Down button may be used to reboot or shut down the IRIS 
system.  A system reboot will stop all running programs and then restart the 
system as if power had been applied. A system shut down is used to stop all 
running programs and stop operation. Once all programs have been stopped the system 
will turn off. Typically a unit shut down is used for hardware maintenance functions or to 
turn off the unit for extended periods of time. 

System Reboot 

When the Unit Shut Down button is selected, as a first option, the user will be prompted 
to reboot the system.  

 

Select “Yes” to reboot 
the system.  

Select “Cancel” to 
cancel this function 
and return to the Main 
Menu.  

Select “No” to open a 
dialog box for the 
option to “Shut Down” 
the system. 
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System Shut Down 

The second option for the Unit Shut Down button is the option to shut down the unit 
completely and stop operation. After selecting “No” to reboot the system, a dialog box 
will be displayed to Shutdown IRIS System.  

 

 

 

Select “Yes” to Shut 
Down the IRIS system 
and stop all operation. 

Select “No” or 
“Cancel” to cancel this 
function and return to 

the Main Menu. 
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System Testing and Turnover 

Surveillance Cameras 

Apply power to the surveillance cameras. Connect the hand-held video monitor to each 
surveillance camera in turn and adjust the focus and aperture of the camera for the best 
picture obtainable. 

Transaction Cameras 

IRIS Transaction Cameras are pre-focused at approximately 28-30 inches. It is possible 
to refocus a transaction camera if necessary, but it is not recommended. If it does 
become necessary to do so, please contact the IRIS Technical Support department for 
the correct procedure. 

Transaction Tests 

1. Restart the IRIS FX-Series system.   

2. Write the location name, date and camera number on the small white board.   

3. Stand in front of camera 1, hold the white board in the camera viewing area, and 
have an appropriate facility employee do a dummy transaction. This will take a 

transaction picture. Increment the transaction camera number on the white board, 
and step into the view area of the number 2 camera and have the facility employee 
do a dummy transaction at that transaction window. Continue this procedure until all 
transaction cameras have had test shots taken.   

4. Save the receipts from these transactions for the facility files.   

5. Repeat this process for all ATM cameras that are installed at the facility. 

The dummy 
transaction may be a 
$0.01 deposit into 
any account number, 
which can be 
reversed later.  
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Adjustment of Brightness and Contrast 

FX-Series systems are designed to work with cameras that have auto-iris capability. In 
normal installations, the auto-iris feature provides sufficient dynamic range that 
adjustment of the brightness and contrast is not necessary. 

The default setting for the contrast and brightness is adequate in most average settings; 
however, some locations may experience unique situations where the subject area is in 
a poor lighting area or in a strong backlight area.  

FX-Series systems provide the capability to adjust the brightness and contrast settings 

and each may be adjusted individually. This adjustment may be applied as a global 
setting where the setting affects all cameras equally, or the contrast and brightness 
setting may be applied on an individual camera-by-camera basis. 

To adjust the contrast or brightness setting the FX-Series system must be running the 
IRIS DVS Application. See the IRIS DVS Service vs. Application section of this Manual 
(page 97) on how to start the IRIS DVS Application. Use the procedure outlined in the 
following global or individual setting sections to adjust the contrast and/or brightness. 

Global Brightness Setting 

This section describes the method of changing the default global brightness settings for 
the captured images. 

To adjust the Global Brightness for all cameras: 

1. Open the DVS Application. 

2. Select Images, and specify how you want the images displayed. 
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3. Place the cursor over an image and right-click. From the drop-down menu 
make sure the Global Adjust option is enabled as indicated by a check. If 
the Global Adjust is not checked, click to enable this option.  
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To adjust the brightness setting, place the cursor over the image and right-click and 
select Brightness. 

The IRIS system will show a small slide bar. Adjust the slide bar on the screen and the 
effects of the change will be shown on the image. Adjust the brightness setting for the 
best overall setting and click OK to save the setting. Cancel to return to the previous 

setting, or Set Default to set the brightness to the default setting.  

 

To view the right-
click options, refer 
to the drop-down 
menu displayed in 
the previous 

image. 
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Global Contrast Setting 

This section describes the method of changing the default global contrast settings for the 
captured images. 

To adjust the Global Contrast for all cameras: 

1. Open the DVS Application. 

2. Select Images, and specify how you want the images displayed. 

 

3. Place the cursor over an image and right-click. From the drop-down menu 
make sure the Global Adjust option is checked.  
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4. To adjust the contrast setting, place the cursor over the image and right-
click. From the drop-down menu select Contrast.  

5. The IRIS system will display a small slide bar. Adjust the slide bar on the screen 
and the effects of the change will be shown on the image. Adjust the contrast 
setting for the best overall setting. When done select OK to save the setting, Cancel 

to return to the previous setting, or Set Default to set the contrast to the default 
setting.  
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Individual Camera Brightness Setting 

This section describes the method of changing the default brightness settings for images 
from an individual camera. 

To adjust brightness for an individual camera: 

1. Open the DVS Application. 

2. Select Images, and specify how you want the images displayed. 

 

3. Place the cursor over the image and right-click. From the drop-down menu 
make sure the Global Adjust option is not checked. If checked then select 
the Global Adjust option to unselect it. 
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4. To adjust the brightness setting, place the cursor over the desired image, right-click, 
and select Brightness from the drop-down selection list.  

 
An Adjust Image Brightness dialog box will be displayed with a small slide bar. 
Adjust the slide bar on the screen and the effects of the change will be shown on 
the image. Adjust the brightness setting for the best overall setting and click OK to 

save the setting, Cancel to return to the previous setting, or Set Default to set the 
brightness to the default setting.  
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Repeat steps 3 to 5 for each of the cameras to be changed from the default setting. 
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Individual Camera Contrast Setting 

This section describes the method of changing the default contrast settings for images 
from an individual camera. 

To adjust the Contrast for an individual camera: 

1. Open the DVS Application. 

2. Select Images, and specify how you want the images displayed. 

 

3. Place the cursor over the image and right-click. From the drop-down menu make 
sure the Global Adjust option is not checked. If checked then select the Global 
Adjust option to unselect it. 

4. To adjust the contrast setting, place the cursor over the desired image right-click. 
Select Contrast from the drop-down list. 
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5. The IRIS system will show a small slide bar. Adjust the slide bar on the screen and 
the effects of the change will be shown on the image. Adjust the contrast setting for 
the best overall setting. When done, select ok to save the setting, Cancel to return 
to the previous setting, or Set Default to set the contrast to the default setting.  

Repeat steps 3 to 6 for each of the cameras to be changed from the default setting. 
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Adjust Motion Detect Sensitivity 

FX-Series systems use a patented method of motion detection to record only images 
that have actual motion. This method reduces the number of images recorded, greatly 
reducing storage space necessary for images while still retaining the images of interest. 

In the FX-Series systems, each camera may be set to a different amount of sensitivity 
for this motion detection. The setting of motion detection sensitivity was covered in the 
Port Assignment section of this Manual (page 45). This section identifies how the 
installer can verify that the motion detection threshold is adjusted correctly. 

Show Motion  

To test the motion sensitivity for an individual camera. 

3. Open the DVS Application. 

4. Select Images, and specify how you want the images displayed. 
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5. Place the cursor over the image and right-click. From the drop-down menu make 
sure the Show Motion option is checked. If not checked then select the Show 
Motion option to select it.  

 

6. Now observe the image shown on the application or have someone cause 
movement in the camera field of view. When the system detects sufficient motion 
the system will show a red “smear” across the image. 

 If the motion detect sensitivity is correctly adjusted, the red “smear” will 
display when the image changes in sufficient detail to warrant that the 
image should be saved.  

 If the image changes but no motion is detected, the motion detect needs 
to be more sensitive. Reduce the motion detect percentage value for the 
camera and repeat the test. 

 If the motion detect indicator is on when there is no relevant motion, the 
motion detect is too sensitive. Increase the motion detect percentage 
value for the camera and retest. 

Repeat steps 3 to 5 for each of the cameras. 

Example of 

movement smear. 
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Show Record Activity 

In addition to testing motion sensitivity, the FX-Series system can display which images 
are being recorded by the system with a small red dot in the upper-left of the image. 
Normally this feature is not used during set-up but may be used to verify which images 
(surveillance, transaction, and event) images are being recorded. This section describes 
the procedure that indicates which images are recorded. 

To activate the Show Record indicator: 

1. Open the DVS Application. 

2. Select Images, and specify how you want the images displayed. 
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3. Place the cursor over the image and right-click. From the drop-down menu 
make sure the Show Record option is checked. If not checked then select 
the Show Record option to select it. 

 

Now observe the image shown on the application window. When an image is recorded, 
the system will show a small red circle in the upper left-hand corner of the image. 

Either the Show Motion or Show Record indicators may remain enabled during normal 
operation; although, the Show Record is a more subtle indicator. 

 

Red circle 
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Motion Masking  

The FX-Series DVR’s feature image area motion masking.  Basically, this features 
allows you to select what portions of a viewed image should not trigger recording based 
on motion.  This function will come in handy, for example, when an exterior camera has 
a busy street running through a portion of the observed scene.  Without image area 
motion masking enabled, vehicles driving down a busy street in this camera’s view 
would trigger excessive recording.   

Image area motion masking can only be used while in the IRIS DVS Configurator, and 
can vary from camera to camera.   

1. Place the cursor over the desired image to mask the area.   

2. Right-click on the image. 

3. Select Show Active Zones – the image is now divided into 64 zones. 

4. Highlight each zone where you want the motion masked. 

 

Example: First 
three columns 
have been 
masked 
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5. When all areas have been masked, select Hide Active Zones. 

 

Any masked areas can be disabled by repeating steps 1-5 (above).  Masked image(s) can be 
verified when used in conjunction with Show Motion and/or Show Record functions.  

Pause Live Display   

The FX-Series software allows you to pause a live display while in the 
Application.   

1. Place cursor over image to pause. 

2. Right-click, select Pause Live Display.  Recording continues. 

3. Right-click again to resume live image. 
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Displaying Images by Row   

Another feature of the FX-Series of DVR’s is the ability to select how images are 
displayed on the screen. 

1. From the IRIS Application, select Window. 

2. Select Images in Each Row, select desired layout. 
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System Troubleshooting 
When a FX-Series system is turned on the IRIS DVS server service is automatically 
started and runs a series of Power-on-Self-Tests (POST). In some configurations the 
unit may not be able to display an error code or message on the user screen. When the 
IRIS DVS software detects a major problem that will prevent the unit from starting the 
unit will indicate the error condition by playing a series of beeps using the internal 
transducer. Using these beep codes the installer can usually identify the error condition 
that is preventing the unit from running and correct the situation. 

Error Beep Codes 

Beep Problem Solution 

Low Bad Comm Channel Check Comm settings. Ensure no 
conflicts with other programs. 

Low, High Bad Video Card Check video card, video settings, 
and video card software 
installation. 

Low, High, Low Unable to Communicate with 
IRIS VEM 

Check Comm Port to VEM, Check 
VEM Comm Port setting, Check 
VEM power, and then Check VEM. 

 



 IRIS FX-SERIES DVS SERVER  

IRIS FX-Series DVR’s 130 001.09  

Problem Solving 
Most issues are resolved with some basic field troubleshooting.  Below are problem 
examples with possible solutions.  Contact your internal technical support or the IRIS 
Customer Service Department for further assistance. 

 
Problem: Not getting an image from camera #5. 

Possible Solutions: Power failure for the camera, camera is not enabled in the 
Configurator, bad crimp on BNC connector, defective wire, bad camera, replace camera. 
 

Problem: IRIS Inquiry is unable to connect to any other FX-Series TotalVisionTS or 

DVS units on the network. 

Possible Solutions: Network cable is not connected properly or is in the wrong plug, bad 
crimp for Ethernet connector, defective wire, drivers for the LAN card, configuration of 
the TCP/IP, check the IP address, check gateway; check network connectivity; check 
access rights; check remote IP addresses; check remote DVS operation. 

 

Problem: None of the LED’s on the bottom of the FX-Series TotalVisionTS unit is lit. 

Possible Solutions: The VEM is set on the wrong com port, power connector has been 
detached, cameras are not enabled, check programming; check cameras; check camera 
inputs. 

 

Problem: The images on camera #4 are too dark, all the rest of the cameras are fine. 

Possible Solutions: Bad camera, closed iris, low on power, direct light in the lens on a 
camera, check camera operation; check cable; check programming. 
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Problem: Not getting an image when an ATM transaction takes place. 

Possible Solutions: ATM data interface is not programmed correctly, ribbon cable 
crimping is wrong; protocol in the Configurator is set wrong, check data cable; check 
ATM data interface operation; check data interface sync LED; check network operation; 
check ATM operation. 

 
Problem: The modem will not answer when I try to connect with the FX-Series 

TotalVisionTS.  

Possible Solutions: Poor phone line (static, etc.), wrong phone number, someone else is 
on the line, modem drivers, modem was not reset correctly. 

 
Problem: Keystrokes on the virtual keyboard are not where the screen is being pressed. 

Possible Solutions:  The virtual keyboard has lost calibration.  Please contact the IRIS 
Customer Service Department department at 888.451.4646. 

 
Problem: The virtual keyboard is always displayed.  

Possible Solutions:  Press the “Min” key above and to the right of the cursor pad on the 
virtual keyboard. 

 
Problem: The virtual keyboard will not display.  

Possible Solutions:  Press the “KB” key in the lower-right corner of the screen.  If that 
does not display the virtual keyboard, down the IRIS application and reboot the system. 

 

The front panel of the FX-Series TotalVisionTS is designed to pivot downward to allow 
easy access to the internal components.  Under no circumstance should the security 
screws on either side of the front panel be removed.  Only the top three (3) Phillips 
screws should be removed to open the unit. 
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Quick Reference 

IRIS DVS Computer Quick Start-up and  
Programming 

Start DVS 
After installing the video equipment and connecting to the IRIS FX-Series DVR, turn-on 
the system, and wait for the Windows screen. 
  

Administrator Password 
1. Select Start > Programs > Administrative Tools (common) > User Manager 

2. Double-click ADMINISTRATOR. 

3. Enter the password and confirm.  Use no punctuation marks or spaces in the 
password. 

4. Check the Password Never Expires option. 

5. Click OK. 

 Add DVS Users 

1. Select User > New User. 

2. Enter a new username. 

3. Enter the password and confirm. 

4. Check the User Cannot Change Password option. 

5. Check the Password Never Expires option. 

6. Click OK. 

The maximum 
length of the 
password can not 
exceed ten (10) 
characters. 
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Program IRIS DVS for Surveillance Image Recording 

Stop IRIS-DVS Service  

1. Select Start > Settings > Control Panel > Services. 

2. Select IRIS VIDEO SERVER. 

3. Click Stop and wait for confirmation. 

4. Confirm YES. 

5. Close open windows. 

Set System Configuration 

1. Select Start > Bank IRIS_XP (at the top of the Start Menu). 

2. Select File > Password. 

3. Enter IRIS for the password (password is case sensitive). 

4. Select Config  > Configure  > Video > Cameras > System Configuration 

 Enter total number of cameras on the system in the box, click OK.  

5. Select  Config  > Configure  > Video > Cameras > Port Configuration 

 Check Enabled for each camera on the system (will not work if not 
enabled). 

 Enter the name of each camera in the Camera Name box. The Camera 

Name will be displayed for remote viewer convenience.                                                         

 Click the Apply button after all cameras have been enabled and named.  

 Click OK. 

Select Site Data > Site Identification 

 Type a location name in the Site Name box.  

 Click OK.  

These instructions 
do not apply to an 

embedded system. 
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Set DVS Time and Date 

1. Double-click the Time in the lower right corner, and verify the time and date. 

2. Click on the Time Zone tab and set to appropriate time zone. 

3. Check the box to Automatically Adjust Clock for Daylight Savings. 

4. Close all open windows. 

Reboot Computer  

 Reboot the computer to save the changes.  
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Installation Tools and Equipment 

  Screw drivers - #1 and #2 Phillips, 1/4" & 3/16" common, small common. 

  Nut drivers - 1/4" and 3/16" hex.  

  Pliers - chain nose, 90ْ chain nose, electricians. 

  Crimping tools - RJ45, BNC for both standard RG59 and RG59 plenum, insulated 
lug, DB ribbon cable. 

  Cutting tools – small and medium diagonal cutters, wire strippers for 16-26 AWG, 
coax strippers for RG59 and RG59 plenum, strippers for Silver Satin, strippers for 
jacketed multiple wire cable, industrial strength scissors, drywall saw, hacksaw, and 
blades 

  Awl (for marking mounting holes). 

  Measuring tools - tape measure (25'), torpedo level, length of string to align 
transaction cameras. 

  Cable pulling tools - 50' fish tape, bucket of pull string, push-pole set, and  
de-spooler. 

  3/8" cordless drill/driver with necessary bits (including bell hanger's bits) and 
accessories (battery charger, extra batteries, screw driver adapter, etc.). 

  Hole saw set. 

  Flashlight. 

  Instruments - DVM, CAT5 cable tester, hand-held, battery-powered video monitor, 
telephone line toner and tone receiver. 

  8' step ladder. 

  Small shop vacuum. 

  Small white board and marker - to write the date and camera number on for testing 
each camera. 
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Cable and Connector Specs 

Cables 

Video - RG59 coax is required in most municipalities when cable is installed above drop 

ceilings or in high-rise buildings. 

Data - 8-conductor Silver Satin can be used on runs up to 50' between Tower Cameras 

with TDI, ATM Interfaces, and Data Inserters unless local codes require plenum 
coatings. (Silver Satin is not plenum rated.) Above 50' and for the connection between 
the FX-Series unit and the Network Router 4-pair CAT5 cable should be used. ATM 
Data connection to the ATM Interface is via a 25-conductor ribbon cable. Printer to 
transaction camera data interface requires a 9-conductor ribbon cable. 

Surveillance Camera Power - 22/4 stranded cables up to 50' with 2 wires connected 

together for each side of the power. Above 50' 18/2 stranded is preferred. Plenum if 
required.  

Com Ports - Serial ports between UPS and the FX-Series TotalVisionTS unit should 
use pre-made serial cables no longer than necessary. 

Connectors 

Video - Crimp style BNC for RG59 coax or RG59 plenum coax. 

Data - RJ45 for Silver Satin and CAT5. Crimp style DB 9 male and female, and DB 25 

male and female. 
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Technical Support  
IRIS provides a technical support line regarding the installation, operation, and use of all 
hardware and application modules. Users may reach a technical support representative 
using any of the following methods.   

Telephone 

Use these numbers to reach the IRIS Customer Service Department and speak to a 
technical support representative during normal office hours: 

 Monday –  Fr iday 8 :30  am to 5 :00 pm CST  

 Phone: 214 .349.0480   

Fax: 214.349.9429  

After-hours the number below may be used to request assistance. Using a touch-tone 
telephone, enter the full phone number, including area code, and a support 
representative will return your call as soon as possible: 

After-Hours  Number: 888.451.4646  

Calls to the regular support number after-hours will be forwarded to a voicemail system. 
Leave a message with the full phone number, including area code. The voicemail 
system will then contact the technical support representative that a request for support 
message is in the system.   
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Email 

To send questions using email, and to receive a detailed answer from the technical 
support department by return email, use the following address: 

support@secur itytexas.com  

To contact the sales department use the following address: 

sales@secur i tytexas.com 

Internet 

To access the IRIS Digital Video Systems website for more information on the company, 
products, and updates, use the following URL: 

  www.DigitalVideocc.tv 

Software and/or Firmware Updates 

IRIS maintains its most current versions of software on its website.  At the home screen, 
select IRIS DIGITAL VIDEO SYSTEMS, and then SUPPORT.  Among the options under 
SUPPORT will be password-controlled SOFTWARE DOWNLOADS.   

If you have not been given the password, check with your local IRIS technical resource, 
or contact IRIS Customer Service Department. 

You then have a choice of software, firmware, or instruction downloads. Be sure to 
select the appropriate category for the product you are working on. 

Manuals 
Each FX-Series system will have a copy of the necessary Manuals in digital format on it.  
Current versions and/or updates are also available on the IRIS website. 
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ATM Interface 
An ATM Interface Module is a device that is connected to the ATM data bus with a 25-
conductor ribbon cable similar to a printer cable. This module triggers an image capture 
from a camera mounted in or near the ATM or ATM housing, and captures three (3) 
lines of text data from the ATM transaction. Up to thirty-two (32) images may be 
captured per transaction.   

 

Figure 9 - ATM Interface Module 

The ATM Interface cable is assembled and connected like a data cable. Ensure the 
three (3) connectors are of the appropriate polarity and that pin 1 of each connector is 
on the same conductor of the ribbon cable. Locate the ATM Interface module in or near 
the ATM housing. Terminate all of the cables properly and make the connections (RG59 
coax, 8-conductor Silver Satin, 4-pair CAT5, or 25-conductor ribbon cable).   

The ATM Interface 
was designed to 
work with earlier 
generations of the 
IRIS product line.  
Contact IRIS 
Technical Support 
for assistance with 
the FX-Series. 

Refer to the 25-pin Y 
data cable drawing 
included in the Cable 
Illustrations in the 
Quick Reference 
section of this Manual 
beginning on page 
147. 
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Figure 10 - ATM Installations 

IRIS Digital Video Systems Dallas, Texas  
Protected by Patents: #5,751,345,  # 5,751,346,  #365,834, and # D524834                                 Copyright  1994-2008 
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Site Map Generation 
One of the features of the IRIS DVS Server is the ability of a remote user to view a Site 
Map of a location and locate all of the cameras in their field of view using IRIS Inquiry. 
To facilitate this feature, it is necessary for the installer to make a drawing of the location 
prior to configuring the system. A simple drafting aid is a software package called 

Visio. It is recommended that the IRIS installer have a copy of this program on their 
laptop computer for use in the field. Along with this Installation Manual, the installer will 
receive a set of files that have been produced by IRIS Digital Video Systems to facilitate 
standardization, and assist the installer in the generation of each Site Map.   

Sample Files 

 IRISstencil.vss is a stencil file that has standardized shapes for various items 

located in the area of video coverage. This file will open on top of the Visio screen 
and allow the user to select various shapes for the drawings.   

 IRISstandards.vsd displays a sample of a typical drawing created in Visio. The 
IRISstandards.jpg displays this drawing captured as a .jpg file, which removes all 

guides, connection points, and grids.  

 Sitemap.vsd is a blank drawing page with the correct page set-up standards. 

 IRIS symbol descriptions.vsd presents a sample page with descriptions of the 
symbols used in a drawing. The IRIS symbol descriptions.jpg displays this 

drawing captured as a .jpg, which will remove all guides, connection points, and 
grids. 

The installer should 
copy the sample 
files to the MY 
Documents section 
of the C: drive on 
their laptop.  
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Create Site Map 

1. To create a Site Map with Visio, open the file named Sitemap.vsd. A blank drawing 
will be displayed.  

2. Open the IRISStencil.vss to display a stencil that has been prepared 
specifically for this purpose with standardized shapes for the location.   

 

IRIS Stencil.vss 

Blank drawing 
page with default 
page set-up 
standards 
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3. Using the various stencil items, make a simple drawing of the site layout 
showing the location of major items such as the vault door, the front door, 
the transaction window, etc. It is not necessary that this drawing be to 
scale, but merely representative of the site. Locate all cameras and orient 
the camera symbol so that an idea of coverage is indicated. 

 Select an item from the stencil and drag and drop on page. 

 Images may be sized and moved anywhere on the page. 

 

 

 

 

 

 

 

 

 

 

This image 
displays an 
example 
drawing as it 
may appear in 
Visio.   
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Save Site Map 

When the drawing is completed, click File > Save As from the Main Menu. Select .jpg 

as the file type, path to the location where the file should be saved on the local hard 
drive, and click Save. 

 



QUICK REFERENCE  

001.09 145 IRIS FX-Series DVR’s  

When the JPG Output Filter Setup page is displayed, enter 3” x 1.75” in the Size option 
in the lower left-hand corner, and click OK. The file will be saved to the  location 

previously specified.  

 

Copy Site Map to BankIRIS_NT Directory 

Copy the Sitemap.jpg to the C:\BankIRIS_NT directory on the IRIS DVS computer. 

Viewing a Site Map 

Placed cameras on a saved Site Map may be viewed through IRIS Inquiry using View > 
by Location.  Refer to the IRIS Inquiry Manual for more information. 
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Standard Camera Names 

Transaction Window # (from left to right from the perspective of the 
customer.) 

Behind Transaction Window # (from left to right from the perspective of the 
customers.) 

Queue Line 

Vault Door 

Safe 

Back Room 

Drive-In ATM # 

Drive-In Transaction Window # 

Inside ATM # 

Exterior ATM # 

Exit - North, South, East, or West 

Night Drop 

Parking Lot - North, South, East, or West 
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Cable Illustrations 

 

Figure 11 - DB-9 Data Cable 
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Figure 12 - 8-Conductor Flat Communication Cable 
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Figure 13 - 75 Ohm Coax Video Cable 

 



 IRIS FX-SERIES DVS SERVER  

IRIS FX-Series DVR’s 150 001.09  

 

Figure 14 - Video Camera and Power Supply 
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Figure 15 - DB-25 Y Data Cable for ATM Connection 
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RAID - Mirroring (RAID 1)  

The FX-Series systems are available with redundant array hard disk drives configured in 
a mirroring mode.  Mirroring writes duplicate data onto a pair of drives while reads are 
performed in parallel.  SATA RAID 1 is fault tolerant because each drive of a mirrored 
pair is installed on a separate channel.  If one drive suffers a mechanical failure or does 
not respond, the remaining drive will continue to function.  This is called Fault Tolerance.  
If one drive has a physical sector error, the mirrored drive will continue to function.   

1

2

3

4

1

2

3

4

1

2

3
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Figure 16 - RAID 1 (Mirroring) Data Block 

On the next reboot, the RAID utility will display an error in the array and recommend 
replacing the failed drive.  

The system may be powered-off at a later time, and the failed drive may be physically 
removed and replaced.  Spare drives must be the same or larger capacity than the 
smallest array member.  Upon reboot, the RAID software will rebuild the image onto the 
newly replaced drive.  Contact the IRIS Customer Service Department for additional 
information if needed. 
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Teller Configuration Files 
Teller Configuration files are used by two (2) different sections of the IRIS DVS software. 
The first section is where Custom is selected as the transaction protocol in the 
Transaction Set-up screen (refer to page 64). The second area is when Teller Printer is 
selected as the Device Type in the TCP/IP Transaction Monitoring screen (refer to page 
73).  

File Contents 

The teller configuration file can be edited using a normal text editor such as Windows 
Notepad. 

Filename for Teller Configuration File 

The system normally looks for the file BasicTeller.CFG in the C:IRIS-DVS directory as 
the teller configuration file. Adding the following information to the IRISNT.INI file on the 
DVS can change this name. 

[TCPIP] 
Teller TCPIP Cfg File = filename 

Identification of Teller Configuration 

The following field can be used to identify the use and style of the teller configuration file. 

[GENERAL] 
Name = First Bank Teller TCPIP Transactions 2-15-08 

TCP/IP Source and Destination Ports 

The main TCP/IP monitoring screen defines the TCP/IP or MAC address that will be 
used to qualify the monitored data. (To determine the MAC address, refer to page 158.) 
In addition to this main address the IRIS DVS can be set to look for a specific Source or 
Destination Port Address. The port address should be set to the hexadecimal value 
observed in the packet. If the port address is set to 0,0 then no checking will be 
performed. 

[TCPIP] 
TCPIP Dest Port = 0,0 
TCPIP Src Port = 05,C5 

EBCDIC vs. ASCII format 
To select the EBCDIC character set this value to 1. If this value is set to “0” or the Use 
EBCDIC tag is not present in the configuration file the IRIS DVS software uses the 

ASCII character set. 
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[TCPIP] 
Use EBCDIC = 1 

Condition Strings 

Just like the generic transaction protocol set-up, the Teller Printer can be conditioned to 
look for specific condition strings within the data packet. The condition string is used to 
define which TCP/IP packet represents a transaction. Once a packet is determined to 
have the correct TCP/IP address and TCP/IP port number the data field of the packet is 
examined to see if the packet contains the key phrase. 

Several options exist for the condition string. The IRIS system provides an option for two 
(2) condition strings. These two (2) strings can be used together to define a specific set 
of circumstances. [TCPIP] 

Condition 1 String = 
Condition 1 Ignore Case = 0  
Condition 2 String = 
Condition 2 Ignore Case = 
Both Conditions = 0   

Sequence Location 

Just like the generic transaction protocol set-up the sequence number can be extracted 
from the data by specifying a location in the packet. The teller configuration file adds an 
additional parameter, Seq Len, which can be specified to limit the number of digits used 
in determining the sequence number at the specified sequence location. 

[TCPIP] 
Seq Loc = 124 
Seq Len = 4 

Each transaction image is recorded with a sequence number. If a sequence number is 
shown in the transaction packet information, then that number can be captured from the 
transaction packet and included with the image. If the transaction packet does not 
include a sequence number, then the system can be programmed to insert an auto 
incrementing sequence number for all transactions that meet the data template. 

To capture a sequence number directly from the transaction packet, locate the sequence 
number in the transaction packet. Using the four-digit number at the left and the position 
of the number in the row determine the position of the first number of the sequence 
number. Convert this hex number to decimal (i.e. position 0041 is position 65). This 
number is the information to enter for the sequence position. (Note: The sequence 
number must be shown in ASCII format in the transaction packet.) 
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If the IRIS DVS system cannot locate a valid number at the location specified, it will 
assign a sequential sequence number from 1 to 9999 to the transaction. 

To have the IRIS DVS system assign a unique sequential sequence number between 1 
and 9999, set the sequence number to 0. 

Text Location 

Just like the generic transaction protocol set-up, the text location in the packet can be 
defined. The text location parameter defines the data field portion of the 
message. Generally a received message includes header information followed by the 
data payload. The Text Location parameter enables the user to specify the starting 
location of the text within this data payload. If the number is set to 0 then system 
assumes that the message format is TCP/IP and adjusts the value for a TCP/IP 
message format. Other message formats or positions can be specified by setting this 
value to a number greater than “0”. 

[TCPIP] 
Text Loc = 0 

Teller Location 

Just like the generic transaction protocol set-up, the teller number can be extracted from 
the data by specifying a location in the packet. The teller configuration file adds an 
additional parameter, Teller Len, which can be specified to limit the number of digits 

used in determining the teller number at the specified sequence location. Each 
transaction image is recorded with a teller number.  

[TCPIP] 
Teller Loc = 120 
Teller Len = 4 

If a teller number is shown in the transaction packet information, that number can be 
captured from the transaction packet and included with the image. If the transaction 
packet does not include the teller number, the system can be programmed to insert a 
constant teller number for all transactions that meet this data template. 

To capture a teller number directly from the transaction packet, locate the teller number 
in the transaction packet.  Next, determine the position of the first number of the teller 
number using the four-digit number at the left and the position of the number in the row. 
Convert this hex number to decimal (i.e. position 0041 is position 65). This number is the 
information to enter for the teller position.  

To insert a static teller number, enter the negative of that number for the teller number. 
Example: Enter –2510 will record the teller number 2510 for each transaction recorded. 

 

The teller 
number must 
be shown in 
ASCII format in 
the transaction 

packet. 
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Branch Number 

Just like the generic transaction protocol set-up the branch number can be extracted 
from the data by specifying a location in the packet. 

[TCPIP] 
Branch = 222 
 

The branch number recorded with each transaction image is fixed and is not captured 
from the transaction packet. Enter the branch number to be assigned to this port. Branch 
Number must be numeric with a maximum value of 65000. The Branch Number is saved 
with each image. 

 

Each data 
template can 
have a different 

branch number. 
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Minimum Data Length 

The teller configuration file can specify a minimum length for a valid transaction packet. 
All captured packets less than this minimum length will be ignored. 

[TCPIP] 
Min Len = 127 

Required Number 

Just like the condition strings the teller configuration file can specify a location where a 
required number must exist. The exact value of the number is not important (if it was we 
could use the condition string setting) but the location must contain a number value. The 
teller configuration file can specify a minimum and/or maximum number of digits in the 
required number field. If any parameter is set to 0 the parameter test is ignored for that 
condition. 

[TCPIP] 
Required Number Loc = 120 
Min Nbr Digits = 8 
Max Nbr Digits 

Printable 

Just like the required number field sometimes it is necessary to ensure that the data 
portion of the packet contains a printable character. The printable parameter requires 
that the first position of the data packet contains a printable character if the parameter is 
set to equal to 1. 

[TCPIP] 
Printable = 0 
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Network Monitoring of Dynamic IP Address   

The IRIS DVS software monitors the network to capture transaction events. Normally, 
when the system is installed the installer specifies the TCP/IP address of the network 
device that should be monitored, but the software also has the capability to capture 
network traffic based on a MAC address. Using this capability the IRIS DVS software 
can also be programmed to monitor devices that use dynamic IP addresses. 

All devices on a TCP/IP network have a unique IP address. This address can be fixed 
and always assigned to a specific device. When the IP address is fixed it is referred to 
as a static IP address. In some networks TCP/IP addresses are assigned dynamically. 
When a device first powers up, the device requests a TCP/IP address from a DHCP 
host. The DHCP then assigns an IP address that is available from a range of IP 
addresses to the device for a limited amount of time. This time limit is referred to as 
lease time and normally the lease expires in 72 hours although the time may be longer 
or shorter. Once the lease expires or the power is cycled on the device the device will 
need to contact the DHCP host to request a new TCP/IP address. A network can have 
both dynamic and static IP addresses simultaneously. 

To capture network traffic the IRIS DVS software is programmed with the TCP/IP 
address of the device. This method is used for a static IP address since generally the IP 
address is easier to determine for a particular device and is hardware independent. The 
IRIS software also provides the ability to monitor network traffic using the destination 
MAC address. The MAC address specifies a particular Ethernet card and is unique for 
each device. The MAC address can be used to monitor both static and dynamic IP 
addresses. This text will outline the process necessary to set-up a device using a MAC 
address. 

Note: The only limitation of using a MAC address is if the monitor device hardware is 
ever replaced then the IRIS DVS system will need to have the new MAC address 
programmed. Generally, this is not a limitation when monitoring the IP address since the 
new replacement device receives the same IP address as the old unit. 

Determining MAC Address 
Since the MAC address is assigned to a specific network card within the device the 
system administrator does generally not know this number. There are several ways to 
determine this address. The following procedure outlines a convenient method whereby 
the installer can use the IRIS DVS software to determine the MAC address. 
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1. To determine the current IP address of the monitor device: 

For WinXP - open a DOS window and run IPCONFIG.EXE. 

2. Record the IP address since this will be used in the set-up procedure. 

3. Start the IRIS DVS application. Verify that the IRIS service has been stopped. 

4. After entering the password, select Configuration from the Main Menu. 

5. Using the IRIS Configurator, select Events > TCPIP Monitoring. 

6. Set-up the items as you would normally for the type of device you are monitoring. 
Enter the TCP/IP address that you recorded from step 1 (above). At this time leave 
the MAC address fields empty. 

7. Save and close the IRIS Configurator program. 

8. Start the IRIS DVS application. 

9. Perform a test transaction on the monitor device. 

10. Using the IRIS DVS application window select Status > Monitor TCPIP port. If the 

IRIS system has detected the network traffic for the device the system will show a 
MAC address. 

11. Record this MAC address. (Systems with IRIS DVS Software version 10.02d or later 
will have a Save MAC button. Select this button and go to step 15. This button will 
automatically save the MAC address.) 

12. From the Main Menu select Config > Configuration. 

13. Using the IRIS Configurator, select Events > TCPIP Monitoring. 

14. Enter the MAC address that you recorded in a previous step. 

15. Clear-out all of the fields for the TCP/IP address and select the UPDATE button. 

16. Save and close the IRIS Configurator program. 
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17. Stop the IRIS DVS application. 

At this point the system has been programmed to use the MAC address instead of the 
TCP/IP address and will work for both the IRIS DVS Service and IRIS DVS Application 
programs. 
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Glossary 

Term Definition 

ATM  Automatic Teller Machine. Provides 24-hour access to 
deposits, cash, and accounts by customers. 

BNC Miniature radio frequency connector for coaxial cable 
invented by two engineers at Bell Labs named Neal and 
Councilman. The B stands for Bayonet. 

CAT5 Category 5 cable. Consists of twisted pairs inside an 
insulated jacket. Used for high-speed data transmission 
between pieces of equipment to reduce line loss and data 
garbling. (See Silver Satin.) 

Coax A 2-conductor cable in which one conductor is coaxial to 
the second. Used for RF and video transmission to reduce 
line loss. 

Data Inserter An electronic module that is used to interface between a 
transaction printer and the IRIS VEM. This interface 
triggers a video image capture and transfers transaction 
data to the IRIS PC. 

DB Connector A dual-row connector with various odd numbers of pins (9, 
15, 25, etc.) with various types of terminations (solder cup, 
crimp for ribbon cable, solder eye, printed circuit board 
pin, etc.) Used to connect various digital signal cables in 
the IRIS system. 

Ethernet Card An electronic module that plugs into the FX-Series unit 
card slot and provides an interface between the unit and a 
WAN router. 

Gateway Hub Another name for a network router. 
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Term Definition 

IP Address An address for each piece of electronic equipment 
connected to a proprietary network. The format for this 
address is XXX.XXX.XXX.XXX where the first 3 sections 
identify the facility location and the 4th identifies the 
individual piece of equipment. 

IRIS System Image Retention and Information System - A video image 
and data storage system proprietary to The Security 
Center, Inc. It operates within the Windows environment 
and is remotely accessible to view, retrieve, and print 
images and associated data. 

IRIS DVS Server An IRIS system that operates in the Windows 
environment, and allows the system to be accessible 
using either a WAN or modem connection. 

LAN Local Area Network connects devices located within the 
same building or a group of buildings in on geographical 
area as opposed to a WAN (Wide Area Network) which 
connects two or more sites located in different geographic 
areas. LANs use self-installed lines where WANs usually 
require leased lines. 

Modem An electronic device usually plugged into a device slot in a 
FX-Series system, which converts digital signals to 
standard telephone tones (modulator), or converts 
standard telephone tones to digital signals (demodulator). 
This makes it possible for two computers to communicate 
over standard telephone lines. 

Network A collection of electronic devices (usually PCs) connected 
together on a continuous basis either over dedicated lines 
leased from the phone company or through CAT5 cables 
and hubs and/or switches. 
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Term Definition 

Plenum Cable Any multi-conductor cable covered with insulation that has 
been tested to not produce toxic fumes when burned. 
Most building codes in high-rise and other drop-ceiling 
installations where ventilation systems are automatically 
shut-off by fire alarm activation requires this type of cable. 

Ribbon Cable Multi-conductor cables where the insulation for each 
conductor is bonded to the insulation of the conductors on 
either side of it. This produces a flat ribbon-like cable with 
all of the conductors parallel to one another thus reducing 
line loss in digital signals, which could corrupt data. 

RJ45 Connector Series of connectors designed to be used with Silver Satin 
and CAT5 cable for the communication industry. These 
connectors are slid onto the un-stripped conductors of a 
cable and crimped-on with a special tool. 

Router An electronic switching device used on a network to 
connect various pieces of equipment together to 
exchange data. 

Silver Satin A flat ribbon type cable with an outer jacket over the 
insulation of the individual conductors developed for the 
communications industry. Used with RJ-style connectors. 
Only the outer jacket needs to be removed with a special 
stripper before the RJ connector is crimped to the 
conductors. (See CAT5.) 

Sign Camera A proprietary IRIS camera installed in a slim metal and 
plastic housing used by the IRIS system to capture 
transaction images. A Sign Camera is mounted at each 
transaction window and may feature financial industry 
specific logo or custom artwork. 

Subnet Mask Used with IP Address to determine local segment 
information.  
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Term Definition 

Surveillance Camera An IRIS camera that monitors a particular area at a facility 
and has its images captured and stored based upon a 
preset time rotation with all other surveillance cameras. 
Surveillance cameras are not activated by a transaction. 

TouchScreen An LCD monitor with a thin transparent overlay, displaying 
a virtual keyboard or keypad, that converts touch pressure 
(via fingertip or stylus) into electronic signals that serve as 
keyboard or mouse input.  (The keyboard overlay can be 
minimized when not needed.)  An external keyboard and 
mouse are optional.  The IRIS TotalVisionTS was the first 
DVR in the CCTV industry to use a TouchScreen input 
device. 

Tower Camera A proprietary IRIS camera installed in a slim metal and 
plastic housing used by the IRIS system to capture 
transaction images. A Tower Camera is mounted at each 
transaction window. 

UPS Uninterruptible Power Supply. Represents an electronic 
device, which is plugged into AC power at the customer 
site and delivers regulated power to the IRIS system. 
Stand-by batteries in the UPS continue to deliver power to 
the PC in the event the site power fails. When the stand-
by batteries reach a predetermined discharge level the 
UPS can send a signal to the IRIS PC to initiate an orderly 
shutdown to prevent system problems. The length of time 
that the UPS will support the IRIS PC depends upon the 
size of the stand-by batteries and the amount of load from 
the IRIS system. 

VEM Short for Video Expansion Multiplexer. An electronic 
device used to connect multiple inputs to another 
electronic device in a logical order. In the IRIS system the 
VEM connects video signals from all cameras to the video 
capture card in the FX-Series unit.  May be internal or 
external. 
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Term Definition 

WAN Wide Area Network. A network which connects two or 
more sites located in different geographic areas, as 
opposed to a LAN (Local Area Network) which connects 
devices located within the same building or a group of 
buildings in a geographical area. WANs usually required 
leased lines where LANs use self-installed lines. 

Wide Dynamic Range Wide Dynamic Range describes the circuitry within a 
camera that analyzes lighting pixel-by-pixel.  This 
produces and image with much more detail under harsh or 
difficult lighting. The IRIS Total Light Control (TLC) 
camera models utilize wide dynamic range circuitry. 
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Appendix A 

IRIS ATM Interface Unit Installation and Service 

Product Description 

The IRIS ATM Interface unit is designed as an add-on option to the Bank IRIS system. 
Each IRIS ATM Interface unit is capable of monitoring one ATM unit. The IRIS ATM 
Interface unit will automatically adjust its data format to adapt to the Bank IRIS PC 
configuration requirements.  Contact IRIS Customer Service Department Support 
department for additional assistance. 

With the IRIS ATM unit installed, the Bank IRIS system can monitor ATM traffic and 
record images based on transaction data in much the same way that the basic Bank 
IRIS system records images based on teller transaction data. In fact the IRIS ATM 
interface unit makes the ATM appear as a unique and special teller position. All Bank 
IRIS and IRIS Inquiry functions that apply to teller images also apply to ATM images.  

To identify ATM transactions, a unique teller number is used. Since this teller number is 
unique and not assigned to a teller position at that location, retrieval and identification of 
ATM transactions can easily be accomplished. Refer to the System Set-up and 
Programming section, presented on page 171, for instructions on setting the ATM's teller 
number. 

Product Operation 

When the IRIS ATM unit is initially powered-up, the unit monitors the ATM network and 
determines the network address of the locally connected ATM unit. This network 
address is then used to filter all network traffic so that the IRIS ATM will only monitor 
messages for the desired ATM.  

When the IRIS ATM Interface unit determines that an ATM transaction has occurred, a 
message is sent to the Bank IRIS PC, indicating the type of transaction and the 
transaction sequence number. The Bank IRIS PC then uses this information to capture 
and catalog an image.  Transaction images are recorded and saved in a similar way to 
teller transactions. 

Note: The standard 
convention is to 
assign numbers 90, 
91, 92 ... 99 as the 
teller number for 
ATM units. Using 
this convention will 
enable the IRIS 
Inquiry software to 
automatically identify 
ATM transactions. 
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Set-up Instructions for Various ATM Installation Types 
The IRIS DVS supports various ATM installations. The chart on page 200 identifies 
several of the common ATM interfaces and how the IRIS system can be used to capture 
transaction information. 

Basic IRIS ATM Installation  

1. Use the ATM data cable supplied with the IRIS ATM Interface Unit, or fabricate a 
"Y” data cable as shown on page 183. Route the cable from the ATM data interface 
to the mounting location of the IRIS ATM. The cable end with the two DB-25 
connectors should be located at the ATM end. 

2. Connect the IRIS ATM Interface Unit as shown on the next page, depending on the 
installation. 

3. Using a data communication cable as shown on page 184, connect a PC to the DB-
9 connector of the IRIS ATM Interface Unit. Make sure the PC is running a 
communication program and the connected serial port is configured for 2400 baud, 
N-8-1 and that the control keys are passed to the serial port. 

4. Apply power to the IRIS ATM Interface Unit. The power LED should come on. This 
LED will flicker about once a second indicating that the unit is working correctly. If 
switch #2 was OFF, the unit will display a “sign-on” message on the terminal. 
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Figure 17 - IRIS ATM Installation 
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5. If switch #1 is OFF, the Sync LED should flash while the IRIS ATM unit is looking for 
the network address. Once a network address is found, the Sync LED will come on 
solid. If the LED does not come on solid within 10 seconds check the following: 

 Is the network up and running?  Check the status LED's on the ATM 
Interface Unit. 

 Is the "Y” data cable correctly fabricated and installed?  Make sure the 
connectors are  installed correctly and the cable is securely installed. 

 Check the internal jumpers on the IRIS ATM Interface Unit 

If switch #1 is ON, then the Sync LED will come on solid once the ATM interface 
completes initialization. 

6. Using the steps outlined for the Maintenance Menu, enter the Bank ID, teller 
number and transaction set-up information. Save the data by entering an "E". 

7. Monitor the ATM for a network poll. Verify that the IRIS ATM Interface Unit flashes 
the Rx LED periodically indicating that it is receiving the poll messages. If the LED 
does not flash on each poll, check the following: 

   Is the network up and running?  Check the status LED's on the ATM 
Interface Unit. 

   Is the "Y” data cable correctly fabricated and installed?  Make sure the 
connectors are  installed correctly and the cable is securely installed. 

  Is switch #1 ON?  If it is, then the unit will not acquire a new network 
address but use  the last saved network address. (Refer to Table 8 - IRIS 

ATM Switch Selections presented on page 181.)  If this address is not the 
 same as the current network address, the unit will not function. 

   Check the internal jumpers on the IRIS ATM interface. If the default 
jumper positions  do not work, try changing JP3-5 to JP3-6 and installing 
JP3-5 to JP3-7. 
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8. Monitor the ATM for a transaction or perform a transaction. Verify that the TX 
LED flashes indicating a transaction was detected and sent to the Bank IRIS 
system. In addition, the IRIS ATM Interface unit should have printed a 
transaction message on the PC indicating the transaction type, Bank ID, Teller 
ID, and sequence number. If everything is OK, remove the PC from the DB-9 
connector. If the IRIS ATM Interface is connected as shown in Figure , install 
the cable to the Bank IRIS system using the DB-9 connector and monitor the 
ATM for a second transaction or perform a second transaction.  

9. After the transaction is complete, connect to the Bank IRIS system and verify that 
the transaction was recorded along with the correct information. If the transaction 
was recorded, this completes the installation. If the transaction was not recorded, 
check the following: 

  If the installation is as shown in Figure , check the cable between the 
Bank IRIS PC  and the IRIS ATM Interface Unit. Is the cable correct and 
secure? 

System Set-up and Programming 

The IRIS ATM Interface unit has a built-in Maintenance Menu function that can be used 
to set-up the unit or to verify operation. To interface with the Maintenance Menu, 
connect a terminal or PC to the DB-9 connector on the back of the IRIS ATM Interface 
Unit using an interface cable as shown on page 184. All communication is done using 
2400 baud, 8 data bits, 1 stop bit, and no parity. 

To access the Maintenance Menu, the IRIS ATM Interface unit must be connected to the 
network and have received a network address (Sync LED ON – refer to the Status LED 
Function table presented on page 182) or Switch #1 must be ON to force the unit to use 
the saved network address. 
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Accessing the Maintenance Menu 

To access the Maintenance Menu type: <CTRL> A MM <CTRL> C. The unit should display 
the following menu items: 

 1) Teller ID Number 

 2) Bank ID Number 

 3) Network Address 

4) Toggle Data Capture Mode 

 5) Communication Protocol 

 6) Transaction Protocol 

H) Help 

 Q) Quit - Do Not Save 

 E) End - Save Data 

Menu Item: Teller ID Number 

Select this item to change the teller ID number. The teller ID number is used with each 
transaction to indicate that the ATM device completed the transaction. Generally, teller 
ID's of 90 through 99 are used to indicate ATM tellers.  

 The default teller ID is 99.  

 The teller ID number is a numeric field and can only contain the numbers 
 0 to 9.  

 The maximum number of characters in the field is 9. 

Menu Item: Bank ID Number 

Each transaction records the bank location where the transaction took place. The Bank 
ID is used to record this information. The Bank ID value should be set to the standard 
Bank ID value used for that location. Generally this is the same bank ID as used on teller 
transactions.  

 The Bank ID value is a numeric field and can only contain numbers 0 to 9.  
Maximum number of characters in the field is 9. 

Menu Item: Network Address 

For some ATM transactions, protocol communication on the network is accomplished in 
a multi-drop environment. In this case, each device on the network has a unique 

The standard 
convention is to 
assign numbers 90, 
91, 92 ... 99 as the 
teller number for 
ATM units. Using 
this convention will 
enable the IRIS 
Inquiry software to 
automatically 
identify ATM 
transactions. 
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address from 0x00 to 0xff. When the IRIS ATM device is powered up, it searches the 
network to determine the address used for the ATM device that is connected at this 
location. This is the function that is performed while the Sync LED is flashing. Generally 
the installer will not have to alter this field. In those rare cases where the installer wants 
to predefine the network address, the installer can enter a new value (between 0x00 and 
0xff). To ensure that the unit uses the save network address and does not hunt for a 
network address, the installer must turn Switch #1 ON. 

Menu Item: Toggle Data Capture Mode 

This diagnostic tool is used to display all network traffic to the installer. When this 
function is enabled, the IRIS ATM Interface unit will echo all network traffic addressed to 
the monitored unit to the DB-9 interface connector. Care should be taken not to leave 
this item enabled or system performance may be degraded. This diagnostic mode is 
automatically set to OFF on each power-up. 

Menu Item: Communication Protocol 

This menu item is used to select the communication protocol used on the RJ-45 
connector. The communication protocol on the DB-9 connector is fixed and cannot be 
altered. 

If the system is installed in a configuration as shown in Figure 27, all items connected to 
the IRIS VEM must be communicating at the same baud rate and format. Using this 
menu item, the installer can configure the RJ-45 port to be the same as all other teller 
interfaces.  

Default communication protocol is 9600 baud, 8 data bits, no 
parity, and 1 stop bit.  

Menu Item: Transaction Protocol 

This menu item is used to select the ATM protocol. The ATM interface supports seven 
(7) basic protocols. After selection of this menu item several sub-menus are displayed 
that allow the user to control where the ATM transaction data will be contained.  

 0) Camera Field Data 

 1) Multipoint HDLC 911 EBCDIC 

2) NCR TCP/IP Async 9600 N81 Interface 

3) InterBold TCP/IP Async 9600 N81 Interface 

The most common 
method of ATM 
communication involves 
using the Camera Field.  

The second most 
popular method 
involves setting the IRIS 
ATM Interface Unit to 
specify the location of 
the ATM transaction 
number contained in the 
print field information. 
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4) BiSync 911 Emulation Interface 

5) SDLC 911 ASCII Sync N81 

6) Async 911 ASCII 4800 E71 

Options 0 and 1 are used when the ATM is connected to a SDLC/HDLC multi-drop 

network. In this configuration the device will detect a unique address since the system is 
on a polled multi-drop line. 

Options 2 and 3 are used when the ATM is connected to a TCP/IP network and the 

ATM provides a serial output port to a camera recorder. 

Option 4 is used when the ATM is connected to a Bi-Sync 911 emulation network. 

Typically this type of network may be used on a dial-up modem or a free standing ATM.  

Option 5 is used when the ATM is connected using SDLC point-to-point protocol. 

Printed data can be sent in ASCII or EBCDIC format. 

Option 6 is typically used at free standing or walk-up style ATM’s.  Communication to 

the central host is accomplished using asynchronous 4800 Baud 7, E, 1 with 911 
protocols.  Normally this will be using a dial-up phone line and an external modem. 
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The next option specifies the character format used for the data sent to the printer. Each 
of the transaction protocols identified in the previous step specify a default character 
format, either ASCII or EBCDIC but this option can be used to override and change that 
default character format. If a transaction protocol supports both ASCII and EBCDIC 
formats then this option will be shown. 

0) EBCDIC 

1) ASCII 

The next option specifies the end-of-line character used in the printed receipt field. 
There are two possible choices: a line-feed character (LF) or a new line or carriage 
return (NL). Starting with version 4.04 of the IRIS ATM Interface firmware this option is 
not necessary but is retained for backward compatibility. Starting with version 4.04, the 
IRIS ATM Interface firmware checks for both end-of-line symbols. 

 0) LF 

 1) NL 

In normal operation, the IRIS ATM Interface unit captures the print field information 
contained in the ATM communication protocol and provides this information to the user 
using the two communication ports. During installation, the unit can be programmed to 
only capture and display a subset of the lines from the print field. The number of lines to 
be captured is programmed as follows: 

 Number of Print Lines to Display - 10 

This will enable the IRIS ATM Interface to capture and display the first ten (10) lines of 
the ATM print field. 
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For most transaction protocols, the user can specify the location of the transaction 
number by specifying the print line and character position of the transaction number. 

 Transaction Number on Line - 10 

 Transaction Number in Position - 5 

This example will program the IRIS ATM Interface unit to look for the transaction number 
on the 10th line of the print field. The first four (4) characters on that line will be ignored 
and the unit will capture the first numeric string starting after the 5th character. 

If the user set both the Transaction Number Line number and Position Number to 0, then 
the system will automatically determine the transaction number from the camera field 
number in the transaction. This is the preferred method of setting the transaction number 
capture. 

The next field specifies the maximum number of lines in a transaction. This field should 
be set to a number as big as or bigger than the number of print lines to display. 

Number of lines in transaction – 10 

As an added safeguard, the ATM Interface unit measures the time between transaction 
packets. The transaction delay time is the maximum amount of time that is permitted 
between packets for the same transaction. This parameter used primarily for transaction 
protocols 2 and 3.  By default the transaction delay time is set to 750ms. This setting 
should be adequate for all field installations and should not be changed without 
contacting the IRIS Customer Service Department. 

Transaction delay time (10ms) - 75 

Menu Item: Quit - Do Not Save 

Selection of this menu item will terminate the Maintenance Menu but will not save any 

of the entered parameters. The only option still in effect will be the toggle data capture 
mode if the item was selected. 

Menu Item: End - Save Data 

Selection of this menu item will terminate the Maintenance Menu and will save all 

parameters entered. After saving all data, recycle the power to the ATM Interface unit for 
settings to take place. 

NOTE: Do not leave 
the IRIS ATM 
Interface Unit in the 
Maintenance Menu 
mode. Selection of 
the Maintenance 
Menu mode interrupts 
operation of network 
monitoring for valid 

transactions. 
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ATM I/F Jumper Selection  

The IRIS ATM Interface unit has a jumper block that is divided into seven (7) major 
sections. This jumper block is used to configure the unit operation and defines pin-outs 
for various communication signals. In most cases, the factory default setting should be 
adequate.  However, if installation requirements vary, the jumper selections can be 
changed to alter the unit’s configuration. Units come from the factory in the default 
mode. 

 

Figure 18 - Jumpers on ATM I/F PCB 
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Figure 19 - Jumper Locations 

Selection of DCE (Network) Data and Clock 

The JP3 section of the jumper block is used to configure the DCE or Network side of the 
interface connector. 

JP3-1 to JP3-2 DCE TX data from Pin 2 of DB-25 connector (TXD) 

JP3-1 to JP3-3 DCE TX data from Pin 3 of DB-25 connector (RXD) (default) 

Table 2 - Selection of Network Data Source 

JP3-5 to JP3-6 DCE TX clock from JP8 selection (Default) 

JP3-5 to JP3-7 DCE TX clock from Pin 15 of DB-25 connector (TC) 

JP8-1 to JP8-2 DCE TX clock from Pin 17 of DB-25 connector (RC) (default) 

JP8-3 to JP8-4 DCE TX clock from Pin 24 of DB-25 connector (DA) 

Table 3 - Selection of Network Clock Source 



APPENDIX A   

001.09 179 IRIS FX-Series DVR’s  

Selection of DTE (ATM) Data and Clock 

The JP2 section of the jumper block is used to configure the DTE or ATM side of the 
interface connector. 

JP2-3 to JP2-4 DTE TX data from pin 2 of DB-25 connector (TXD) (default) 

JP2-3 to JP2-5 DTE TX data from pin 3 of DB-25 connector (RXD) 

JP2-3 to JP2-1 DTE TX data from pin 3 of J4 (optional DB-9 connector) 

Table 4 - Selection of ATM Data Source 

Selection of Serial Port Operation 

The JP7 section of the jumper block is used to configure the DB-9 serial port on the rear 
of the IRIS ATM Interface unit. Generally these jumpers should not be changed in the 
field and are configured at the factory for the hardware configuration of the assembly. 

JP7-1 to JP7-2  Maintenance Port RXD on DB-9-pin 3 to CPU UART (default) 

JP7-1 to JP7-3  Maintenance Port RXD on DB-9-pin 3 to Auxiliary UART 

JP7-5 to JP7-6  Maintenance Port TXD on DB-9-pin 2 to CPU UART (default) 

JP7-5 to JP7-7  Maintenance Port TXD on DB-9-pin 2 to Auxiliary UART 

Table 5 - Serial Port Operation 

The ATM clock source 
is always derived from 
pin 17 of DB-25 
connector (RC). 
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External Reset Connector 

The JP4 section of the jumper block is used to connect an external reset switch. 
Connecting JP4-1 to JP4-2 will cause a hardware reset for the unit. 

Selection of Watchdog Operation 

The JP5 and JP6 section of the jumper block is used to select watchdog operation for 
the unit. 

JP5-1 to JP5-2  Watchdog not enabled (default) 

JP6-1 to JP6-2  Watchdog enabled 

Table 6 - Watchdog Operation 

Selection of Power Source 

The JP1 section of the jumper block is used to enable remote power for the IRIS ATM 
unit. Generally, the IRIS ATM Interface unit is installed with a small wall-mounted 
transformer. This wall-mounted transformer is connected to the power plug on the rear 
of the unit and supplies power to the unit.  

JP1-1 to JP1-2 (installed)   Power from RJ-45 Connector. 

JP1-1 to JP1-2 (removed)  Power from wall mounted power transformer. 

Table 7 - Remote Power Selection 
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Switch Selection 

The IRIS ATM unit contains a 6-position dipswitch that is used to select various firmware 
options.  The following table identifies the switch functions. 

Position Default Function 

Switch #1 OFF If ON, the unit will use the last saved net address and will not search for new 
address. 

Switch #2   ON If ON, unit sends IRIS format commands on RS-232 port. With the switch 
OFF, data is not sent in the IRIS format. (Normally Switch #2 is ON if ATM is 
connected directly to IRIS-DVS PC.) 

Switch #3 ON Used for transaction protocol #4 Bi-Sync 911 emulation mode. If switch is 
ON then do not check CRC. 

Switches #4-#6   OFF Not used. 

Table 8 - IRIS ATM Switch Selections 

 

Figure 20 - Switch on ATM I/F PCB 
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ATM I/F LED Functions 

The front of the IRIS ATM Interface unit has several status LED's. The function of these 
LED's is: 

Power LED is ON while unit is powered. LED flickers once a second to indicate unit is 
operational. 

Sync LED flashes while unit is looking for network address. Once a network address has 
been acquired the LED will remain ON solid. 

Rx LED flashes when unit detects a message for the monitored ATM. Normally the 
network should periodically poll the ATM and cause the LED to flash. 

Tx LED flashes when the IRIS ATM Interface detects a valid transaction for the ATM 
and sent a message to the Bank IRIS. 

Video LED flashes to indicate that BANK IRIS is capturing images. Feature is only active 
when IRIS ATM Interface unit used with BANK IRIS and no IRIS VEM. 

Table 9 - Status LED Function 

 

Figure 21 - Jumper and Switch Location on ATM I/F PCB 
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Male
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1 1 

2 2 
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10 10 
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16 16 
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22 22 

23 23 

24 24 

25 25 

 

Figure 22 - DB-25 Y Data Cable
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Female
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4 4 

5 5 

6 6 

7 7 

8 8 

9 9 

 

Figure 23 - DB-9 Data Cable 
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Additional Commands Supported by IRIS ATM Interface 

In addition to the standard IRIS VEM commands, the IRIS ATM Interface Unit also 
supports the following additional commands: 

NAxxxx - Assigns net address xxxx to unit. Note xxxx is a decimal value. 

BIxxx - Assigns bank identifier to unit for use in transaction messages to IRIS. 

TIxxx - Assigns teller identifier to unit for use in transaction message to IRIS. 

MM - Go to Maintenance Mode and display menu. 

Synchronous SDLC/HDLC Multi-Drop ATM Operation 

Some ATMs communicate to the central host using synchronous SDLC communications. 
Typically these ATM are drive-up or bank lobby units and a co-located with other ATMs or on-
line banking equipment. This setting is to be used for multipoint networks where each unit has 
an individual address based on the communication protocol. 

1. Once the ATM Data Interface is connected to the ATM network we can proceed 
with setting-up the ATM Data Interface and the IRIS DVS to capture transaction 
information. 

2. Remove the four (4) screws on the bottom of the case, and remove the cover. 

3. Make sure jumpers JP8 1-2, JP3 1-3, JP3 5-6, JP2 3-4, JP5 1-2, JP7 1-2, and JP7 
5-6 are installed. 

4. Place switch 1 ON, switch 2 OFF. 

5. Using a 9-pin cable, connect the ATM Data Interface to the serial port of a laptop. 
This cable is a direct-connect cable and does not require a modem-eliminator cable. 
(See ATM Data Interface Manual for detailed connection information on RS-232 
cable.) 

6. Apply power to the ATM Data Interface. The Power and Sync LED’s should come 
ON solid. 

7. Enter <Ctrl> A MM <Ctrl> C on the terminal to bring up the Maintenance Menu. 

8. Using menu item 1, set the teller number. 

9. Using menu item 2, set the bank ID number. 

Note: All Commands 
must follow the 
standard IRIS serial 
protocol of: CTRL A 

Command CTRL C. 
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10. Select menu item 5 and set the: 

 Transaction protocol to (1) Multipoint HDLC 911 EBCDIC  

 Character format to EBCDIC (0) 

 End of line character to (0) LF 

 Number of lines displayed to 12 

 Transaction number on line to 0 

 Transaction number in position to 0 

 Number of lines in transaction to 16 

 Transaction delay to 75  

11. Using menu item “E”, save the settings and close the Maintenance Menu. 

12. Set switch S1 position 1 OFF and position 2 ON. Remove and reapply power to the 
ATM Data Interface. Leave the ATM Data Interface connected to the serial port 
terminal. 

13. The ATM Data Interface power LED should come ON solid. The Sync LED should 
flash briefly. Once the ATM Data Interface is synchronized with the network, the 
Sync LED will come ON solid or it may flash as data is received. Verify that the ATM 
Data Interface displayed “PU00” on the terminal connected. 

14. Run a test transaction on the ATM and compare the results shown on the serial port 
terminal with the printed ATM receipt. 

15. The terminal should display several lines. Each line should start with MR01:L0x: 
where ‘x’ is the line number. 

 If the information shown on the terminal does not contain the same number of 
lines as shown on the printed ATM receipt, then repeat steps 7, 10, and 11 but 
set the End of Line Character to (1) NL.  Then repeat steps 14 and 15.  

 If no data is shown or the data seems garbled, repeat steps 7, 10, and 11 but 
set the Character Format to (1) ASCII.  Then repeat steps 14 and 15. 

16. The last line shown on the terminal should look something like; “B:4444 T:99 
S:1234.” The number after the “S:” is the sequence number. Verify that this is the 
same as the sequence number printed on the ATM receipt.  

 If the two numbers are the same, go to step 19.  
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 If they are different, go to step 17 to change the capture of the sequence 
number from the Camera Field to the Print Field. 

17. Using the ATM printed data shown on the terminal, find the transaction number. At 
the beginning of this line, there will be “MR01:Lxx:.” Record the number shown on 
the terminal for “xx”; this is the line number of the transaction. To locate the 
character position, count the number of characters from the “MR01:Lxx:” to the first 
character in the sequence number. Start counting with the first character after the 
“:Lxx:” and do not count the first character of the sequence number. 

Example: “MR01:L10:DEPOSIT SEQ 1234”. 

In this example, the transaction number is 1234, the transaction is on line 10, and 
the transaction is at character position 12. Make sure all space characters are 
counted. Record the transaction line number and the transaction character position, 
and go to step 18 to save the numbers. 

18. Repeat steps 7, 10, and 11 but set the transaction line number to the number 
observed in step 17, and set the transaction character position to the character 
position recorded in step 17. Repeat steps 14, 15, and 16 to verify that the ATM 
Data Inserter is now capturing the correct transaction sequence number. 

19. Compare the ATM printed data shown on the terminal with the ATM receipt. If the 
data shown on the terminal is terminated before the end of the receipt data, repeat 
steps 7, 10, and 11 and increase the number of lines to display. Do not increase the 
number of lines to display past the line number that was used for the transaction. 
Repeat steps 14, 15, and 16 to verify that the complete ATM receipt data is now 
displayed. 

20. Repeat step 14. Save a copy of the data captured on the terminal as this 
information will be used in setting-up the IRIS DVS. 

This completes the set-up portion of the ATM Data Interface. 

21. Connect the ATM Data Interface to the IRIS DVS system.  

 Leave switch S1 position 2 ON.  

This completes the set-up requirements for the Synchronous SDLC/HDLC Multi-
Drop ATM Operation. 
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Synchronous SDLC/HDLC Point-to-Point ATM Operation 

Some ATM’s communicate to the central host using synchronous SDLC communications. 
Typically these ATM are drive-up or bank lobby units. This setting is to be used for point-to-
point communications and not for multipoint networks where each unit has an individual 
address based on the communication protocol. 

To set the ATM Interface unit in the mode for synchronous operation, use the following 
procedure: 

1. Once the ATM Data Interface is connected to the ATM network, proceed with 
setting-up the ATM Data Interface and the IRIS DVS to capture transaction 
information. 

2. Remove the four (4) screws on the bottom of the case, and remove the cover. 

3. Make sure jumpers JP8 1-2, JP3 1-3, JP3 5-6, JP2 3-4, JP5 1-2, JP7 1-2, and JP7 
5-6 are installed. 

4. Place switch 1 ON, switch 2 OFF. 

5. Using a 9-pin cable, connect the ATM Data Interface to the serial port of a laptop. 
This cable is a direct-connect cable and does not require a modem-eliminator cable. 
(See ATM Data Interface manual for detailed connection information on RS-232 
cable.) 

6. Apply power to the ATM Data Interface. The Power and Sync LED’s should come 
ON solid. 

7. Enter <Ctrl> A MM <Ctrl> C on the terminal to bring up the Maintenance Menu. 

8. Using menu item 1, set the teller number. 

9. Using menu item 2, set the bank ID number. 

10. Select menu item 5, and set: 

 Transaction protocol to (5) SDLC 911 ASCII Sync 

 Format to ASCII (1) 

 End of line character to (0) LF 

 Number of lines displayed to 12 

 Transaction number on line to 0 

Currently the IRIS 
ATM supports all 
synchronous rates 
up to 19.2K baud. 
Data rates above 
this amount may 
yield unpredictable 
results.  
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 Transaction number in position to 0 

 Number of lines in transaction to 16 

 Transaction delay to 75.  

11. Using menu item “E”, save the settings and close the Maintenance Menu. 

12. Set switch S1 position 1 OFF and position 2 ON. Remove and reapply power to the 
ATM Data Interface. Leave the ATM Data Interface connected to the serial port 
terminal. 

13. The ATM Data Interface power LED should come ON solid. The Sync LED should 
flash briefly. Once the ATM Data Interface is synchronized with the network, the 
Sync LED will come ON solid or it may flash as data is received. Verify that the ATM 
Data Interface displayed “PU00” on the terminal connected. 

14. Run a test transaction on the ATM. Compare the results shown on the serial port 
terminal with the printed ATM receipt. 

15. The terminal should display several lines. Each line should start with “MR01:L0x:” 
where ‘x’ is the line number.  

 If the information shown on the terminal does not contain the same number of 
lines as shown on the printed ATM receipt then repeat steps 7, 10, and 11 but 
set the “End of Line Character” to (1) NL. Repeat steps 14 and 15. 

16. The last line shown on the terminal should look something like; “B:4444 T:99 
S:1234.” The number after the “S:” is the sequence number. Verify that this is the 
same as the sequence number printed on the ATM receipt. 

 If the two numbers are the same go to step 19.  

 If they are different go to step 17 to change the capture of the sequence 
number from the camera field to the Print Field. 

17. Using the ATM printed data shown on the terminal, find the transaction number. At 
the beginning of this line there will be “MR01:Lxx:. Record the number shown on the 
terminal for “xx”; this is the line number of the transaction. To locate the character 
position, count the number of characters from the “MR01:Lxx:” to the first character 
in the sequence number. Start counting with the first character after the “:Lxx:”, and 
do not count the first character of the sequence number.  

Example: “MR01:L10:DEPOSIT SEQ 1234”. 
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In this example, the transaction number is 1234, the transaction is on line 10, and 
the transaction is at character position 12. Make sure all space characters are 
counted. Record the transaction line number and the transaction character position, 
and go to step 18 to save the numbers. 

18. Repeat steps 7, 10, and 11, but set the transaction line number to the number 
observed in step 17.  Set the transaction character position to the character position 
recorded in step 17. Repeat steps 14, 15, and 16 to verify that the ATM Data 
Interface is now capturing the correct transaction sequence number. 

19. Compare the ATM printed data shown on the terminal with the ATM receipt. If the 
data shown on the terminal is terminated before the end of the receipt data, repeat 
steps 7, 10 and 11 and increase the number of lines to display. Note: Do not 
increase the number of lines to display past the line number that was used for the 
transaction. Repeat steps 14, 15 and 16 to verify that the complete ATM receipt 
data is now displayed. 

20. Repeat step 14. Save a copy of the data captured on the terminal as this 
information will be used in setting-up the IRIS DVS. 

This completes the set-up portion of the ATM Data Interface. 

21. Connect the ATM Data Inserter to the IRIS DVS system.  

 Leave switch S1 position 2 ON.  

This completes the set-up requirements for the Synchronous SDLC/HDLC point-
to-point ATM operation. 

Asynchronous ATM Operations  

Some ATM’s communicate to the central host using asynchronous communications. Typically 
these ATM are free standing or walk-up style ATMs. To set the ATM Interface unit in the 
mode for asynchronous operation, use the following procedure: 

1. Once the ATM Data Interface is connected to the ATM network, proceed with 
setting-up the ATM Data Interface and the IRIS DVS to capture transaction 
information. 

2. Remove the four (4) screws on bottom of case, and remove the cover. 

3. Make sure jumpers JP8 1-2, JP3 1-3, JP3 5-6, JP2 3-4, JP5 1-2, JP7 1-2, and JP7 
5-6 are installed. 
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4. Place switch 1 ON, switch 2 OFF. 

5. Using a 9-pin cable connect the ATM Data Interface to the serial port of a laptop. 
This cable is a direct connect-cable and does not require a modem-eliminator cable. 
(See ATM Data Interface manual for detailed connection information on RS-232 
cable.) 

6. Apply power to the ATM Data Interface. The Power and Sync LED’s should come 
on solid. 

7. Enter <Ctrl> A MM <Ctrl> C on the terminal to bring up the Maintenance Menu. 

8. Using menu item 1, set the teller number. 

9. Using menu item 2, set the bank ID number. 

10. Select menu item 5 and set: 

 Transaction protocol to (6) Async 911 4800, 7, E 

 Format to ASCII (1) 

 End of line character to (0) LF 

 Number of lines displayed to 12 

 Transaction number on line to 0 

 Transaction number in position to 0 

 Number of lines in transaction to 16 

 Transaction delay to 2  

(Currently the ATM Interface Unit only supports asynchronous communication at 
4800 baud 7 bits, even parity, and one stop bit.) 

11. Using menu item E, save the settings and close the Maintenance Menu. 

12. Set switch S1 position 1 OFF and position 2 ON. Remove and reapply power to the 
ATM Data Inserter. Leave the ATM Data Inserter connected to the serial port 
terminal. 

13. The ATM Data Interface power LED should come ON solid. The Sync LED should 
flash briefly. Once the ATM Data Interface is synchronized with the network, the 
Sync LED will come ON solid or it may flash as data is received. Verify that the ATM 
Data Interface displayed “PU00” on the terminal connected. 
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14. Run a test transaction on the ATM. Compare the results shown on the serial port 
terminal with the printed ATM receipt. 

15. The terminal should display several lines. Each line should start with “MR01:L0x:” 
where ‘x’ is the line number.  

 If the information shown on the terminal does not contain the same number of 
lines as shown on the printed ATM receipt, then repeat steps 7, 10 and 11 but 
set the End of Line Character to (1) NL. Repeat steps 14 and 15. 

16. The last line shown on the terminal should look something like; “B:4444 T:99 
S:1234.”. The number after the “S:” is the sequence number. Verify that this is the 
same as the sequence number printed on the ATM receipt.  

 If the two numbers are the same, go to step 19.  

 If they are different, go to step 17 to change the capture of the sequence 
number from the camera field to the Print Field. 

17. Using the ATM printed data shown on the terminal, find the transaction number. At 
the beginning of this line there will be “MR01:Lxx:.” Record the number shown on 
the terminal for “xx”; this is the line number of the transaction. To locate the 
character position, count the number of characters from the “MR01:Lxx:” to the first 
character in the sequence number. Start counting with the first character after the 
“:Lxx:” and do not count the first character of the sequence number.  

Example: “MR01:L10:DEPOSIT SEQ 1234”. 

In this example, the transaction number is 1234, the transaction is on line 10, and 
the transaction is at character position 12. (Make sure all space characters are 
counted.) Record the transaction line number and the transaction character 
position, and go to step 16 to save the numbers. 

18. Repeat steps 7, 10, and 11 but set the transaction line number to the number 
observed in step 17.  Set the transaction character position to the character position 
recorded in step 17. Repeat steps 14, 15, and 16 to verify that the ATM Data 
Interface is now capturing the correct transaction sequence number. 

19. Compare the ATM printed data shown on the terminal with the ATM receipt. If the 
data shown on the terminal is terminated before the end of the receipt data, repeat 
steps 7, 10, and 11 and increase the number of lines to display. Do not increase the 
number of lines to display past the line number that was used for the transaction. 
Repeat steps 14, 15 and 16 to verify that the complete ATM receipt data is now 
displayed. 
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20. Repeat step 14. Save a copy of the data captured on the terminal as this 
information will be used in setting up the IRIS DVS. 

This completes the set-up portion of the ATM Data Interface. 

21. Connect the ATM Data Inserter to the IRIS DVS system.  

 Leave switch S1 position 2 ON.  

This completes the set-up requirements for the Asynchronous ATM operation. 

ATM Interface TCP/IP ATM 

1. Remove the four (4) screws on bottom of case, and remove the cover. 

2. Place switches 1 and 2 to the ON position. 

3. Change jumpers J3.1 to J3.2 and J3.3 to J3.4. 

4. Reinstall cover and tighten four screws. 

5. Connect cable to host port, and set PC to 2400 N,8,1. Apply power to the ATM 
interface. Unit should display sign-on message. 

6. On the PC, enter <CTRL> A MM <CTRL> C to enter Maintenance Menu. 

7. Program the interface for operation with the NCR or InterBold (Diebold) ATM as 
shown below. 

8. Select the End and Save option by entering E. 

The ATM interface unit is now ready for operation. 

NCR Interface TCP/IP ATM 

1. Select option 6 to set the Transaction protocol. 

2. Set the transaction protocol to NCR TCP/IP option 2. 

3. Set the end of line character to LF (Option 0). 

4. Set the number of print Lines to 20. 

5. Set the transaction on line number to 9. 

These instructions 
apply to ATM 
interface with F/W 
version 4.01 or later. 
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6. Set the transaction position to 81 to use the network supplied transaction 
number that is contained in the camera field of the ATM transaction information 

from the network.  

To use the printed transaction number, set the transaction position to the 

character position number of the location where the transaction number is located 
on the transaction line. As an example if the transaction line is “WITHDRAW 0003” 
where the “0003 “ identifies the transaction number the transaction position should 
be set to 9. In test with past transactions the transaction number has been located 
at position 25. 

7. Select the End and Save option by entering E. 

This completes the set-up requirements for the NCR TCP/IP ATM. 

InterBold (Diebold) TCP/IP ATM 

1. Select option 6 to set the Transaction Protocol. 

2. Set the transaction protocol to InterBold TCP/IP option 3. 

3. Set the end of line character to LF (Option 0). 

4. Set the number of print lines to 20. 

5. Set the transaction on line number to 11. 

6. Set the transaction position to 25. 

7. Select the End and Save option by entering E. 

This completes the set-up requirements for the Diebold TCP/IP ATM. 
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NCR ATM with Internal Modem  

This procedure applies to the NCR Model 0101 Class 5870 ATM with built-in modem. 
(Note: This procedure may also apply to other NCR ATMs since all NCR ATM machines 
should be capable of supporting the camera interface port.) 

Most NCR ATM machines include a camera interface port. This RS-232 serial port can 
be used to capture transaction data once the ATM is configured correctly. The IRIS 
system has an optional IRIS NCR ATM Interface kit that can be used to configure the 
NCR ATM and connect the ATM to the IRIS system. The kit includes a configuration disk 
for the NCR ATM, required interface cables, and complete instructions for the NCR ATM 
and IRIS DVS system. 

This completes the set-up requirements for the NCR ATM with built-in modem. 
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IRIS ATM using Bi-Sync Communication Protocol 

There are various ATM network configurations in use. The IRIS DVS system is capable 
of interfacing with these systems using the ATM Data Inserter but the interface must be 
configured correctly. This section provides a guide in connecting the IRIS DVS system to 
ATMs and addresses most common installation problems and only applies to ATMs that 
are using a Bi-Sync communication protocol. If the ATM is using a TCP/IP protocol, refer 
to page 167. 

Identify Network Type  

To identify the type of network being used, locate the ATM’s connection to the network.  

 If the network protocol is a Bi-Sync protocol, the ATM’s network connection will be 
connected directly to a modem using a 25-conductor cable (round or flat). The 
connector on the ATM is normally a DB-25 connector. The modem will then be 
connected to a phone line. The modem should indicate that the connection is 
synchronous and will typically show data traffic periodically even when the ATM is 
not being used.  

 If the ATM is connected to the network using an RJ-45 connector or is connected to 
an Ethernet router or hub, the ATM is not using a Bi-Sync communication protocol.  

 If the modem is not on-line at all times or appears to be an asynchronous modem 
then the network connection may not be a Bi-Sync connection but may instead be 
an on-demand dial-up connection.  

Connect to Network 

Before starting, verify that the ATM is operational. Fabricate a Y interface cable for the 
ATM Data Interface Unit as shown in the Installation Manual.  

1. At the ATM network connector, remove the data cable from the modem.  

2. Connect the data cable from the modem to one of the connectors on the Y interface 
cable.  

3. Connect the other end of the Y interface cable to the ATM network connection.  

4. Before connecting the ATM Data Interface, check to verify that the ATM is still 
operational. If the ATM is not operational, recheck the Y interface cable. There is 
something wrong with the cable wiring.  

This set-up 
procedure only 
applies to ATMs 
that use a Bi-Sync 
communication 
protocol. 
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5. Connect the remaining end of the Y interface cable to the ATM Data Inserter and 
apply power to the ATM Data Interface.  

6. Check to verify that the ATM is still operational. If the ATM is not operational, 
remove the Y interface cable from the ATM Data Interface and check the jumpers 
inside the ATM Data Interface. (Refer to the following Jumpers section.)  

7. After correcting the jumpers, reconnect the Y interface cable to the ATM Data 
Inserter and verify that the ATM is operational. 

Verify ATM Data Inserter Jumpers 

To verify the ATM Data Inserter jumper settings, turn the ATM Data Interface over, and 
locate the four (4) small Phillips head screws.  

1. Remove the four (4) screws and remove the top half of the enclosure.  

2. Verify the jumper settings are the same as the default settings listed in the ATM 
Data Interface Manual.  

Set-up ATM Data Interface 

1. Once the ATM Data Interface is connected to the ATM network, proceed with 
setting-up the ATM Data Interface and the IRIS DVS to capture transaction 
information. 

2. Using the procedure outlined in Verifying ATM Data Interface Jumpers (page 

197), remove the top half of the enclosure. Set switch S1 position 1 ON and set 
position 2 OFF. 

3. Using a 9-pin cable, connect the ATM Data Interface to the serial port of a laptop. 
This cable is a direct-connect cable and does not require a modem-eliminator cable. 
(See ATM Data Interface manual for detailed connection information on RS-232 
cable.) 

4. Apply power to the ATM Data Inserter. The Power and Sync LED’s should come 
ON solid. 

5. Enter <Ctrl> A MM <Ctrl> C on the terminal to bring up the Maintenance Menu. 

6. Using menu item 1, set the teller number. 

7. Using menu item 2, set the bank ID number. 
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8. Select menu item 5 and:  

 Set the transaction protocol to (0) Camera Field 

 Set the end of line character to (0) LF 

 Set the number of lines displayed to 10 

 Set the transaction number on line to 10 

 Set the transaction number in position to 5 

9. Using menu item E, save the settings and close the Maintenance Menu. 

10. Set switch S1 position 1 OFF and position 2 ON. Remove and reapply power to the 
ATM Data Interface. Leave the ATM Data Interface connected to the serial port 
terminal. 

11. The ATM Data Interface power LED should come ON solid. The Sync LED should 
flash briefly. Once the ATM Data Interface is synchronized with the network the 
Sync LED will come ON solid. Verify that the ATM Data Interface displayed “PU00” 
on the terminal connected. 

12. Run a test transaction on the ATM and compare the results shown on the serial port 
terminal with the printed ATM receipt. 

13. The terminal should display several lines. Each line should start with “MR01:L0x:” 
where ‘x’ is the line number. If the information shown on the terminal does not 
contain the same number of lines as shown on the printed ATM receipt then repeat 
steps 5, 8, and 9 but set the End of Line Character to (1) NL. Repeat step 12 and 
13. 

14. The last line shown on the terminal should look something like; “B:4444 T:99 
S:1234.”  The number after the “S:” is the sequence number. Verify that this is the 
same as the sequence number printed on the ATM receipt.  

 If the two numbers are the same, go to step 17. 

 If they are different, go to step 15 to change the capture of the sequence 
number from the camera field to the Print Field. 

15. Using the ATM printed data shown on the terminal, find the transaction number. At 
the beginning of this line there will be “MR01:Lxx:.” Record the number shown on 
the terminal for “xx” as this is the line number of the transaction. To locate the 
character position, count the number of characters from the “MR01:Lxx:” to the first 
character in the sequence number. Start counting with the first character after the 
“:Lxx:” and do not count the first character of the sequence number.  
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Example: “MR01:L10:DEPOSIT SEQ 1234” 

Here the transaction number is 1234, the transaction is on line 10, and the 
transaction is at character position 12. Make sure to count all space characters. 
Record the transaction line number and the transaction character position, and go 
to step 16 to save the numbers. 

16. Repeat steps 5, 8, and 9 but set the “Transaction Protocol” to (1) Print Field Data 
using 'TRAN,#' key. Set the transaction line number to the number observed in step 
15.  Set the transaction character position to the character position recorded in step 
15. Repeat steps 12, 13, and 14 to verify that the ATM Data Interface is now 
capturing the correct transaction sequence number. 

17. Compare the ATM printed data shown on the terminal with the ATM receipt. If the 
data shown on the terminal is terminated before the end of the receipt data repeat 
steps 5, 8, and 9 and increase the number of lines to display. Note: Do not increase 
the number of lines to display past the line number that was used for the 
transaction. Repeat steps 12, 13, and 14 to verify that the complete ATM receipt 
data is now displayed. 

18. Repeat step 12. Save a copy of the data captured on the terminal as this 
information will be used in setting up the IRIS DVS. 

This completes the set-up portion of the ATM Data Interface.  

19. Connect the ATM Data Inserter to the IRIS DVS system. 

 Leave switch S1 position 2 ON.  

This completes the set-up requirements for the Bi-Sync Communication Protocol. 

Set-up ATM Transaction Data 
Follow the instructions in the IRIS DVS Installation manual for set-up of the ATM 
Transaction. By saving a copy of the ATM printed transaction data captured in “Set-up of 
ATM Data Inserter and IRIS DVS” it will be easy to identify the three (3) lines to be 
captured along with the video image. 

1. Start the IRIS Configurator program.  

2. From the Main Menu, select Events > ATM Transactions.  

3. Using the data captured in step 18, select 3 lines that will be displayed at the bottom 
of each ATM transaction image. 
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IRIS FX-Series ATM Installation  

  ATM Network Connection Description Installation Instructions 

Modem
ATM

HDLC

Dedicated

Phone Line

to ATM Network

HDLC Multipoint ATM 

Typical ATM installation 
using HDLC multipoint 
protocol. Host system polls 
ATM using a specific 
network address. ATM 
uses 911 protocols. 

Install IRIS ATM Interface Unit 
between modem and ATM using 
“Y” cable. See IRIS Installation 
Manual. IRIS ATM Interface unit 
programmed for transaction 
protocol 1. Refer to page 185. 

Modem
ATM

SDLC

Dedicated

Phone Line

to ATM Network

SDLC ATM 

ATM installation using 
SDLC point-to-point 
protocol. Printed data sent 
in ASCII format. Speed 
determined by 
synchronous modem. ATM 
uses 911 protocols. 

Install IRIS ATM Interface Unit 
between modem and ATM using 
“Y” cable. See IRIS Installation 
Manual. IRIS ATM Interface unit 
programmed for transaction 
protocol 5 

Modem
ATM

Bi-Sync
Dial-Up

Phone Line

 

Bi-Sync NCR 911 Emulation 

Modem polls ATM to 
determine when 
transaction started. 
Modem responsible for 
dialing network and 
connecting ATM to 
network.  

Install IRIS ATM Interface Unit 
between modem and ATM using 
“Y” cable. See IRIS Installation 
Manual. IRIS ATM Interface unit 
programmed for transaction 
protocol 4. 

Modem
ATM

Async
Dial-Up

Phone Line

Asynchronous ATM 

Typically these ATM are 
free standing or walk-up 
style ATM’s.  
Communication to the 
central host using 
asynchronous 4800 baud, 
7, E, 1 with 911 protocols.  

Install IRIS ATM Interface Unit 
between modem and ATM using 
“Y” cable. See IRIS Installation 
Manual. IRIS ATM Interface unit 
programmed for transaction 
protocol 6. 
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  ATM Network Connection Description Installation Instructions 

ATM
Router

Ethernet

 

TCP/IP ATM 

TCP/IP ATM connected 
directly to TCP/IP network. 
Does not have camera 
port option. 

Must install Ethernet hub on 
Ethernet segment between router 
and ATM so that IRIS DVS can 
monitor data. Ethernet data 
monitored directly by IRIS DVS 
(IRIS ATM Interface unit not 
required). See IRIS Installation 
Manual. 

ATM
Router

Ethernet

Camera

Serial

Port

 

TCP/IP ATM with Serial Port 

TCP/IP ATM connected 
directly to TCP/IP network. 
ATM has camera port 
option. 

Install IRIS ATM Interface unit to 
ATM Camera serial port using 
modem emulator cable. See IRIS 
Installation Manual. and IRIS 
ATM VEM users manual 
appendix D. IRIS ATM Interface 
unit programmed for transaction 
protocol 2 or 3 depending on 
model of ATM. 

ATM

SDLC

Link ConverterRouter

Ethernet

Link Converter ATM 

Link converter used to 
connect older SDLC ATM 
to TCP/IP network. 

Transaction data can be 
monitored at either Ethernet 
connection (using a network 
connection) or at the SDLC 
connection (using the IRIS ATM 
Interface). See TCP/IP ATM for 
network connection (will need to 
use MAC address instead of 
TCP/IP address). See SDLC ATM 
if using IRIS ATM Interface. 

ATM

Dial-Up

Phone Line

Telephone

 

Dial-up ATM 

ATM has built-in telephone 
mode. At start of 
transaction ATM dials 
network to complete 
transaction. 

Configuration only supported if 
ATM has optional serial camera 
port. With this option ATM sends 
ASCII data to serial port on each 
transaction. Connect ATM 
Interface unit to serial port. 
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A 

Activity Log Set-up, 93 

Add 

DVS Users, 132 

Adjust 

Brightness/Contrast, 112 
Motion Detect Sensitivity, 122 

Administrator Password, 132 

Alarm 

Configuration, 43, 76 
Enable Phone Report, 79 
Enable Watchdog, 77 
Exclusive Camera Record, 77 
Level, 46 
System Alarms, 77 

Alarm Inputs 

Active State for Input, 80 
Alarm Enabled, 80 
Alarm Input Specification, 82 
Record Surveillance Cameras, 80 
Record Time in Seconds, 80 
Report Alarm, 80 

Alarm Outputs, 82 

Alarm Wiring 

Alarm Input Wiring, 81 
Alarm Output Wiring, 81 

Answer on Ring, 86 

Application Window, 41 

Asynchronous ATM Operations, 190 

ATM 

ATM Interface Unit, 167 
Configuration, 70, 71 
Configuration Style, 73, 75 
Interface, 136, 139, 200 

Receipt Information, 67 

ATM Bi-Sync Installations 

Set-up ATM Transaction Data, 199 
Set-up for ATM Data Inserter, 197 

ATM Installation 

Accessing Maintenance Menu, 172 
Additional Commands, 185 
Asynchronous ATM, 201 
Asynchronous Communications, 190 
Dial-up ATM, 201 
Diebold TCP/IP ATM, 194 
External Reset Connector, 180 
HDLC Multipoint ATM, 201 
I/F Status LED Functions, 182 
Interface for TCP/IP, 193 
Jumper Selection, 177 
Link Converter ATM, 201 
NCR ATM, 195 
NCR TCP/IP, 193 
Product Description, 167 
Product Operation, 167 
SDLC ATM, 201 
Selection of DCE, 178 
Selection of DTE, 179 
Selection of Serial Port Operation, 179 
Selection Power Source, 180 
Selection Watchdog Operation, 180 
Set-up Submenus, 173 
Switch Selection, 181 
Sync NCR 911 Emulation, 201 
Synchronous SDLC/HDLC, 185 
System Set-up and Programming, 171 
TCP/IP ATM, 201 
TCP/IP ATM with Serial Port, 201 

ATM Menu Item 

Bank ID, 172 
Communication Protocol, 173 
Network Address, 172 
Quit, 176 



INDEX   

001.09 203 IRIS FX-Series DVR’s  

Save, 176 
Teller ID, 172 
Toggle Data Capture Mode, 173 
Transaction Protocol, 173 

ATM Transaction Data, 69 

B 

BNC, 24, 136, 161 

Brightness 

Adjust, 112 

C 
Cable and Connector Specs, 136 

Cable Illustrations, 147 

Cabling and Connections, 21 

Bundling, 21 
Specifications, 136 

Calibrate Illumination, 46, 50 

Camera 

Properties, 47 
Transaction, 25 
Video Expansion Multiplexer, 24 

Camera Name Assignment, 48, 51 

CAT 5, 23, 24, 136, 139, 161, 163 

Coax, 135, 161 

Com Port, 136 

Configuration, 88 

Compression Factor, 53 

Configuration Map, 72, 73, 75 

Configurator, 37 

Connect to a Network Time Server, 36 

Contrast 

Adjust, 112 

Control Panel, 35 

Customer Field Size, 65, 66 

D 

Data Inserter, 136, 161 

Day and Hour Scheduling, 62 

DB Connector, 161 

Default communication protocol, 173 

Diagrams 

75 Ohm Coax Video Cable, 149 
8-Conductor Flat Communication Cable, 148 
ATM Installations, 140 
ATM Interface Module, 139 
DB-25 Y Data Cable, 183 
DB-25 Y Data Cable for ATM Connection, 151 
DB-9 Data Cable, 147, 184 
Jumper and Switch Location on ATM I/F PCB, 

182 
Jumper Locations, 178 
Jumpers on ATM I/F PCB, 177 
Sample TotalVisionTS Installation, 17 
Switch on ATM I/F PCB, 181 
TotalVisionTS Unit, 19 
Transaction Cameras, 25 
UPS, Typical, 22 
Video Camera and Power Supply, 150 

Disk Usage, 43, 90, 92 

Disk Allocation, 92 
Max Number of Days, 90 
Minimum Transaction Age, 91 
Reserved Disk Space, 90 

Display Lines, 70 

Displaying Images by Row, 128 

Dynamic IP Address, 158 

E 

Embedded System, 101 

Enable Watchdog, 77 
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Error Beep Codes, 129 

Ethernet Card, 161 

F 

Fluorescent Lighting, 21 

Focus, 26 

G 

Gateway Hub, 161 

Global 

Brightness Setting, 112 
Contrast Setting, 115 

Glossary, 161 

I 

Illumination 

Calibrate, 46 
Monitor, 46 

Image Display, 67 

Image Selection, 46, 53, 54 

Images per Transaction, 65 

Individual Camera 

Brightness, 117 
Contrast, 120 

Installation Diagrams, 17, 18 

Internet, 2 

Introduction, 13 

IP Address, 35, 162, 163 

IRIS Configurator, 37 

Close, 94 

IRIS Configurator Events Menu 

Alarm Configuration, 43, 76 
ATM Transactions, 42 
TCP/IP ATM Configuration, 42, 70, 71, 72 

TCP/IP Monitoring, 42, 70, 75 

IRIS Configurator Files Menu 

Disk Usage, 43, 90, 92 

IRIS Configurator Site Data Menu 

Com Ports, 43, 88, 89, 136 
Modem, 43 
Site ID, 43 
Site Maps, 43 
Software Version Info, 85 
Version Info, 43, 85 

IRIS Configurator Video Menu 

Video Timing, 42 

IRIS DVS Application, 98 

Access, 99 

IRIS DVS Server, 95 

IRIS DVS Service, 97 

Start and Stop, 97 

IRIS Inquiry, 43, 45, 77, 85, 93 

IRIS Scheduler, 60 

IRIS Status Function Menu 

Print, 42, 64, 66, 70, 71, 72 

IRIS symbol descriptions.vsd, 141 

IRISstandards.vsd, 141 

IRISstencil.vss, 141 

L 
LAN, 13, 162, 165 

Last View, 42, 45, 51 

Local Access, 37 

Lumin Compensation, 53 

M 
MAC Address, 158 

Minimum Transaction Age, 91 
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Modem, 86, 162 

Set Number of Rings, 86 

Monitor Illumination, 46, 50 

Monitored 

Data Ports, 83 
Video Ports, 83 

Motion Detect, 46 

Percent Change, 46 
Sensitivity, 122 
Sensitivity Test, 122 
Show Motion, 122 

Motion Masking, 126 

Multi-Drop ATM Operation, 185 

N 

Net Monitor, 64 

Network, 15, 23, 35, 36, 136, 162, 165 

Network Monitoring, 64, 73 

Dynamic IP Address, 158 

O 

Off Period, 60 

On Period, 60 

P 

Pause Live Display, 127 

Percentage Change, 46 

Phone Report, 79 

Pixel Change, 53, 54 

Pixel Delta, 53, 54 

Plenum Cable, 163 

Point-to-Point ATM Operations, 188 

Port 

Assignment, 45 

Configuration, 45, 47, 51 
Number, 75 

Position Cameras, 96 

Print 

Field, 70, 71, 72 
Transaction Events, 64 

Problem Solving, 130 

Q 
Quick Reference, 132 

R 

RAID 

Mirroring, 152 

Receipt Display, 67, 70 

Record Activity 

Show, 124 

Red Circle, 125 

Remote 

Access, 40 
Monitoring, 43, 83, 84 

Report 

Disk Failure, 78 
Illumination Alarms, 78 
Power-up, 78 
Reboot, 78 
VEM Failure, 78 
Video Failures, 78 

Reserved Disk Space, 90 

Ribbon Cable, 135, 163 

RJ 11, 23 

RJ 45, 24, 136, 163 

Router, 23, 136, 161, 163 
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S 

Schedule by Day and Hour, 62 

Serial Port, 136 

Service vs. Application, 97 

Set 

DVS Time and Date, 134 
Illumination Monitoring, 50 
System Configuration, 133 

Set-up 

Activity Log, 93 
Network Addressing and Protocol, 35 
Status Log, 94 
Synchronous SDLC/HDLC, 188 

Show 

Record Activity, 124 
Video Resolution, 55 

Sign Camera, 163 

Silver Satin, 135, 136, 139, 161, 163 

Site 

Identification, 84 
Installation Requirements, 19 
Map, 43, 95, 96, 141, 142 
Map, 141 

Site Map 

Configuration, 95 
Copy to NT Directory, 145 
Create, 142 
Sample Files, 141 
Save, 144 
Viewing, 145 

Sitemap.vsd, 141, 142 

Standard Camera Names, 146 

Start DVS, 132 

Start Local Application, 99 

Status Logs, 43 

Set-up, 94 

Stop 

Bank IRIS_NT, 133 

Submenus 

ATM Setup, 173 

Subnet Mask, 35, 163 

Surveillance Camera, 164 

Surveillance Cameras, 26, 80, 111 

Power, 136 

Surveillance Schedule, 43, 60 

Synchronous SDLC/HDLC 

Multi-Drop, 185 
Point-to-Point, 188 

System 

Configuration, 33 
Specifications, 15 
Troubleshooting, 129 

System Alarms, 77, 79 

System Health, 43, 90 

System Parameters 

Surveillance Camera, 45 

System Status, 100 

Show Attached Users, 100 
Show Change in Image, 100 
Show TCP/IP Adapter, 100 
Show TCP/IP Port Status, 100 

System Testing, 111 

T 

TCP/IP 

ATM Configuration, 42, 71, 72 
ATM Configuration, 70 
ATM Configuration, 70 
Network Monitoring, 73 
Transaction Monitoring, 75 

Technical Support, 137 
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After-Hours, 137 
Email, 138 
Fax, 137 
Internet, 138 
Manuals, 138 
Telephone, 137 
Updates, 138 

Teller Configuration Files, 153 

Branch Number, 156 
Condition Strings, 154 
Destination Ports, 153 
EBCDIC vs. ASCII, 153 
File Contents, 153 
Filename, 153 
Identification, 153 
Minimum Data Length, 157 
Printable, 157 
Required Number, 157 
Sequence Location, 154 
TCP/IP Source, 153 
Teller Location, 155 
Text Location, 155 

Touch Screen, 164 

Tower Camera, 136, 164 

Transaction Cameras, 111 

Transaction Number Source, 70 

Camera Field, 70, 71, 72, 73 
Print Field, 70, 71, 72, 73 

Transaction Protocol, 64, 65, 66 

Transaction Set-up, 65 

Transaction Tests, 111 

Trigger Sequence, 64 

U 
UPS, 16, 19, 22, 136, 164 

Installation, 22 

User Interface, 41 

V 
VEM, 24, 78, 88, 164 

Slave, 88 

Version Control 

Information, 85 

Video Expansion Multiplexer, 24, 164 

Video Parameters, 57 

Video Recovery Time, 42 

Video Resolution 

Set, 55 
Show, 55 

Video Sync Time, 42 

Video Timing, 42 

Visio, 14, 141, 143 

W 
WAN, 161, 162, 165 

Wide Dynamic Range, 165 

X 

XP Embedded System, 101 

Exit Maintenance, 106 
Inquiry IRIS, 104 
IRIS Application, 104 
LAN Settings, 107 
Maintenance, 102 
System Reboot, 108 
System Shut-Down, 109 
Unit Shut-Down, 108 
Upgrade Software, 105 

 


